Closed Bug 1289670 Opened 4 years ago Closed 4 years ago

Flash ask to activate does not work on areena.yle.fi

Categories

(Core :: Plug-ins, defect)

50 Branch
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox49 --- unaffected
firefox50 + fixed

People

(Reporter: 6lobe, Assigned: blassey)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: nightly-community)

Attachments

(1 file)

Firefox does not offer to activate Flash when trying to watch videos on YLE Areena after bug 1186948 landed.

Test: http://areena.yle.fi/1-2037581
Blocks: 1186948
Keywords: regression
Whiteboard: nightly-community
[Tracking Requested - why for this release]: Regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(blassey.bugs)
Tracking 50+ for this ask to activate regression.
This is checking navigator.mimetypes instead of navigator.plugins. I thought this case was covered, but apparently not. Will dig in further
Flags: needinfo?(blassey.bugs)
Attached patch mimeTypes.patchSplinter Review
Assignee: nobody → blassey.bugs
Attachment #8775337 - Flags: review?(blassey.bugs)
Attachment #8775337 - Flags: review?(blassey.bugs) → review?(mrbkap)
Attachment #8775337 - Flags: review?(mrbkap) → review+
Pushed by blassey@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/312eafb1465b
Show plugin activation icon when navigator.mimetypes is queried r=mrbkap
https://hg.mozilla.org/mozilla-central/rev/312eafb1465b
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
This is still an issue.
Blocks: 1290474
This is indeed still reproducible (50.0b4-build1), if I got this right from the information available here and in Bug 1290474.

With Flash set to "Ask to Activate" from about:addons#plugins, http://areena.yle.fi/1-2037581 is _not_ displaying the expected infobar (i.e. Allow <url> to run "Adobe Flash"? | Continue Blocking | Allow...) and it's also _not_ displaying the plug-in icon in the Location Bar.

Clicking the play button will instead display the "Activate Adobe Flash." overlay instead.
Blocks: 1277346
You need to log in before you can comment on or make changes to this bug.