Flash ask to activate does not work on areena.yle.fi

RESOLVED FIXED in Firefox 50

Status

()

--
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: 6lobe, Assigned: blassey)

Tracking

(Blocks: 1 bug, {regression})

50 Branch
mozilla50
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 unaffected, firefox50+ fixed)

Details

(Whiteboard: nightly-community)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Firefox does not offer to activate Flash when trying to watch videos on YLE Areena after bug 1186948 landed.

Test: http://areena.yle.fi/1-2037581
(Reporter)

Updated

2 years ago
Blocks: 1186948
Keywords: regression
Whiteboard: nightly-community
[Tracking Requested - why for this release]: Regression
Status: UNCONFIRMED → NEW
status-firefox49: --- → unaffected
status-firefox50: --- → affected
tracking-firefox50: --- → ?
Ever confirmed: true
Flags: needinfo?(blassey.bugs)
Tracking 50+ for this ask to activate regression.
tracking-firefox50: ? → +
This is checking navigator.mimetypes instead of navigator.plugins. I thought this case was covered, but apparently not. Will dig in further
Flags: needinfo?(blassey.bugs)
Created attachment 8775337 [details] [diff] [review]
mimeTypes.patch
Assignee: nobody → blassey.bugs
Attachment #8775337 - Flags: review?(blassey.bugs)
(Assignee)

Updated

2 years ago
Attachment #8775337 - Flags: review?(blassey.bugs) → review?(mrbkap)
Attachment #8775337 - Flags: review?(mrbkap) → review+

Comment 5

2 years ago
Pushed by blassey@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/312eafb1465b
Show plugin activation icon when navigator.mimetypes is queried r=mrbkap

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/312eafb1465b
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
This is indeed still reproducible (50.0b4-build1), if I got this right from the information available here and in Bug 1290474.

With Flash set to "Ask to Activate" from about:addons#plugins, http://areena.yle.fi/1-2037581 is _not_ displaying the expected infobar (i.e. Allow <url> to run "Adobe Flash"? | Continue Blocking | Allow...) and it's also _not_ displaying the plug-in icon in the Location Bar.

Clicking the play button will instead display the "Activate Adobe Flash." overlay instead.
You need to log in before you can comment on or make changes to this bug.