Flash ask to activate does not work on areena.yle.fi

RESOLVED INVALID

Status

()

Core
Plug-ins
--
major
RESOLVED INVALID
2 years ago
7 months ago

People

(Reporter: smaug, Unassigned)

Tracking

({regression})

50 Branch
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 unaffected, firefox48 unaffected, firefox49 unaffected, firefox50 affected, firefox51 affected)

Details

(Whiteboard: nightly-community)

(Reporter)

Description

2 years ago
[Tracking Requested - why for this release]:

+++ This bug was initially created as a clone of Bug #1289670 +++

Firefox does not offer to activate Flash when trying to watch videos on YLE Areena after bug 1186948 landed.

Test: http://areena.yle.fi/1-2037581

Now Areena asks one to update Flash, if Ask To Activate is enabled
(Reporter)

Comment 1

2 years ago
...but updating doesn't help.

But if Flash is always activated, Areena works fine.
(Reporter)

Updated

2 years ago
Flags: needinfo?(blassey.bugs)
The plugin icon appears in the address bar for me (i.e. this is working as expected). Are you seeing differently?

Side note, I'm working on replacing "update/install flash" banners in bug 1289802.
Flags: needinfo?(blassey.bugs) → needinfo?(bugs)

Comment 3

2 years ago
The hanger does not appear but the plugin activation icon does.
How to display a doorhanger without regressing bug 1289496?
(Reporter)

Comment 5

2 years ago
FWIW, I submitted this bug in favor for a friend who said Flash with ask-to-activate doesn't work anymore with Nightly. And then I also tested, and couldn't get flash working.
Perhaps there was some way to enable Flash, but at least two tech-savvy FF users couldn't immediately understand how.
Earlier there was a doorhanger showing that Flash could be enabled.
Flags: needinfo?(bugs)
(In reply to Masatoshi Kimura [:emk] from comment #4)
> How to display a doorhanger without regressing bug 1289496?

We could display the door hanger when we detect a "install flash" banner in bug 1289802.
(In reply to Brad Lassey [:blassey] (use needinfo?) from comment #6)
> (In reply to Masatoshi Kimura [:emk] from comment #4)
> > How to display a doorhanger without regressing bug 1289496?
> 
> We could display the door hanger when we detect a "install flash" banner in
> bug 1289802.

Then again if we're successfully replacing those banners with CTP UI, the door hanger might be overkill
status-firefox47: --- → unaffected
status-firefox48: --- → unaffected
status-firefox49: --- → unaffected
status-firefox51: --- → affected
tracking-firefox51: --- → ?
What are we going to do here?
Flags: needinfo?(blassey.bugs)
This is working as expected showing the plugin icon in the address bar. I think this is won't fix.

If the icon isn't obvious enough for people, replacing the install flash content (bug 1289802) should improve that.
Flags: needinfo?(blassey.bugs)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
Not tracking for 50/51.
tracking-firefox50: ? → ---
tracking-firefox51: ? → ---
(In reply to Olli Pettay [:smaug] from comment #5)
> at least two tech-savvy FF
> users couldn't immediately understand how.
> Earlier there was a doorhanger showing that Flash could be enabled.

Make that three. Plus the filers of other bugs since then. This UI is awfully well hidden and has led sites like deezer.com to direct users to change the setting to "Active Everywhere".
You need to log in before you can comment on or make changes to this bug.