Closed Bug 1290167 Opened 3 years ago Closed 2 years ago

[e10s-multi] New tab always triggers the tab spinner

Categories

(Firefox :: New Tab Page, defect, P3)

x86
Windows 7
defect

Tracking

()

RESOLVED DUPLICATE of bug 1384290
Tracking Status
firefox50 --- affected

People

(Reporter: jimm, Unassigned)

References

Details

(Whiteboard: [e10s-multi:-])

STR:

1) set processCount to 5
2) enable the activity test pilot experiment
2) Open a series of new tabs

result: I always see the tab spinner briefly (about a second) before new tab content starts to fill in.
Flags: needinfo?(gkrizsanits)
I could not reproduce this on windows 10 with the latest nightly. What I've experienced is the spinner in the tab header in the tab bar, so it seems like there is no preloaded tab with this experiment on. But could not see the spinner in the content area, nor did I see any difference between e10s and e10s multi. Do you have some kind of special, custom sandboxing enabled that might slow down the content process startup?
Flags: needinfo?(gkrizsanits)
Flags: needinfo?(jmathies)
Nope, default nightly settings.

Test pilot  no longer shows up in my UI so I can't go back and test now.
Flags: needinfo?(jmathies)
Assignee: nobody → mrbkap
Whiteboard: [e10s-multi:?] → [e10s-multi:M1]
From some initial testing, it's looking like the new content process is taking forever and a day to start up (and then Activity Stream takes even longer). I'll try to get some profiles on an opt build in the next week or so. I'm not sure any more if we should block M1 on this.
Essentially same as bug 1304393.
Opening anything visible of new remote content process has always shown me the spinner (since it was added, for about a second.) Luckily I stick to opening first regular new tab pages most of the time (if not opening background tab.)
No longer blocks: 1303113
Depends on: 1324428
Whiteboard: [e10s-multi:M1] → [e10s-multi:?]
Whiteboard: [e10s-multi:?] → [e10s-multi:+]
- because this is sdk related.
No longer blocks: e10s-multi-aurora
Whiteboard: [e10s-multi:+] → [e10s-multi:-]
Component: Activity Streams: Newtab → Activity Streams: General
Priority: -- → P3
Assignee: mrbkap → nobody
Component: Activity Streams: General → Activity Streams: Newtab
Test pilot version with sdk is no more but sounds similar to bug 1384290.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1384290
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.