Note: There are a few cases of duplicates in user autocompletion which are being worked on.
Bug 1304546 (e10s-multi-aurora)

[meta] Turn e10s-multi on in Aurora-DevEdition

RESOLVED FIXED in Firefox 54

Status

()

Core
General
RESOLVED FIXED
10 months ago
3 months ago

People

(Reporter: mrbkap, Assigned: krizsa)

Tracking

(Depends on: 6 bugs, Blocks: 1 bug)

Trunk
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 wontfix, firefox53 wontfix, firefox54 fixed, firefox55 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
This is a placeholder bug to turn e10s-multi on (for some number of processes to be determined at a later date) in Aurora.
(Reporter)

Updated

10 months ago
Blocks: 1304547
(Assignee)

Updated

7 months ago
Depends on: 1307511
(Assignee)

Updated

6 months ago
Depends on: 1289723
(Assignee)

Updated

6 months ago
Depends on: 1324428
Depends on: 1333914
(Reporter)

Updated

6 months ago
Depends on: 1231208
(Reporter)

Updated

6 months ago
Depends on: 1284201
(Reporter)

Updated

6 months ago
Depends on: 1285888
(Reporter)

Updated

6 months ago
Depends on: 1272113
(Reporter)

Updated

6 months ago
Depends on: 1306458
(Reporter)

Updated

6 months ago
Depends on: 1315042
(Reporter)

Updated

6 months ago
Alias: e10s-multi-aurora
(Reporter)

Updated

6 months ago
Depends on: 1333798
(Reporter)

Updated

6 months ago
Depends on: 1333799
(Assignee)

Updated

6 months ago
Depends on: 1336389
(Assignee)

Updated

6 months ago
Depends on: 1336398
(Reporter)

Updated

5 months ago
Depends on: 1337778
(Assignee)

Updated

5 months ago
Depends on: 1340512
(Assignee)

Updated

5 months ago
Depends on: 1334716
(Reporter)

Updated

5 months ago
Depends on: 1290167
(Reporter)

Updated

5 months ago
Depends on: 1301015
(Reporter)

Updated

5 months ago
Depends on: 1341008
(Reporter)

Updated

5 months ago
Depends on: 1208957
(Reporter)

Updated

5 months ago
No longer depends on: 1290167
(Reporter)

Updated

5 months ago
Depends on: 1325049

Updated

4 months ago
Depends on: 1352706
(Assignee)

Comment 1

4 months ago
Created attachment 8854045 [details] [diff] [review]
Enable 4 content processes on aurora
Assignee: nobody → gkrizsanits
Attachment #8854045 - Flags: review?(mrbkap)
(Reporter)

Updated

4 months ago
Attachment #8854045 - Flags: review?(mrbkap) → review+
(Reporter)

Comment 2

4 months ago
Comment on attachment 8854045 [details] [diff] [review]
Enable 4 content processes on aurora

Approval Request Comment
[Feature/Bug causing the regression]: e10s-multi
[User impact if declined]: n/a
[Is this code covered by automated tests?]: Yes.
[Has the fix been verified in Nightly?]: Yes.
[Needs manual test from QE? If yes, steps to reproduce]: No.
[List of other uplifts needed for the feature/fix]: We're uplifting as we go.
Attachment #8854045 - Flags: approval-mozilla-aurora?
(Reporter)

Comment 3

4 months ago
Note to sheriffs: this change has no effect on Nightly (we've already enabled e10s-multi on Nightly).

Comment 4

4 months ago
Pushed by gkrizsanits@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a0fce48c63f
Turning on e10s-multi in Aurora. r=mrbkap

Comment 5

4 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5a0fce48c63f
Status: NEW → RESOLVED
Last Resolved: 4 months ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Tweaking the status flags so we won't lose the uplift request
status-firefox52: affected → wontfix
status-firefox53: --- → wontfix
status-firefox54: --- → affected

Comment 7

4 months ago
Comment on attachment 8854045 [details] [diff] [review]
Enable 4 content processes on aurora

Enable e10s-multi on aurora and see how it goes. Aurora54+.
Attachment #8854045 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 8

4 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/29eab893bad0
status-firefox54: affected → fixed
(In reply to Ryan VanderMeulen [:RyanVM] from comment #8)
> https://hg.mozilla.org/releases/mozilla-aurora/rev/29eab893bad0

it seems this is causing leaks like https://treeherder.mozilla.org/logviewer.html#?job_id=88700020&repo=mozilla-aurora 

i did some bisecting in https://hg.mozilla.org/try/rev/110f708df669971abf55dbab23056701e2fbb380 and that try run is entirely green.
gabor, blake: since this is a very important change i guess i we either need to fix or back this change out from aurora
Flags: needinfo?(mrbkap)
Flags: needinfo?(gkrizsanits)
(Assignee)

Comment 11

4 months ago
I'm going to try to fix this in the test, but I wonder why this might be happening only on aurora and not on central...

Sotaro, I think you worked on a similar issue before in bug 1285238, do you know if there is any diversion between aurora and nightly that can cause this leak?

(In reply to Carsten Book [:Tomcat] from comment #9)
> (In reply to Ryan VanderMeulen [:RyanVM] from comment #8)
> > https://hg.mozilla.org/releases/mozilla-aurora/rev/29eab893bad0
> 
> it seems this is causing leaks like
> https://treeherder.mozilla.org/logviewer.html#?job_id=88700020&repo=mozilla-
> aurora 
> 
> i did some bisecting in
> https://hg.mozilla.org/try/rev/110f708df669971abf55dbab23056701e2fbb380 and
> that try run is entirely green.
Flags: needinfo?(gkrizsanits) → needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 12

4 months ago
RyanVM|mtg> gabor, mrbkap: 
3:21 PM https://treeherder.mozilla.org/logviewer.html#?job_id=88717085&repo=mozilla-aurora is also happening frequently on Windows and it wouldn't shock me if it turned out to be the same root issue

Dão, are you aware of any diversion between aurora and nightly that could cause this failure?
Flags: needinfo?(dao+bmo)
(In reply to Gabor Krizsanits [:krizsa :gabor] from comment #12)
> RyanVM|mtg> gabor, mrbkap: 
> 3:21 PM
> https://treeherder.mozilla.org/logviewer.html#?job_id=88717085&repo=mozilla-
> aurora is also happening frequently on Windows and it wouldn't shock me if
> it turned out to be the same root issue
> 
> Dão, are you aware of any diversion between aurora and nightly that could
> cause this failure?

Nope... redirecting to Florian who wrote this test and the feature being tested.
Flags: needinfo?(dao+bmo) → needinfo?(florian)
Let's move the leak discussion over to bug 1347625, which I believe is the same root cause. Regarding the Windows failures in browser_devices_get_user_media_anim.js, I believe Gabor is still investigating.
Flags: needinfo?(sotaro.ikeda.g)
Flags: needinfo?(mrbkap)
Flags: needinfo?(florian)

Updated

4 months ago
Depends on: 1353910
(Reporter)

Updated

3 months ago
No longer depends on: 1352706
You need to log in before you can comment on or make changes to this bug.