Closed Bug 1291192 Opened 5 years ago Closed 1 year ago

Add console filtering support for "-" exclusion operator

Categories

(DevTools :: Console, enhancement, P3)

47 Branch
enhancement

Tracking

(firefox73 fixed)

RESOLVED FIXED
Firefox 73
Tracking Status
firefox73 --- fixed

People

(Reporter: 709922234, Assigned: Harald)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete)

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160606114208
Component: Untriaged → Developer Tools: Console
Summary: Console support "-" operator or regex → Console filtering support "-" operator or regex
Status: UNCONFIRMED → NEW
Depends on: enable-new-console
Ever confirmed: true
Priority: -- → P3
For clarification, prepending the filter string with "-" should invert the filter, meaning every message that does *not* match the entered string.
The "-" operator should also work together with filtering tags requested in bug 1420689.

I've split out the regex filter option to bug 1441079, so this one can focus on the negation operator.

Sebastian
Severity: normal → enhancement
See Also: → 1420689, 1441079
Summary: Console filtering support "-" operator or regex → Add console filtering support for "-" operator
See Also: → 1441082
Product: Firefox → DevTools
Duplicate of this bug: 1533146
Summary: Add console filtering support for "-" operator → Add console filtering support for "-" exclusion operator

TIL Network panel filtering already supports this.

Assignee: nobody → hkirschner
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c6f80ffff41b
Exclude-mode filtering for Console r=nchevobbe
Flags: needinfo?(hkirschner)
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b4eea71fe5b1
Exclude-mode filtering for Console r=nchevobbe

Backed out changeset c6f80ffff41b (bug 1291192) for causing browser_webconsole_filter_by_regex_input.js to permafail

This was readded to the patch list after being backed out for some reason.

https://hg.mozilla.org/integration/autoland/rev/6c0c0cabf1cfae290a7e43a74011b735f5a4de12

Attachment #9114787 - Attachment is obsolete: true
Pushed by hkirschner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/38c72e42d480
Exclude-mode filtering for Console (v2) r=nchevobbe

Clearing ni?

Flags: needinfo?(hkirschner)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73
You need to log in before you can comment on or make changes to this bug.