Closed Bug 1291683 Opened 6 years ago Closed 6 years ago

[Narrate] Clicking play/stop multiple times will make narrator panel close when reading will jump to the next page

Categories

(Toolkit :: Reader Mode, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox48 --- affected
firefox49 --- affected
firefox50 --- affected
firefox51 --- affected

People

(Reporter: bogdan_maris, Unassigned)

Details

(Keywords: regressionwindow-wanted)

Attachments

(1 file)

[Affected versions]:
- Firefox 49 beta 1
- Firefox 48 beta 9
- Latest Developer Edition 50.0a2
- Latest Nightly 51.0a1

[Affected platforms]:
- Ubuntu 16.04 32-bit
- Mac OS X 10.9.5
- Windows 7 64-bit
- Windows 10 32-bit

[Steps to reproduce]:
1. Start Firefox
2. Visit a page with multiple pages in reader mode
(eg: http://www.bbc.com/travel/story/20160801-living-in-the-worlds-most-reputable-countries)
3. Enter reader mode
4. Click on Narrator button
5. Click Play/Pause multiple times

[Expected result]:
- Narrator panel is not dismissed only if user clicks outside of the panel.

[Actual result]:
- Narrator panel is closed when narration switches to a page.
(this may require multiple times to reproduce)

[Regression range]:
- Not sure if this is a regression, will search for one asap.

[Additional notes]:
- Screencast showing the issue attached.
I'm having a hard time reproducing what you see. I think it is because narrate is not in play state when it scrolls, and it will automatically close in that case. The actual scroll is being done by narrate to go to the next paragraph. So it is in an interesting state where narrate is not playing anymore, but the scroll from the previous play makes the dialog go away.

In any case, this issue will go away along with bug 1255261 because stop/play will no longer advance the currently read paragraph.
I'm probably going to mark this as WORKSFORME once bug 1255261 is resolved.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.