Inspect element action does not work correctly while RDM is enabled

VERIFIED FIXED in Firefox 51

Status

P1
normal
VERIFIED FIXED
2 years ago
5 months ago

People

(Reporter: mboldan, Assigned: jryans)

Tracking

51 Branch
Firefox 51
Dependency tree / graph

Firefox Tracking Flags

(firefox48 unaffected, firefox49 unaffected, firefox50 unaffected, firefox51 verified)

Details

(Whiteboard: [multiviewport] [reserve-rdm])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8777797 [details]
inspect element.mov

[Affected versions]:
- Firefox 51.0a1 (2016-08-03)

[Affected platforms]:
- Windows 10 x64, Mac OS X 10.11.1, Ubuntu 16.04 x64

[Steps to reproduce]:
1. Launch Firefox.
2. From about:config, enable the devtools.responsive.html.enabled pref.
3. Open RDM.
4. Enable Toggle tools.
5. Right click on an element from the page and select the 'Inspect Element' option.

[Expected result]:
- The details of the selected element are displayed in the Inspector.

[Actual result]:
- The inspected element is not selected in the HTML tree (see the attached screencast). 

[Regression range]:
- This is not a regression.
(Reporter)

Updated

2 years ago
QA Whiteboard: [qe-rdm]

Updated

2 years ago
Flags: qe-verify+
Priority: -- → P3
Whiteboard: [multiviewport] [triage] → [multiviewport] [reserve-rdm]
(Assignee)

Updated

2 years ago
status-firefox51: affected → fix-optional
(Assignee)

Updated

2 years ago
Blocks: 1296498
(Assignee)

Updated

2 years ago
Assignee: nobody → jryans
Status: NEW → ASSIGNED

Updated

2 years ago
Iteration: --- → 51.2 - Aug 29
Priority: P3 → P1
Comment hidden (mozreview-request)
(Assignee)

Updated

2 years ago
Depends on: 1297569
(Assignee)

Comment 3

2 years ago
This work depends on the change in bug 1297569, so you'll need to apply that patch as well (if you want to test during review).

Comment 4

2 years ago
mozreview-review
Comment on attachment 8785343 [details]
Bug 1292133 - Add contextmenu tunnelling for inspect element.

https://reviewboard.mozilla.org/r/74584/#review72788

I really appreciate such patch to review after having to review patches to like bug 1297362 ;)

Note that Inspect element still appear when right clicking within RDM document and fails with "Permission denied to access property "ownerDocument""
you might want to disable the context menu entry or something?
Attachment #8785343 - Flags: review?(poirot.alex) → review+
(Assignee)

Comment 5

2 years ago
mozreview-review-reply
Comment on attachment 8785343 [details]
Bug 1292133 - Add contextmenu tunnelling for inspect element.

https://reviewboard.mozilla.org/r/74584/#review72788

> Note that Inspect element still appear when right clicking within RDM document and fails with "Permission denied to access property "ownerDocument""
you might want to disable the context menu entry or something?

Hmm, thanks for pointing this out!  I think I'll defer this to bug 1278762 (the more general "context menu doesn't really work" bug).  There isn't really a simple way to disable just this one item in this specific context.  Over in that bug, I might make my own context menu with just the few things that work...?  Unsure so far.

Comment 6

2 years ago
Pushed by jryans@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f91a4cdf2718
Add contextmenu tunnelling for inspect element. r=ochameau

Updated

2 years ago
Iteration: 51.2 - Aug 29 → 51.3 - Sep 12

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f91a4cdf2718
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox51: fix-optional → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
(Assignee)

Updated

2 years ago
Depends on: 1300103
(Reporter)

Comment 8

2 years ago
The issue is no longer reproducible on Firefox 51.0a1 (2016-09-13), using the STR from Comment 0.
The tests were performed under Windows 10x64, Mac OS X 10.11.1 and under Ubuntu 16.04x64.
I am marking this issue Verified Fixed.
Status: RESOLVED → VERIFIED
status-firefox51: fixed → verified
Flags: qe-verify+

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.