Intermittent file:///builds/slave/test/build/tests/jsreftest/tests/jsreftest.html?test=ecma_6/TypedArray/every-and-some.js and every other test | application terminated with exit code 5

RESOLVED FIXED

Status

()

Core
JavaScript Engine
P3
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({intermittent-failure})

unspecified
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox49 unaffected, firefox50 fixed, firefox51 fixed)

Details

All recent bugs with "application terminated with exit code 5" seem to be the same issue, that was previously categorized as bug 1285465.

I triggered jsreftest on more revisions:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-searchStr=jsref%20osx%20opt&tochange=87c0b92cae4244ff7f0156f1fc90cb161f9243e9&fromchange=45312f91ab910ed9c646da50baba3a09415abe8f

and it looks like it started from bug 1119537
https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=c23ff1725f56734958eb2978040ab36f278a6063&filter-searchStr=jsref%20osx%20opt

terrence, do you have any idea?
(or should I trigger more runs?)
Flags: needinfo?(terrence)
See Also: → bug 1119537, bug 1285465
It's nice to know this reproduces jstestbrowser. I'll try to get it in a debugger today.
Duplicate of this bug: 1292420
Duplicate of this bug: 1292487
Duplicate of this bug: 1292758
Duplicate of this bug: 1292825
Duplicate of this bug: 1292927
Duplicate of this bug: 1292947
Duplicate of this bug: 1292980
Duplicate of this bug: 1293083
Duplicate of this bug: 1293084
Duplicate of this bug: 1293138
Duplicate of this bug: 1293183
Duplicate of this bug: 1293265
Duplicate of this bug: 1293351
Duplicate of this bug: 1293413
Duplicate of this bug: 1293629
Duplicate of this bug: 1293826
Duplicate of this bug: 1293851
Duplicate of this bug: 1293864
Duplicate of this bug: 1293882
Duplicate of this bug: 1293900
Duplicate of this bug: 1293905
Duplicate of this bug: 1293914
Duplicate of this bug: 1293920
Duplicate of this bug: 1294051
Duplicate of this bug: 1294163
Duplicate of this bug: 1294252
I can reproduce easily in the shell on c23ff1725f56, but not on tip. Nick has recently switched us over from NSPR threads to std:: polyfills and I expect something in there has fixed the issue. I'll try to bisect it.
Summary: Intermittent file:///builds/slave/test/build/tests/jsreftest/tests/jsreftest.html?test=ecma_6/TypedArray/every-and-some.js | application terminated with exit code 5 → Intermittent file:///builds/slave/test/build/tests/jsreftest/tests/jsreftest.html?test=ecma_6/TypedArray/every-and-some.js and every other test | application terminated with exit code 5
Duplicate of this bug: 1294850
Duplicate of this bug: 1294852
Duplicate of this bug: 1296131

Comment 33

2 years ago
37 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 25
* mozilla-inbound: 7
* mozilla-central: 3
* fx-team: 2

Platform breakdown:
* linux64: 18
* osx-10-10: 11
* windows7-32-vm: 4
* windows7-32: 3
* android-4-3-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1292324&startday=2016-08-15&endday=2016-08-21&tree=all

Comment 34

2 years ago
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
These seem to have gone away when Jon found the missing signal.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(terrence)
Resolution: --- → FIXED
status-firefox49: --- → unaffected
status-firefox50: --- → fixed
status-firefox51: --- → fixed
Depends on: 1288579
You need to log in before you can comment on or make changes to this bug.