[e10s] Firefox Nightly Can't load Gzipped files

RESOLVED FIXED in Firefox 50

Status

()

Core
Networking: HTTP
P2
normal
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: cade, Assigned: dragana)

Tracking

({nightly-community, regression})

50 Branch
mozilla51
nightly-community, regression
Points:
---

Firefox Tracking Flags

(e10s+, firefox48 unaffected, firefox49 unaffected, firefox50- fixed, firefox51 fixed)

Details

(Whiteboard: [necko-active])

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8778283 [details]
Screenshot from 2016-08-05 10-57-19.png

Firefox Nightly (51, updated on the mornging of August 5th 2016) Appears to have become incapable of loading GZipped files.

STR:
 
1. Using the version of nightly above visit: https://d2rqpywgspga97.cloudfront.net/static/53253f8/css/b8611c350d3c.css.gz
2. Notice that the CSS file is just garbled text.

If you do the same in stable or another browser, it should be decompressed into valid CSS

I included a screenshot - Nightly is on the left, Firefox 47 running on the right.
I'm also experiencing this.

Gonna hunt down a regression range.
Flags: needinfo?(mconley)
Keywords: regression, regressionwindow-wanted
This works for me with latest Nightly builds:

Win7: Nightly 51.0a1, 20160805030444
Mac 10.11: Nightly 51.0a1, 20160805030444
Ubuntu 14.04: Nightly 51.0a1, 20160805030444

Chris, can you reproduce in safemode?
Interestingly, I can't reproduce this with a clean profile, so there's something about our configuration that's exposing this.

Anyhow, I used my default profile to regression-hunt, and drilled it down to:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d22b099cf1e312edf24adc27dd23541b37900cfe&tochange=e1f3ed984607e209ab9ba3a4892b58d3d03b9430

Bug 1261585 looks like the obvious suspect.

Hey Dragana, any idea what's going on? I'll post my about:support in a sec.
status-firefox48: --- → unaffected
status-firefox49: --- → unaffected
status-firefox50: --- → affected
status-firefox51: --- → affected
tracking-e10s: --- → ?
Flags: needinfo?(mconley) → needinfo?(dd.mozilla)
Summary: Firefox Nightly Can't load Gzipped files → [e10s] Firefox Nightly Can't load Gzipped files
Application Basics
------------------

Name: Firefox
Version: 51.0a1
Build ID: 20160805030444
Update Channel: nightly
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
OS: Windows_NT 6.1
Multiprocess Windows: 1/1 (Enabled by user)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

Report ID: bp-c443af47-1dac-4416-82dd-1f2302160805
Submitted: 2 hours ago

Report ID: bp-d5d08c3c-2a6f-474c-afc1-543e02160805
Submitted: 3 hours ago

All Crash Reports

Extensions
----------

Name: Activity Stream
Version: 1.1.1
Enabled: true
ID: @activity-streams

Name: Chrome Store Foxified
Version: 2.2
Enabled: true
ID: Chrome-Store-Foxified@jetpack

Name: Cycle Collector Graph Analyzer, about:cc
Version: 0.0.1
Enabled: true
ID: cycle.collector.graph.analyzer@pettay.fi

Name: Differo
Version: 0.3.2
Enabled: true
ID: differo@grigory.ca

Name: DOM Inspector
Version: 2.0.16.1-signed
Enabled: true
ID: inspector@mozilla.org

Name: Emoji Cheatsheet for GitHub, Basecamp etc.
Version: 1.2.0
Enabled: true
ID: jid1-Xo5SuA6qc1DFpw@jetpack

Name: Fangs
Version: 1.0.8.1-signed.1-signed
Enabled: true
ID: {21D01944-2878-4eb3-A72A-83E8D1E6D4A6}

Name: FlyWeb
Version: 1.0.0
Enabled: true
ID: flyweb@mozilla.org

Name: Imgur Uploader
Version: 1.0.6.1-signed
Enabled: true
ID: giorgio@gilestro.tk

Name: Mass Password Reset
Version: 1.05.1-signed.1-signed
Enabled: true
ID: masspasswordreset@johnathan.nightingale

Name: Mozilla Tree Status
Version: 1.0.2
Enabled: true
ID: mozilla-tree-status@jsantell.com

Name: Multi-process staged rollout
Version: 1.0
Enabled: true
ID: e10srollout@mozilla.org

Name: No More 404s
Version: 1.5.3
Enabled: true
ID: wayback_machine@mozilla.org

Name: No Twitter Moments
Version: 1.1
Enabled: true
ID: no-twitter-moments@mikeconley.ca

Name: Pocket
Version: 1.0.4
Enabled: true
ID: firefox@getpocket.com

Name: RB DoubleClick
Version: 0.0.1
Enabled: true
ID: rb-doubleclick@mikeconley.ca

Name: Reviewboard Collapser
Version: 1.0
Enabled: true
ID: reviewboard-collapser@webextensions

Name: Statuser
Version: 0.1.4
Enabled: true
ID: @statuser

Name: tab-crasher
Version: 0.1.1-signed.1-signed
Enabled: true
ID: jid1-KrxrrWKPOoE4Mw@jetpack

Name: Test Pilot
Version: 0.8.3-tag-2016-07-29
Enabled: true
ID: @testpilot-addon

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Name: wontfix
Version: 1.0
Enabled: true
ID: jid1-SDCOUnA2RvYHFg@jetpack

Name: 'Sup Son
Version: 0.1.1
Enabled: false
ID: @sup-son

Name: about:addons-memory
Version: 10.1-signed.1-signed
Enabled: false
ID: about-addons-memory@tn123.org

Name: Add-on Compatibility Reporter
Version: 2.1.1
Enabled: false
ID: compatibility@addons.mozilla.org

Name: australis-bugzilla-widget
Version: 0.1
Enabled: false
ID: jid1-Z6r2SFr66RSx4Q@jetpack

Name: Beyond Australis
Version: 1.4.6
Enabled: false
ID: thefoxonlybetter@quicksaver

Name: Bugzilla Tweaks
Version: 1.12.1.1.1-signed.1-signed.1-signed
Enabled: false
ID: jid0-qBnIpLfDFa4LpdrjhAC6vBqN20Q@jetpack

Name: Buttons Back
Version: 8.1-signed.1-signed
Enabled: false
ID: buttonsback@darktrojan.net

Name: Change Max Rows of Autocomplete In URL Bar
Version: 1.4.1-signed.1-signed
Enabled: false
ID: jid0-PTmUBsaKAokPOYNMcrQbssRkn7Y@jetpack

Name: Check4Change
Version: 1.9.8.1
Enabled: false
ID: check4change-owner@mozdev.org

Name: Context Search Compact
Version: 0.1.0
Enabled: false
ID: context-search-compact@2k1dmg.org

Name: Counter for Mozilla's End of Year Fundraising
Version: 0.0.5
Enabled: false
ID: mofofuraco@archaeopteryx

Name: Cycle Collector Analyzer, about:ccdump
Version: 0.4.3.1-signed.1-signed
Enabled: false
ID: ccdump@getfirebug.com

Name: DevEdition theme enabler
Version: 1.0
Enabled: false
ID: devedition-theme-enabler@tim-addons.com

Name: dontbeevil
Version: 1.1.1.1-signed.1-signed
Enabled: false
ID: jid0-uKv2BxxWlXSDahl79DjVU4yqsvY@jetpack

Name: Drumpfinator
Version: 1.0
Enabled: false
ID: drumpfinator@xulforge.com

Name: Feature Recommender
Version: 0.1.0
Enabled: false
ID: cfr-moz@insights.mozilla.org

Name: feedly
Version: 16.0.528.1-signed.1-signed
Enabled: false
ID: feedly@devhd

Name: Firefox Interest Dashboard
Version: 0.9.1.1-signed.1-signed
Enabled: false
ID: firefox.interest.dashboard@up.mozilla

Name: FireGestures
Version: 1.10.11
Enabled: false
ID: firegestures@xuldev.org

Name: geckoprofiler
Version: 1.16.16
Enabled: false
ID: jid0-edalmuivkozlouyij0lpdx548bc@jetpack

Name: Ghostery
Version: 6.3.1
Enabled: false
ID: firefox@ghostery.com

Name: GitHub Extension Installer
Version: 1.7.0
Enabled: false
ID: {86054B0A-BD85-42F9-8E58-8794EC6F6EA1}

Name: Greasemonkey
Version: 3.8
Enabled: false
ID: {e4a8a97b-f2ed-450b-b12d-ee082ba24781}

Name: Heartbleed Monitor
Version: 0.2.1.1-signed.1-signed
Enabled: false
ID: jid1-eMhaOaq3SPBFDg@jetpack

Name: Integrated Google Calendar
Version: 1.5.1
Enabled: false
ID: intgcal@egarracingteam.com.ar

Name: LastPass
Version: 3.3.1
Enabled: false
ID: support@lastpass.com

Name: Lightbeam
Version: 1.3.1
Enabled: false
ID: jid1-F9UJ2thwoAm5gQ@jetpack

Name: Media Hint
Version: 0.1.13.1
Enabled: false
ID: mediahint@jetpack

Name: MemChaser
Version: 0.7.1-signed
Enabled: false
ID: memchaser@quality.mozilla.org

Name: Modify Headers
Version: 0.7.1.1.1-signed.1-signed
Enabled: false
ID: {b749fc7c-e949-447f-926c-3f4eed6accfe}

Name: Muditanist
Version: 0.1.1-signed.1-signed
Enabled: false
ID: jid1-oyNpUQcL3f9kyg@jetpack

Name: New Tab Override (browser.newtab.url replacement)
Version: 3.0
Enabled: false
ID: newtaboverride@agenedia.com

Name: Nicer Bugzilla Comments
Version: 1.4.1.1-signed.1-signed
Enabled: false
ID: jid0-8OJNdDJ6MBHtfB9FElhQ3wt2FMw@jetpack

Name: Noise Control
Version: 16
Enabled: false
ID: jid1-hUBct1DNfZQIeQ@jetpack

Name: NoScript
Version: 2.9.0.13
Enabled: false
ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: Open in Browser
Version: 1.17
Enabled: false
ID: openinbrowser@www.spasche.net

Name: Profilist
Version: 1.2.1-signed
Enabled: false
ID: Profilist@jetpack

Name: Puzzle Bars
Version: 2.1.14
Enabled: false
ID: thePuzzlePiece@quicksaver

Name: Remote XUL Manager
Version: 1.3.2
Enabled: false
ID: remotexulmanager@xulforge.com

Name: Restartless Restart
Version: 9.1-signed.1-signed
Enabled: false
ID: restartless.restart@erikvold.com

Name: Shumway
Version: 0.11.617
Enabled: false
ID: shumway@research.mozilla.org

Name: skiptco
Version: 1.2.1.1-signed.1-signed
Enabled: false
ID: plugin@skiptco.org

Name: SnoozeTabs
Version: 0.1.1
Enabled: false
ID: jid1-snoozetabs@jetpack

Name: Soundcloud Player
Version: 0.9.1-signed.1-signed
Enabled: false
ID: soundcloud-player@mikedeboer.nl

Name: SQLite Manager
Version: 0.8.3.1-signed.1-signed
Enabled: false
ID: SQLiteManager@mrinalkant.blogspot.com

Name: Tab Badge
Version: 2.1
Enabled: false
ID: badge@darktrojan.net

Name: Tab Data
Version: 0.5.10.1
Enabled: false
ID: jid1-4ogjq7MUzAiCOw@jetpack

Name: Tabsmack
Version: 0.5.0
Enabled: false
ID: jid1-CzCFymQL7Znp9g@jetpack

Name: TabSubmit
Version: 1.0.2.4.1-signed.1-let-fixed.1-signed
Enabled: false
ID: {421e87b4-d3d2-49c8-b08f-b83f4dc88444}

Name: TabSubmit Basic
Version: 0.2.1.1-signed.1-signed
Enabled: false
ID: jid1-KR7YJG7ASAuPHQ@jetpack

Name: TART - Tab Animation regression Test
Version: 1.0
Enabled: false
ID: bug848358@mozilla.org">bug848358@mozilla.org

Name: Terms of Service; Didn’t Read
Version: 0.4.1.1-signed.1-signed
Enabled: false
ID: jid0-3GUEt1r69sQNSrca5p8kx9Ezc3U@jetpack

Name: Test Pilot
Version: 1.2.3.4
Enabled: false
ID: testpilot@labs.mozilla.com

Name: test-widget
Version: 0.1
Enabled: false
ID: jid1-ahoQUEjmds0TqQ@jetpack

Name: Textarea Cache
Version: 0.9.3.4
Enabled: false
ID: {578e7caa-210f-4967-a0d3-88fe5b59a39f}

Name: The Addon Bar (restored)
Version: 3.2.9-compat-fixed-4
Enabled: false
ID: the-addon-bar@GeekInTraining-GiT

Name: The Grim Tab Reaper
Version: 0.2.1-signed.1-signed
Enabled: false
ID: jid1-VOwFjnJ0krddcw@jetpack

Name: Tilt
Version: 1.0.1.1-signed.1-signed
Enabled: false
ID: tilt@mozilla.com

Name: TinEye Reverse Image Search
Version: 1.2.1
Enabled: false
ID: tineye@ideeinc.com

Name: Toggle animated GIFs
Version: 1.3.1
Enabled: false
ID: giftoggle@simonsoftware.se

Name: Toggle Paint Flashing
Version: initial.rev7.1-signed.1-signed
Enabled: false
ID: jid0-vUWmQUzNnMcAZ6NPmhAEmMjI66M@jetpack

Name: Toolbar Autohide
Version: 6.7.2
Enabled: false
ID: fullscreentoolbarhover@com.sppad

Name: Translate This!
Version: 3.5.0
Enabled: false
ID: jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack

Name: User Agent Overrider
Version: 0.4.1
Enabled: false
ID: useragentoverrider@qixinglu.com

Name: Visual Hashing
Version: 0.3.1-signed.1-signed
Enabled: false
ID: jid1-NzIEzRc5sYX4Ww@jetpack

Name: Wallflower
Version: 1.5.1.1-signed.1-signed
Enabled: false
ID: jid1-uB4sJEPvR2m4QQ@jetpack

Name: WCAG Contrast checker
Version: 1.5.1.1-signed.1-signed
Enabled: false
ID: colorchecker@colorcheckerniquelao.net

Name: web_clipper
Version: 6.2.0
Enabled: false
ID: {E0B8C461-F8FB-49b4-8373-FE32E9252800}

Name: ZenHub
Version: 2.23.2
Enabled: false
ID: zenhub@zenhub.io

Graphics
--------

Features
Compositing: Direct3D 9
Asynchronous Pan/Zoom: wheel input enabled; touch input enabled
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics P3000 Direct3D9Ex vs_3_0 ps_3_0)
WebGL2 Renderer: WebGL creation failed: * Refused to create native OpenGL context because of blacklist entry: WEBGL_NATIVE_GL_OLD_INTEL * Exhausted GL driver options.
Hardware H264 Decoding: No; Hardware video decoding disabled or blacklisted
Audio Backend: wasapi
DirectWrite: false (6.2.9200.17568)
GPU #1
Active: Yes
Description: Intel(R) HD Graphics P3000
Vendor ID: 0x8086
Device ID: 0x010a
Driver Version: 9.17.10.4101
Driver Date: 1-30-2015
Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Subsys ID: 04981028
RAM: Unknown

Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: skia
AzureContentBackend: cairo
AzureFallbackCanvasBackend: cairo
failures: [GFX1-]: VendorIDMismatch V 0x8086 0
Decision Log
DIRECT2D:
failed by runtime: Direct3D11 device does not support texture sharing
D3D11_HW_ANGLE:
broken by runtime: RenderTargetViews need recreating


Failure Log
(#0) Error: VendorIDMismatch V 0x8086 0
(#2) Error: [D3D11] create component blender failed: 0x80070057, 0
(#3) Error: [D3D11] create component blender failed: 0x80070057, 0
(#4) Error: [D3D11] create component blender failed: 0x80070057, 0
(#5) Error: [D3D11] create component blender failed: 0x80070057, 0
(#6) Error: [D3D11] create component blender failed: 0x80070057, 0
(#7) Error: [D3D11] create component blender failed: 0x80070057, 0
(#8) Error: [D3D11] create component blender failed: 0x80070057, 0
(#9) Error: [D3D11] create component blender failed: 0x80070057, 0
(#10) Error: [D3D11] create component blender failed: 0x80070057, 0
(#11) Error: [D3D11] create component blender failed: 0x80070057, 0
(#12) Error: [D3D11] create component blender failed: 0x80070057, 0
(#13) Error: [D3D11] create component blender failed: 0x80070057, 0
(#14) Error: [D3D11] create component blender failed: 0x80070057, 0
(#15) Error: [D3D11] create component blender failed: 0x80070057, 0
(#16) Error: [D3D11] create component blender failed: 0x80070057, 0

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.hashstats_reported: 1
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 3
browser.download.importedFromSqlite: true
browser.download.manager.alertOnEXEOpen: true
browser.places.smartBookmarksVersion: 8
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20160805030444
browser.startup.homepage: resource://activity-streams/data/content/activity-streams.html#/
browser.startup.homepage_override.buildID: 20160805030444
browser.startup.homepage_override.mstone: 51.0a1
browser.tabs.remote.autostart: true
browser.tabs.remote.autostart.2: false
browser.tabs.warnOnOpen: false
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.allow_XUL_XBL_for_file: false
dom.apps.lastUpdate.buildID: 20160725030248
dom.apps.lastUpdate.mstone: 50.0a1
dom.apps.reset-permissions: true
dom.disable_open_during_load: false
dom.mozApps.maxLocalId: 1008
dom.mozApps.runUpdate: false
dom.mozApps.used: true
dom.mozContacts.enabled: true
dom.mozTCPSocket.enabled: true
dom.push.userAgentID: 3f551ac990a54b38ae3be50f9a7756b1
dom.w3c_touch_events.expose: false
extensions.lastAppVersion: 51.0a1
font.internaluseonly.changed: true
gfx.crash-guard.d3d11layers.appVersion: 43.0a1
gfx.crash-guard.d3d11layers.deviceID: 0x010a
gfx.crash-guard.d3d11layers.driverVersion: 9.17.10.3517
gfx.crash-guard.d3d11layers.feature-d2d: true
gfx.crash-guard.d3d11layers.feature-d3d11: true
gfx.crash-guard.glcontext.gfx.driver-init.direct3d11-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle: true
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-d3d11: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-force-warp: false
gfx.crash-guard.glcontext.gfx.driver-init.webgl-angle-try-d3d11: true
gfx.crash-guard.status.d3d11layers: 2
gfx.crash-guard.status.d3d9video: 2
gfx.crash-guard.status.glcontext: 2
gfx.direct3d.last_used_feature_level_idx: 0
gfx.driver-init.appVersion: 43.0a1
gfx.driver-init.deviceID: 0x010a
gfx.driver-init.driverVersion: 9.17.10.3517
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
media.benchmark.vp9.fps: 198
media.benchmark.vp9.versioncheck: 1
media.gmp-eme-adobe.abi: x86_64-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1456329566
media.gmp-eme-adobe.version: 17
media.gmp-gmpopenh264.abi: x86_64-msvc-x64
media.gmp-gmpopenh264.enabled: true
media.gmp-gmpopenh264.lastUpdate: 1451919922
media.gmp-gmpopenh264.version: 1.5.3
media.gmp-manager.buildID: 20160805030444
media.gmp-manager.lastCheck: 1470412396
media.gmp-widevinecdm.abi: x86_64-msvc-x64
media.gmp-widevinecdm.lastUpdate: 1464807594
media.gmp-widevinecdm.version: 1.4.8.866
media.gmp.storage.version.observed: 1
media.hardware-video-decoding.failed: false
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1469916186
places.favicons.optimizeToDimension: 64
places.history.expiration.transient_current_max_pages: 139016
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.flash: 1
plugin.state.java: 0
plugin.state.npdeployjava: 0
plugin.state.npgoogleupdate: 0
plugin.state.nppdf: 0
plugin.state.npspwrap: 0
plugin.state.npwatweb: 0
plugin.state.npwlpg: 0
print.printer_CutePDF_Writer.print_bgcolor: false
print.printer_CutePDF_Writer.print_bgimages: false
print.printer_CutePDF_Writer.print_colorspace:
print.printer_CutePDF_Writer.print_command:
print.printer_CutePDF_Writer.print_downloadfonts: false
print.printer_CutePDF_Writer.print_duplex: 6881395
print.printer_CutePDF_Writer.print_edge_bottom: 0
print.printer_CutePDF_Writer.print_edge_left: 0
print.printer_CutePDF_Writer.print_edge_right: 0
print.printer_CutePDF_Writer.print_edge_top: 0
print.printer_CutePDF_Writer.print_evenpages: true
print.printer_CutePDF_Writer.print_footercenter:
print.printer_CutePDF_Writer.print_footerleft: &PT
print.printer_CutePDF_Writer.print_footerright: &D
print.printer_CutePDF_Writer.print_headercenter:
print.printer_CutePDF_Writer.print_headerleft: &T
print.printer_CutePDF_Writer.print_headerright: &U
print.printer_CutePDF_Writer.print_in_color: true
print.printer_CutePDF_Writer.print_margin_bottom: 0.5
print.printer_CutePDF_Writer.print_margin_left: 0.5
print.printer_CutePDF_Writer.print_margin_right: 0.5
print.printer_CutePDF_Writer.print_margin_top: 0.945138931274414
print.printer_CutePDF_Writer.print_oddpages: true
print.printer_CutePDF_Writer.print_orientation: 0
print.printer_CutePDF_Writer.print_page_delay: 50
print.printer_CutePDF_Writer.print_paper_data: 1
print.printer_CutePDF_Writer.print_paper_height: 11.00
print.printer_CutePDF_Writer.print_paper_name:
print.printer_CutePDF_Writer.print_paper_size_type: 0
print.printer_CutePDF_Writer.print_paper_size_unit: 0
print.printer_CutePDF_Writer.print_paper_width: 8.50
print.printer_CutePDF_Writer.print_plex_name:
print.printer_CutePDF_Writer.print_resolution: 6881398
print.printer_CutePDF_Writer.print_resolution_name:
print.printer_CutePDF_Writer.print_reversed: false
print.printer_CutePDF_Writer.print_scaling: 0.30
print.printer_CutePDF_Writer.print_shrink_to_fit: false
print.printer_CutePDF_Writer.print_to_file: false
print.printer_CutePDF_Writer.print_unwriteable_margin_bottom: 0
print.printer_CutePDF_Writer.print_unwriteable_margin_left: 0
print.printer_CutePDF_Writer.print_unwriteable_margin_right: 0
print.printer_CutePDF_Writer.print_unwriteable_margin_top: 0
print.printer_Gestetner_MP_C2551_PCL_6.print_bgcolor: false
print.printer_Gestetner_MP_C2551_PCL_6.print_bgimages: false
print.printer_Gestetner_MP_C2551_PCL_6.print_colorspace:
print.printer_Gestetner_MP_C2551_PCL_6.print_command:
print.printer_Gestetner_MP_C2551_PCL_6.print_downloadfonts: false
print.printer_Gestetner_MP_C2551_PCL_6.print_duplex: 6881395
print.printer_Gestetner_MP_C2551_PCL_6.print_edge_bottom: 0
print.printer_Gestetner_MP_C2551_PCL_6.print_edge_left: 0
print.printer_Gestetner_MP_C2551_PCL_6.print_edge_right: 0
print.printer_Gestetner_MP_C2551_PCL_6.print_edge_top: 0
print.printer_Gestetner_MP_C2551_PCL_6.print_evenpages: true
print.printer_Gestetner_MP_C2551_PCL_6.print_footercenter:
print.printer_Gestetner_MP_C2551_PCL_6.print_footerleft: &PT
print.printer_Gestetner_MP_C2551_PCL_6.print_footerright: &D
print.printer_Gestetner_MP_C2551_PCL_6.print_headercenter:
print.printer_Gestetner_MP_C2551_PCL_6.print_headerleft: &T
print.printer_Gestetner_MP_C2551_PCL_6.print_headerright: &U
print.printer_Gestetner_MP_C2551_PCL_6.print_in_color: true
print.printer_Gestetner_MP_C2551_PCL_6.print_margin_bottom: 0.5
print.printer_Gestetner_MP_C2551_PCL_6.print_margin_left: 0.5
print.printer_Gestetner_MP_C2551_PCL_6.print_margin_right: 0.5
print.printer_Gestetner_MP_C2551_PCL_6.print_margin_top: 0.945138931274414
print.printer_Gestetner_MP_C2551_PCL_6.print_oddpages: true
print.printer_Gestetner_MP_C2551_PCL_6.print_orientation: 1
print.printer_Gestetner_MP_C2551_PCL_6.print_page_delay: 50
print.printer_Gestetner_MP_C2551_PCL_6.print_paper_data: 9
print.printer_Gestetner_MP_C2551_PCL_6.print_paper_height: 11.00
print.printer_Gestetner_MP_C2551_PCL_6.print_paper_name:
print.printer_Gestetner_MP_C2551_PCL_6.print_paper_size_type: 0
print.printer_Gestetner_MP_C2551_PCL_6.print_paper_size_unit: 1
print.printer_Gestetner_MP_C2551_PCL_6.print_paper_width: 8.50
print.printer_Gestetner_MP_C2551_PCL_6.print_plex_name:
print.printer_Gestetner_MP_C2551_PCL_6.print_resolution: 6881398
print.printer_Gestetner_MP_C2551_PCL_6.print_resolution_name:
print.printer_Gestetner_MP_C2551_PCL_6.print_reversed: false
print.printer_Gestetner_MP_C2551_PCL_6.print_scaling: 1.50
print.printer_Gestetner_MP_C2551_PCL_6.print_shrink_to_fit: true
print.printer_Gestetner_MP_C2551_PCL_6.print_to_file: false
print.printer_Gestetner_MP_C2551_PCL_6.print_unwriteable_margin_bottom: 0
print.printer_Gestetner_MP_C2551_PCL_6.print_unwriteable_margin_left: 0
print.printer_Gestetner_MP_C2551_PCL_6.print_unwriteable_margin_right: 0
print.printer_Gestetner_MP_C2551_PCL_6.print_unwriteable_margin_top: 0
print.printer_TOR5-DrClaw.print_bgcolor: false
print.printer_TOR5-DrClaw.print_bgimages: false
print.printer_TOR5-DrClaw.print_colorspace:
print.printer_TOR5-DrClaw.print_command:
print.printer_TOR5-DrClaw.print_downloadfonts: false
print.printer_TOR5-DrClaw.print_duplex: 6881395
print.printer_TOR5-DrClaw.print_edge_bottom: 0
print.printer_TOR5-DrClaw.print_edge_left: 0
print.printer_TOR5-DrClaw.print_edge_right: 0
print.printer_TOR5-DrClaw.print_edge_top: 0
print.printer_TOR5-DrClaw.print_evenpages: true
print.printer_TOR5-DrClaw.print_footercenter:
print.printer_TOR5-DrClaw.print_footerleft: &PT
print.printer_TOR5-DrClaw.print_footerright: &D
print.printer_TOR5-DrClaw.print_headercenter:
print.printer_TOR5-DrClaw.print_headerleft: &T
print.printer_TOR5-DrClaw.print_headerright: &U
print.printer_TOR5-DrClaw.print_in_color: true
print.printer_TOR5-DrClaw.print_margin_bottom: 0.5
print.printer_TOR5-DrClaw.print_margin_left: 0.5
print.printer_TOR5-DrClaw.print_margin_right: 0.5
print.printer_TOR5-DrClaw.print_margin_top: 0.945138931274414
print.printer_TOR5-DrClaw.print_oddpages: true
print.printer_TOR5-DrClaw.print_orientation: 0
print.printer_TOR5-DrClaw.print_page_delay: 50
print.printer_TOR5-DrClaw.print_paper_data: 9
print.printer_TOR5-DrClaw.print_paper_height: -1.00
print.printer_TOR5-DrClaw.print_paper_name:
print.printer_TOR5-DrClaw.print_paper_size_type: 0
print.printer_TOR5-DrClaw.print_paper_size_unit: 1
print.printer_TOR5-DrClaw.print_paper_width: -1.00
print.printer_TOR5-DrClaw.print_plex_name:
print.printer_TOR5-DrClaw.print_resolution: 6881398
print.printer_TOR5-DrClaw.print_resolution_name:
print.printer_TOR5-DrClaw.print_reversed: false
print.printer_TOR5-DrClaw.print_scaling: 1.00
print.printer_TOR5-DrClaw.print_shrink_to_fit: false
print.printer_TOR5-DrClaw.print_to_file: false
print.printer_TOR5-DrClaw.print_unwriteable_margin_bottom: 0
print.printer_TOR5-DrClaw.print_unwriteable_margin_left: 0
print.printer_TOR5-DrClaw.print_unwriteable_margin_right: 0
print.printer_TOR5-DrClaw.print_unwriteable_margin_top: 0
privacy.clearOnShutdown.cookies: false
privacy.clearOnShutdown.offlineApps: true
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.migrateFx3Prefs: true
privacy.trackingprotection.enabled: true
privacy.trackingprotection.introCount: 20
security.disable_button.openCertManager: false
security.sandbox.content.tempDirSuffix: {10aa2415-98ed-4fec-8fdf-78ad1b5c87e5}
services.sync.declinedEngines: passwords
services.sync.engine.prefs.modified: false
services.sync.lastPing: 1470409661
services.sync.lastSync: Fri Aug 05 2016 11:54:11 GMT-0400 (Eastern Standard Time)
services.sync.numClients: 3
storage.vacuum.last.index: 0
storage.vacuum.last.places.sqlite: 1470348192

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.12
Version in use: 4.12

NSS
Expected minimum version: 3.26
Version in use: 3.26

NSSSMIME
Expected minimum version: 3.26
Version in use: 3.26

NSSSSL
Expected minimum version: 3.26
Version in use: 3.26

NSSUTIL
Expected minimum version: 3.26
Version in use: 3.26

Experimental Features
---------------------
Blocks: 1261585
Keywords: regressionwindow-wanted
Keywords: nightly-community
(Reporter)

Comment 5

a year ago
When I start up nightly in safe mode, the bug disappears.
(Assignee)

Updated

a year ago
Component: Untriaged → Networking: HTTP
Flags: needinfo?(dd.mozilla)
Product: Firefox → Core
(Assignee)

Updated

a year ago
Assignee: nobody → dd.mozilla
Whiteboard: [
(Assignee)

Updated

a year ago
Whiteboard: [ → [necko-active]
(Assignee)

Updated

a year ago
Status: NEW → ASSIGNED
I can repeat it in my nightly, and if I just open a non-e10s window and paste the link there - it works!
(Assignee)

Comment 7

a year ago
I know what is wrong and how to fix it. Thanks.
If you remove an addon that uses nsITraceableChannel it will work too :).
I will have a patch soon.
(Assignee)

Comment 8

a year ago
Created attachment 8779856 [details] [diff] [review]
bug_1292586.patch
Attachment #8779856 - Flags: review?(honzab.moz)
(Assignee)

Comment 9

a year ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=976e3649387f

Updated

a year ago
tracking-e10s: ? → +
Priority: -- → P2
See Also: → bug 1294174
(In reply to Dragana Damjanovic [:dragana] from comment #8)
> Created attachment 8779856 [details] [diff] [review]
> bug_1292586.patch

Please describe the patch and the cause of the problem for reference.  Thanks.
Flags: needinfo?(dd.mozilla)
(Assignee)

Comment 11

a year ago
(In reply to Honza Bambas (:mayhemer) from comment #10)
> (In reply to Dragana Damjanovic [:dragana] from comment #8)
> > Created attachment 8779856 [details] [diff] [review]
> > bug_1292586.patch
> 
> Please describe the patch and the cause of the problem for reference. 
> Thanks.

My patch from bug 1261585 was only considering extension that need the external app helper service, but the thing is more complicated, especially I was missing once that do not need the helper, like text:
https://hg.mozilla.org/mozilla-central/diff/9b2a99adc05e/uriloader/base/nsURILoader.cpp#l224
I do not want to duplicate all of that so I decided to move the decision to the child and suspend parent in mean time
Flags: needinfo?(dd.mozilla)
(Assignee)

Updated

a year ago
Duplicate of this bug: 1295830
(In reply to Dragana Damjanovic [:dragana] from comment #11)
> (In reply to Honza Bambas (:mayhemer) from comment #10)
> > (In reply to Dragana Damjanovic [:dragana] from comment #8)
> > > Created attachment 8779856 [details] [diff] [review]
> > > bug_1292586.patch
> > 
> > Please describe the patch and the cause of the problem for reference. 
> > Thanks.
> 
> My patch from bug 1261585 was only considering extension that need the
> external app helper service, but the thing is more complicated, especially I
> was missing once that do not need the helper, like text:

Thanks.  The link tho doesn't point to any useful.. whatever you wanted to show.

> https://hg.mozilla.org/mozilla-central/diff/9b2a99adc05e/uriloader/base/
> nsURILoader.cpp#l224
> I do not want to duplicate all of that so I decided to move the decision to
> the child and suspend parent in mean time

I must point out that this is made only when there is a tracable listener added.  Is there any addon that may add it on every or significant number of channels?  Because this will have a performance impact.  Instead of queuing OnStart/OnData*/OnStop fast on the IPC wire, we must wait for the response from the child to resume the real parent channel.  IPC rtt is small (on machines I test with - i.e. fast) but still this would be a regression.
Comment on attachment 8779856 [details] [diff] [review]
bug_1292586.patch

Review of attachment 8779856 [details] [diff] [review]:
-----------------------------------------------------------------

r- based on the heavily failing try run in comment 9 (if that is the one, but it seems to).

I understand the intent, but this seems fragile until done really carefully.

::: netwerk/protocol/http/HttpChannelChild.cpp
@@ +441,5 @@
>    nsCOMPtr<nsISupportsPRUint32> container =
>      do_CreateInstance(NS_SUPPORTS_PRUINT32_CONTRACTID, &rv);
>    if (NS_FAILED(rv)) {
> +    if (mContentDecodingWillBeCalledOnParent) {
> +      SendApplyConversion(false);

this will be easy to forget when we add some new |return| here.  could we have some Auto class or something a bit smarter?

::: netwerk/protocol/http/HttpChannelParent.cpp
@@ +723,5 @@
>    return true;
>  }
>  
> +bool
> +HttpChannelParent::RecvApplyConversion(const bool& aApply)

maybe some comment where from is this invoked and why?

@@ +1043,5 @@
>      if (!mChannel->HaveListenerForTraceableChannel()) {
>        encodedChannel->SetApplyConversion(false);
>      } else {
>        // We have a traceableChannel listener so we need to do a conversion on
> +      // the parent. 

nit: trailing ws

@@ +1045,5 @@
>      } else {
>        // We have a traceableChannel listener so we need to do a conversion on
> +      // the parent. 
> +      // Wait for a reply from RecvApplyConversion to inform us whether or not
> +      // we need to do a convesion. nsURILoad and nsExternalHelperAppService

the conversion

@@ +1046,5 @@
>        // We have a traceableChannel listener so we need to do a conversion on
> +      // the parent. 
> +      // Wait for a reply from RecvApplyConversion to inform us whether or not
> +      // we need to do a convesion. nsURILoad and nsExternalHelperAppService
> +      // will made the final decision. They are call on the child.

will make
They are called

@@ +1047,5 @@
> +      // the parent. 
> +      // Wait for a reply from RecvApplyConversion to inform us whether or not
> +      // we need to do a convesion. nsURILoad and nsExternalHelperAppService
> +      // will made the final decision. They are call on the child.
> +      mChannel->SuspendInternal();

when you do this, it must be in tight sync with what you then send down as the contentDecodingWillBeCalledOnParent arg!  I see this bit missing somehow in this patch.  Probably the reason why try tests mostly time out.

::: netwerk/protocol/http/HttpChannelParent.h
@@ +163,5 @@
>    virtual bool RecvDivertOnStopRequest(const nsresult& statusCode) override;
>    virtual bool RecvDivertComplete() override;
>    virtual bool RecvRemoveCorsPreflightCacheEntry(const URIParams& uri,
>                                                   const mozilla::ipc::PrincipalInfo& requestingPrincipal) override;
> +  virtual bool RecvApplyConversion(const bool& applyConversion)  override;

nit: two spaces before override
Attachment #8779856 - Flags: review?(honzab.moz) → review-
Honestly, if this turns out to be too much pain, I'd rather back bug 1261585 out and WONTFIX it.  We could provide tools to apply conversions easily in the consumer's implementation (provide indicators when and what type of conversion may needed to be used).
[Tracking Requested - why for this release]:

This bug is a regression in Firefox 50.

STR:
1. Load https://www.expensify.com/
2. The page looks OK.
3. Open the Firefox devtools.
4. Reload page.

RESULT:
The page is missing some page elements and styling. The devtools console reports:

Found unclosed string ‘"��7Lj�����/ڜ��GG�͋Ͷ��N@�\3 ���J�^��\9 �r\11 ɪ.�t��s� Q���V�ӓ=9\9 �@��%n_Ō��P�\1e ,B0��3�E��’.  Unexpected end of file while searching for end of comment.  Unexpected end of file while searching for closing } of invalid rule set.homepage.2d1fb459.css.gz:7:7
SyntaxError: illegal charactermodule-vendor.ee3aa5db.js.gz:1
SyntaxError: illegal charactermodule-expensify.42016f86.js.gz:1
SyntaxError: illegal characterfastHomepage.19d408aa.js.gz:1
tracking-firefox50: --- → ?
(Assignee)

Comment 17

a year ago
Let's back out bug 1261585 and i will do this in a different way.

Updated

a year ago
Duplicate of this bug: 1294174
Backed bug 1261585 out of central and aurora. 

I'll leave it to you to decide if this bug should be closed. :)
(Assignee)

Comment 20

a year ago
This is resolved by backing out bug 1261585.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
We don't need to track this anymore as the backouts are already done.
status-firefox50: affected → fixed
status-firefox51: affected → fixed
tracking-firefox50: ? → -
Target Milestone: --- → mozilla51
Version: unspecified → 50 Branch
You need to log in before you can comment on or make changes to this bug.