If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

favicons vanish when opening a second tab

RESOLVED DUPLICATE of bug 297155

Status

SeaMonkey
Tabbed Browser
RESOLVED DUPLICATE of bug 297155
16 years ago
5 years ago

People

(Reporter: Leif Singer, Assigned: jag (Peter Annema))

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9+)
Gecko/20020305
BuildID:    2002030508

if 'preferences' -> 'navigator' -> 'tabbed browsing' -> 'hide the tab bar when
only one tab bar is open' is checked, the favicon of the current page is lost
when unhiding the tab bar when opening a second tab. when reloading the first
tab, the favicon reappears and stays.


Reproducible: Always
Steps to Reproduce:
1. make sure the tab bar is hidden when only one tab is open
2. open e.g. http://mozilla.org/
3. open a new tab and see the first tab's favicon vanish
4. reload the first tab and see it's favicon reappear
5. close the second tab
6. open a second tab again and see how the favicon actually stays there even
though the tab bar is switched from hidden to visible again.

Actual Results:  the favicon of the first tab disappeared when opening a second
tab for the first time.

Expected Results:  show the favicon all the time.
 Yep. Hmm...okay. If I have two tabs open, and select the second one, when I go
back to the first one, its favicon.ico is gone. I believe that's your problem.
NOTE: favicons fully enabled via user.js...
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: sairuh → claudius

Comment 2

16 years ago
I'm also seeing this on Windows 98 and Windows 2k with Build 2002031903.

As for comment #2: "If I have two tabs open, and select the second one, when I go
back to the first one, its favicon.ico is gone." 

That isn't what was described. Here is the easiest way to reproduce for me:
1. Open a new browser window
2. Go to any site that has a favicon (such as slashdot.org)
3. Notice that the favicon is visibile in the URL bar
4. Ctrl-T to open a new tab.
5. Notice that the first tab does not show the favicon that was visible in 4
6. Go to any site that has a favicon in Tab #2
7. Notice that the favicon shows up on the Tab #2, but still nothing on #1
8. Go back to Tab #1
9. Reload Tab #1.
10. The favicon is now displayed. Switching tabs does not make it disappear.

--
*grumble* It won't let me change the OS or Platform. It needs to be updated
since this isn't
only happening on Mac.

A better summary might be: "favicon does not display in first tab when a second
tab is opened"?

Comment 3

16 years ago
I'm still seeing this on Win2K Build ID 2002041503.

Any chance of getting the OS and Platform updated?
My (big) patch in 113798 is fixing this.

Comment 5

16 years ago
This appears to be fixed on Win2K Build ID 2002050308.

Comment 6

15 years ago
I can still reproduce the problem with Windows 98, build 2002073019. Please,
adjust the "OS" and "Platform" selector to "All".

Updated

15 years ago
OS: MacOS X → All
Hardware: Macintosh → All

Updated

15 years ago
Blocks: 120352

Comment 7

15 years ago
*** Bug 164761 has been marked as a duplicate of this bug. ***
Reproduced on Win98 using Mozilla build 20020826 - but that's not the latest
build anyway :-(

Have no time to download the latest build, sorry.

Hope you'll soon debug it, people; I like makin' those animated GIF favicons for
my website, and when I open a new tab and favicon's gone, it really breaks my
heart, you know (some of those icons represent hearts ;-)

Comment 9

15 years ago
*** Bug 183392 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
Isn't this just the same thing as bug 109959.  I see a very specific
circumstance of making favicons described here, but think may all be the same
problem.

Comment 11

14 years ago
WFM: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.6b) Gecko/20031125
AFAIK are some favicons parts new since 1.6a.
Could anybody reproduce this bug with an recent build?

Comment 12

14 years ago
I can reproduce the problem in today's build 2003120808.

The steps are simple:

1. Go to http://www.slashdot.org/ .

2. Go to any story.

3. Click on any link using control+click to open the new page in a new tab.

4. Look at the fist tab. You won't see the favicon. BUG!.

My environment:

 - control+click opens a new tab.

 - When only one tab is present, hide tabs.

Comment 13

14 years ago
I can also add to this that this problem exists and it shows in many
different variations including disappearing the icon in the navigation bar
but remaining in the tab.

Comment 14

13 years ago
*** Bug 201124 has been marked as a duplicate of this bug. ***
QA Contact: claudius → technutz
Product: Core → SeaMonkey

Comment 15

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
This was fixed by the patch in bug 297155.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 297155
You need to log in before you can comment on or make changes to this bug.