Closed Bug 1293601 Opened 3 years ago Closed 3 years ago

[Fennec] The video controls are missing the time slider and show a random number at the start of video playback on YouTube

Categories

(Toolkit :: Video/Audio Controls, defect, P1)

50 Branch
All
Android
defect

Tracking

()

VERIFIED FIXED
mozilla51
Tracking Status
firefox48 --- unaffected
firefox49 --- unaffected
firefox50 --- verified
firefox51 --- verified

People

(Reporter: alwu, Assigned: ralin)

References

Details

(Keywords: regression)

Attachments

(2 files)

STR.
1. open Fennec app
2. go to https://www.youtube.com/watch?v=cxeQmF4sUJY&app=desktop
3. start playing (the control interface would not display at that time)
4. click the video, it would show the control interface 

Expected.
5. the layout of the control interface is correct

Actual.
5. the layout of the control interface is incorrect [1]

# note : if you click video again, the layout will be showed correctly.

[1] https://photos.google.com/share/AF1QipOTYFIk3yQMY5G-z_RRMGdZuuF2PAiGEcaxCoi1wfP42v_VfryTd865x9dRH3LAxQ/photo/AF1QipMYHg2iSms-s3Mkioqepb-QwyHfLFxVLM8KlvfO?key=VTVnTmwxc3BZUEFndUtFaVJucEVPd2c5QXV3cFdR
Thank you Alastor

I suspect it is caused by the timing problem between video's state and control's init process. Since this problem is severe, I'll find out the reason ASAP.

The pushlog of narrowed regression window:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=04821a70c739a00d12e12df651c0989441e22728&tochange=151aaa2db94d3fabe8958b61904371b8f415065d
From the pushlog, it looks like it was broken by https://hg.mozilla.org/mozilla-central/rev/afb94913764c
Priority: -- → P1
Summary: The layout of control interface displays incorrectly → [Fennec] The video controls are missing the time slider and show a random number at the start of video playback on YouTube
Thanks Jared!

yes, that is a point leads the result. The other and might be the root cause is the flag: "firstshow"[0], and it affects the display of theses components[1].

I think we should remove the css rules and uplift to beta. 


[0] https://dxr.mozilla.org/mozilla-central/rev/6cf0089510fad8deb866136f5b92bbced9498447/toolkit/content/widgets/videocontrols.xml#1850-1852
[1] https://dxr.mozilla.org/mozilla-central/rev/6cf0089510fad8deb866136f5b92bbced9498447/mobile/android/themes/core/touchcontrols.css#220-225
Assignee: nobody → ralin
Status: NEW → ASSIGNED
Duplicate of this bug: 1290833
Comment on attachment 8779619 [details]
Bug 1293601 - Show slider and mute button at first show on video touch control.

https://reviewboard.mozilla.org/r/70566/#review68098

The commit message has a typo in it. Replace "firt" with "first".
Attachment #8779619 - Flags: review?(jaws) → review+
Keywords: checkin-needed
Ray, what about the random number? Are you still planning on fixing that?
Flags: needinfo?(ralin)
I guess the random is like 0:082:31 in :https://bug1290833.bmoattachments.org/attachment.cgi?id=8776524. The string is composed of "duration label + progress label", and will be separated by slider in my patch.

If not, could you provide me a screenshot? Thanks.
Flags: needinfo?(ralin)
Oh! I didn't think about it that way. Cool, no worries then :)
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/590559290122
Show slider and mute button at first show on video touch control. r=jaws
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/590559290122
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Can we uplift this to 50 (which is also apparently affected)?
Flags: needinfo?(ralin)
Comment on attachment 8779619 [details]
Bug 1293601 - Show slider and mute button at first show on video touch control.

Approval Request Comment
[Feature/regressing bug #]: Fix video control incorrect layout on YouTube
[User impact if declined]: as title, time slider and mute button are missing from control
[Describe test coverage new/current, TreeHerder]: none
[Risks and why]: low rick, css which change display property only.
[String/UUID change made/needed]: none
Flags: needinfo?(ralin)
Attachment #8779619 - Flags: approval-mozilla-aurora?
Hi Ioana, can someone from your team please validate this fix on Nightly/Aurora? Thanks!
Flags: needinfo?(chiorean.ioana)
Keywords: regression
Comment on attachment 8779619 [details]
Bug 1293601 - Show slider and mute button at first show on video touch control.

Recent regression in 50, Aurora50+
Attachment #8779619 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed using:
Device: One A2001 (Android 5.1.1)
Builds: Firefox for Android 50.0a2 (2016-08-21) and Firefox for Android 51.0a1 (2016-08-21)
Flags: needinfo?(chiorean.ioana)
Version: unspecified → 50 Branch
You need to log in before you can comment on or make changes to this bug.