Closed Bug 1293650 Opened 3 years ago Closed 3 years ago

Download notification: Pause/Cancel button not working

Categories

(Firefox for Android :: Download Manager, defect, P1)

51 Branch
All
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 51
Iteration:
1.3
Tracking Status
firefox49 --- unaffected
fennec 50+ ---
firefox50 --- verified
firefox51 --- verified

People

(Reporter: prasanthmani2010, Assigned: sebastian)

References

Details

(Keywords: regression, Whiteboard: [MobileAS])

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160414065514

Steps to reproduce:

Step1: Launch the firefox nightly browser

Step2 : Go to this site http://www92.zippyshare.com/v/FbdkpRQU/file.html

Step 3: Click the download button

Step 4: In the the notification panel, the progress of the download is shown. click on the pause button.


Actual results:

The Pause button did not work. The file continued to download.


Expected results:

The downloading should pause.
OS: Unspecified → Android
Hardware: Unspecified → x86
I can reproduce the issue.
This is a regression:
25-06 good build
26-06 affected build
pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0e073f5ca38a002d43e92016ee40d686da4a0534&tochange=c2da34d96746288b5fee27bf6542a12c9f410988

I think Bug 1075476 - removing download notification restarts Firefox caused this.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jonalmeida942)
Keywords: regression
Maybe Sebastian knows what could be up since he reviewed the patches on bug 1075476.
Flags: needinfo?(s.kaspari)
tracking-fennec: --- → ?
Priority: -- → P1
Hardware: x86 → All
Bug 1075476 seems to be a very likely candidate. Unfortunately jonalmeida's internship just ended. :)

I'll have a look or redirect.
Assignee: nobody → s.kaspari
Status: NEW → ASSIGNED
Flags: needinfo?(s.kaspari)
tracking-fennec: ? → 50+
Summary: pause button not working → Download notifcation: Pause button not working
Depends on: 1297018
Summary: Download notifcation: Pause button not working → Download notification: Pause button not working
Whiteboard: [MobileAS]
The 'cancel' button seems to be broken too.
Summary: Download notification: Pause button not working → Download notification: Pause/Cancel button not working
Comment on attachment 8786370 [details]
Bug 1293650 - NotificationHelper: Create broadcast intent instead of activity intent.

https://reviewboard.mozilla.org/r/75340/#review73380
Attachment #8786370 - Flags: review?(ahunt) → review+
Pushed by s.kaspari@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e81611b17f1a
NotificationHelper: Create broadcast intent instead of activity intent. r=ahunt
Comment on attachment 8786370 [details]
Bug 1293650 - NotificationHelper: Create broadcast intent instead of activity intent.

Approval Request Comment

[Feature/regressing bug #]: Regression introduced by bug 1075476.

[User impact if declined]: "Pause" and "Cancel" actions in download notification are not functional.

[Describe test coverage new/current, TreeHerder]: Manual testing downloading dummy files from http://www.speedtestx.de/

[Risks and why]: Low. This part of the code wasn't refactored in bug 1075476. This is a very small change.

[String/UUID change made/needed]: -
Flags: needinfo?(jonalmeida942)
Attachment #8786370 - Flags: approval-mozilla-aurora?
This should have been broken for all notification actions for notifications created using Notifications.jsm. This patch should fix it for all of them.

If an add-on was relying on the browser app coming to the front when a notification action was clicked then this might be broken now. However this is a problem independently from this patch and a result of the refactoring from bug 1075476.
https://hg.mozilla.org/mozilla-central/rev/e81611b17f1a
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Pause/Cancel/Resume buttons work as expected using Nexus 6 (Android 6.0) on latest Nightly 51.0a1 (2016-09-01)
Status: RESOLVED → VERIFIED
Comment on attachment 8786370 [details]
Bug 1293650 - NotificationHelper: Create broadcast intent instead of activity intent.

New regression in 50, was verified in Nightly, Aurora50+
Attachment #8786370 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Pause/Cancel/Resume buttons work as expected using One A2001 (Android 6.0.1) on Firefox for Android 50 Beta 1.
Iteration: --- → 1.3
You need to log in before you can comment on or make changes to this bug.