Spell checker thinks "adoptee" is a misspelling

RESOLVED FIXED in Firefox 52

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: litewrite, Assigned: litewrite)

Tracking

47 Branch
mozilla52
Points:
---

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(2 attachments, 3 obsolete attachments)

(Assignee)

Description

2 years ago
Created attachment 8779423 [details]
Spell checker thinks "adoptee" is a misspelling

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

1. Visit http://pastebin.mozilla.org/
2. Type "adoptee" into the text box






Actual results:

 Squiggly red underline indicating misspelling


Expected results:

No squiggly red underline indicating misspelling.

For reference for the spelling of "adoptee", please see http://www.merriam-webster.com/dictionary/adoptee or http://www.dictionary.com/browse/adoptee

(currently I am unable to install Xcode on my machine otherwise I would follow the MDN procedure for adding a new word to the en-US dictionary.)

Updated

2 years ago
Component: Untriaged → Spelling checker
Flags: needinfo?(jorgk)
Product: Firefox → Core

Comment 1

2 years ago
We should add this since it seems common enough, has a high SCOWL rating and is in en_US-large:
http://app.aspell.net/lookup?dict=en_US;words=adoptee
Flags: needinfo?(jorgk)
(Assignee)

Comment 2

2 years ago
Hi, I was finally able to get my dev environment set up on my computer and I am trying to add the word per instructions here: https://developer.mozilla.org/en-US/docs/Mozilla/Adding_a_new_word_to_the_en-US_dictionary

I am using mozilla-central via: hg clone https://hg.mozilla.org/mozilla-central

I am able to successfully add the word to "5-mozilla-added" but when I quit my editor and try to run the command "sh merge-dictionaries" as described in the above tutorial from the directory extensions/spellcheck/locales/en-US/hunspell/dictionary-sources it says: "sh: merge-dictionaries: No such file or directory"

I see that there is a "make-new-dict" and "install-new-dict" in the directory but not "merge-dictionaries". What am I missing here to merge the word I added and proceed with moving the revised dictionary file? Any help is greatly appreciated.

Comment 3

2 years ago
To add a single word to the dictionary, add it to en-US.dic and don't forget to increase the count at the very top. This change here is a two-liner.

All those scripts are for bulk import of new dictionaries from the upstream source (SCOWL).

For your case, see
https://hg.mozilla.org/mozilla-central/diff/e42e07e4f668/extensions/spellcheck/locales/en-US/hunspell/en-US.dic
as an example of a single word addition.

Comment 5

2 years ago
Actually, you should add this line:
adoptee/MS
The suffixes M and S are for plural (adoptees) and possessive form (adoptee's) (or vice versa).
(Assignee)

Comment 6

2 years ago
Fantastic. Thank you for clarifying and sharing the example.
(Assignee)

Comment 7

2 years ago
Created attachment 8793850 [details] [diff] [review]
Proposed Patch - Spelling Checker Word Addition

My apologies but I was not able to submit patch via bzexport. Kept receiving the error: "abort: Local changes found; refresh first!" after running hg bzexport -e

Proposed patch for spelling checker has been edited per instructions in comments.

I would like to streamline this process for future additions. Any help or documentation would be greatly appreciated. Thank you for your patience

Comment 8

2 years ago
You need to attach a patch for review, not the edited file.

You can use mercurial queues to create one:
hg qnew -m "Bug 1293704 - added adoptee/MS. r=ehsan" 1293704.patch.

Your reviewer will be Ehsan (ehsan@mozilla.com).
(Assignee)

Comment 9

2 years ago
All set now. When I tried mercurial's qnew previously, I received "hg: unknown command 'qnew'" because I had mq disabled. Enabled mq and was able to create patch. Will attach patch file. Thanks!
(Assignee)

Comment 10

2 years ago
Created attachment 8793880 [details] [diff] [review]
Proposed Patch - Added adoptee/MS to spelling checker
Attachment #8793850 - Attachment is obsolete: true
Attachment #8793880 - Flags: review?(ehsan)

Comment 11

2 years ago
Comment on attachment 8793880 [details] [diff] [review]
Proposed Patch - Added adoptee/MS to spelling checker

Please check patches before attaching them for review.

Did you not see that you saved the file as UTF-8 where it was ANSI encoded before? You destroyed every single word with an accent, and you can see it in the patch, just look:
-Asunción/M
+Asunci�n/M
Attachment #8793880 - Flags: review?(ehsan) → review-
(Assignee)

Comment 12

2 years ago
Apologies - amateur mistake. My editor defaulted to UTF-8. Will resubmit
(Assignee)

Comment 13

2 years ago
Created attachment 8793967 [details] [diff] [review]
Proposed Patch - Added adoptee/MS to spelling checker

Updated proposed patch with correct encoding format. Thank you for your patience.
Attachment #8793880 - Attachment is obsolete: true
Attachment #8793967 - Flags: review?(ehsan)

Comment 14

2 years ago
Comment on attachment 8793967 [details] [diff] [review]
Proposed Patch - Added adoptee/MS to spelling checker

Yep ;-)
Attachment #8793967 - Flags: feedback+

Comment 15

2 years ago
Actually, you don't seem to have Mercurial set up correctly. To land the patch, it needs the author noted in it. My patches for example look have this:

# HG changeset patch
# User Jorg K <jorgk@jorgk.com>
# Parent  5644818538de2413cce52551e32b025e6c7e352e
Bug 301712 - Remove uncommon proper names, remove unneeded words. r=ehsan

Another question. When this bug is done, maybe we can interest you in bug 1255327. That's a little harder since you'd have to add canonicalization/MS and also the verb, canonicalize which comes with the usual suffixes:
canonicalized, canonicalizes, canonicalizing.
(Assignee)

Comment 16

2 years ago
Hmmn - Looks like on my Global Config ("$HOME/.hgrc"): 
[ui]
username = m-r-m-s <litewrite@gmail.com>

but local repository at mozilla-central/.hg/hgrc is an example configuration file. I guess that is overriding global config? Will try and sort out and resubmit. 

Yes, I am interested in bug 1255327 once this bug is complete

Comment 17

2 years ago
I have that in mercurial.ini

Comment 18

2 years ago
Comment on attachment 8793967 [details] [diff] [review]
Proposed Patch - Added adoptee/MS to spelling checker

Review of attachment 8793967 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8793967 - Flags: review?(ehsan) → review+

Comment 19

2 years ago
(In reply to litewrite from comment #16)
> Will try and sort out and resubmit. 

Coming up?

When you do, you can add the review+ yourself and add as a comment:
Added user name to patch. Carrying forward Ehsan's r+.
Then you need to add the keyword "checkin-needed" so a sheriff will take the patch and commit it to the code base.

Updated

2 years ago
Assignee: nobody → litewrite
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 20

2 years ago
Spent most of yesterday trying to figure out why User comments weren't being included in patch despite having the [ui] populated in my .hgrc file (mac os x equilvalent of the mercurial.ini). Still had no success. Added the User comments manually to patch, then did a "hg qrefresh". I will re-submit here shortly per your most recent instructions. Really appreciate all the help so far!
(Assignee)

Comment 21

2 years ago
Created attachment 8794547 [details] [diff] [review]
Proposed Patch - Added adoptee/MS to spelling checker

Added user name to patch. Carrying forward Ehsan's r+.
Attachment #8793967 - Attachment is obsolete: true
Attachment #8794547 - Flags: review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 22

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e84d837b043e
added adoptee/MS. r=ehsan
Keywords: checkin-needed

Comment 23

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e84d837b043e
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.