The default bug view has changed. See this FAQ.

TEST-UNEXPECTED-FAIL | xpcshell-unpack.ini:toolkit/mozapps/extensions/test/xpcshell/test_webextension.js | xpcshell return code: 0 and more

RESOLVED FIXED in Firefox 51

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED FIXED
8 months ago
11 days ago

People

(Reporter: aleth, Assigned: Jorg K (GMT+1))

Tracking

(Blocks: 1 bug, {intermittent-failure})

unspecified
mozilla51
Unspecified
Windows
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox51 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 months ago
Windows only. 

Also TEST-UNEXPECTED-FAIL | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_webextension.js | xpcshell return code: 0
(Reporter)

Comment 1

8 months ago
First seen in https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=adc56f0cd5b514b27a96cebb31afe02503971b0c
Last good https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=7b9fbef870b2d735e06105bfe4e9dc09518545dd
(Assignee)

Comment 2

8 months ago
So the reference to bug 1200128 was misleading, right?

This is wrong:
Last good https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=7b9fbef870b2d735e06105bfe4e9dc09518545dd
Look at
http://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-win32-debug/1470669863/comm-central_win7_ix-debug_test-xpcshell-bm109-tests1-windows-build0.txt.gz

You can already find:
TEST-UNEXPECTED-FAIL | xpcshell-unpack.ini:toolkit/mozapps/extensions/test/xpcshell/test_webextension.js
It doesn't show in the tree herder summary since we had one million other Xpcshell failures at that time.

I'd say it's bug 1263011 that landed 2016-08-07 08:50:16 CEST.
(Assignee)

Comment 3

7 months ago
Just to clarify, there are two errors:
TEST-UNEXPECTED-FAIL | xpcshell-unpack.ini:toolkit/mozapps/extensions/test/xpcshell/test_webextension.js | xpcshell return code: 0
and
TEST-UNEXPECTED-FAIL | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_webextension.js | xpcshell return code: 0

Initially both where Windows only.

As of Wed Aug 17, 0:35:10
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=141fa85916e4b7afee97596269b4ec5537e5aeff
we *additionally* have
TEST-UNEXPECTED-TIMEOUT | xpcshell.ini:toolkit/mozapps/extensions/test/xpcshell/test_delay_update_webextension.js

on *all* platforms. See bug 1295907.
Summary: TEST-UNEXPECTED-FAIL | xpcshell-unpack.ini:toolkit/mozapps/extensions/test/xpcshell/test_webextension.js | xpcshell return code: 0 → TEST-UNEXPECTED-FAIL | xpcshell-unpack.ini:toolkit/mozapps/extensions/test/xpcshell/test_webextension.js | xpcshell return code: 0 and more
(Assignee)

Comment 4

7 months ago
Aleth, would it be an option do disable the test like we did in bug 1267612?
Flags: needinfo?(aleth)
(Reporter)

Comment 5

7 months ago
Yes, as long as TB doesn't support webextensions, these tests don't matter.
Flags: needinfo?(aleth)
(Assignee)

Comment 6

7 months ago
Created attachment 8782051 [details] [diff] [review]
Disable tests not suitable for Thunderbird.

Hi Kris, like in bug 1267612 some tests related to web extensions are failing in the Thunderbird Xpcshell test suite.

To keep the review load low, I've combined to disablements into one patch. We reported the other failure in bug 1295907.

Maybe while I'm here also disable test_webextension_icons.js?
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #8782051 - Flags: review?(kmaglione+bmo)

Comment 7

7 months ago
Comment on attachment 8782051 [details] [diff] [review]
Disable tests not suitable for Thunderbird.

Review of attachment 8782051 [details] [diff] [review]:
-----------------------------------------------------------------

(In reply to Jorg K (GMT+2, PTO during summer) from comment #6)
> Maybe while I'm here also disable test_webextension_icons.js?

Yes, please do.
Attachment #8782051 - Flags: review?(kmaglione+bmo) → review+
(Assignee)

Comment 8

7 months ago
Created attachment 8782080 [details] [diff] [review]
Disable tests not suitable for Thunderbird. (v2).

Carrying forward Kris' r+.
Attachment #8782051 - Attachment is obsolete: true
Attachment #8782080 - Flags: review+
(Assignee)

Comment 9

7 months ago
Aleth, if you get here before the sheriffs, you could push this to inbound. Thanks.
Flags: needinfo?(aleth)
Keywords: checkin-needed
(Assignee)

Updated

7 months ago
Duplicate of this bug: 1295907
(Assignee)

Updated

7 months ago
Component: General → WebExtensions
Product: Thunderbird → Toolkit

Comment 11

7 months ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ef40e047b7b4
bug 1295907 - Disable tests not suitable for Thunderbird. r=kmag
Keywords: checkin-needed
(Assignee)

Updated

7 months ago
Flags: needinfo?(aleth)

Comment 12

7 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ef40e047b7b4
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla51

Comment 13

6 months ago
Thanks for doing this, I've added it here: https://wiki.mozilla.org/Add-ons/Contribute/Recognition#September_2016
(Assignee)

Updated

11 days ago
Blocks: 1346918
You need to log in before you can comment on or make changes to this bug.