create seabld user for Balrog interface

RESOLVED FIXED

Status

Release Engineering
Balrog: Frontend
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: ewong, Assigned: bhearsum)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Please create a user in the balrog admin, and allow
both ewong@pw-wspx.org and callek(he probably has access
already) to modify seabld's permissions. 

Thanks
(Reporter)

Updated

a year ago
Blocks: 1254401
(Assignee)

Comment 1

a year ago
Unfortunately, we don't have the ability to delegate permission granting. Callek has access because he has full access to Balrog, but I can't grant you the same. Here's what I have done:
- Granted ewong@pw-wspx.org full permission to all SeaMonkey Rules and Releases on https://aus4-admin.mozilla.org/ and https://balrog-admin.stage.mozaws.net/
- Granted seabld access to create or modify Releases, and modify Rules that affect SeaMonkey in prod.
- Granted sea-seabld access to create or modify Releases, and modify Rules that affect SeaMonkey in stage.

We try to avoid granting automation accounts more access than they need - so seabld/stage-seabld explicitly can't create Rules or delete Rules or Releases.

Sorry for the long delay here - I was waiting until some big changes to permissions made it to production to do this. Let me know if anything else is needed.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Assignee)

Updated

a year ago
Duplicate of this bug: 1331845
You need to log in before you can comment on or make changes to this bug.