Closed Bug 1294387 Opened 4 years ago Closed 1 year ago

When doing a keyword search in the address bar, show suggestions from the search engine associated with the keyword instead of the default search engine

Categories

(Firefox :: Address Bar, defect, P3)

48 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1496814

People

(Reporter: bruce.bugz, Unassigned)

References

Details

(Whiteboard: [fxsearch])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

Steps to reproduce:

1) Set Google as the default search engine.
2) Give the Wikipedia search engine a keyword of "w" (without quotes).
3) Do a search in the address bar for "w water" (without quotes).


Actual results:

Observed behaviour:

https://i.imgur.com/k7LpJYG.png
The first result is the Wikipedia page for 'Water' but all the other results are Google suggestions for things like 'w water' etc.




Expected results:

Expected behaviour:

https://i.imgur.com/D0dBkmg.png, as seen with the InstantFox add-on (https://addons.mozilla.org/en-US/firefox/addon/instantfox/)

The first result is the Wikipedia page for 'Water' and all the others are results to Wikipedia pages for things like 'watermelon' etc.


I think it is pretty obvious that keywords are meant to be phrases that won't often be a part of the actual search query themselves. On the few occasions that they need to be (e.g. I have a keyword 'gi' for a Google Image search and maybe I need to do a web search for 'gi joe'), it is easy to just add a '?' before the search term so that the keyword gets read as being a part of the search query. Also, a user is much less likely to be searching for things like "w water," "w waters ave" than they are to be looking for the Wikipedia pages for "watergate", "watermelon" etc. Lastly, if Wikipedia is set as the default search engine, Firefox does show suggestions from Wiki itself, so it certainly does have access to Wiki's suggestions API.

So the observed behaviour seems counter-intuitive and suggestions for keyword searches are practically useless beyond the first suggestion in its current state.
I filed this bug from Firefox v47, but the issue described is from Firefox v48. Also, apologies for the messed up formatting.
Status: UNCONFIRMED → NEW
QA Whiteboard: [bugday-20160815]
Component: Untriaged → Location Bar
Ever confirmed: true
Priority: -- → P3
Whiteboard: [fxsearch]
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1209991
I don't think this is a duplicate of Bug 1294387. That bug is merely about preventing typed words intended for a non-default search engine from leaking to it. My bug is a feature request - to have such typed words instead sent to the search engine associated with the keyword used and display suggestions from it; in the process addressing that bug as well. Both these things may be solved in the same go, but they don't look much like duplicates to me. That bug is more like a subset of this request rather than be a superset for it.

::mak, could you please confirm if these are indeed duplicates? I'm reopening it in the meantime because I amn't convinced. Also, is something like this planned or expected to get any attention? Both Opera and Vivaldi handle this pretty well - http://imgur.com/a/kMG65 .
Thanks.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
yeah it's not a dupe, thanks for clarifying.

We discussed introducing automatic keywords for engines in the past, and it may happen in the future, it's something we likely want.
I'm currently still on v47 with Foobar and, since that extension has not been getting updated, I've run into this bug when checking how much can be replicated with vanilla v49.

I really don't want Mozilla automatically determining my search engine keywords for me, but pre-populating them would be good for new users.

What I would love to see to see is:
- Add options checkbox to only search the web when you enter a keyword.
- Use search suggestions of keyword engine first, but fall back to default when they have none.
- Easy option to set the amount of search and places suggestions you get and which one is on top.

I like that you can now remove the search box yourself and have a big input bar, but it's still missing the feature-fullness of something like Foobar to make it truly effective and properly private.
It seems this submission is (tangentially) related as well:
https://bugzilla.mozilla.org/show_bug.cgi?id=1206967
I'm affected by this bug, this prevents me to enable search suggestions.
Also note that this behavior could be different depending to keyword.enabled value. If set to true, the default, it could still look for suggestions on the default search engine when you haven't typed a known search engine keyword (after a short period?). If set to false, it wouldn't.
Not sure if this bug needs to be limited to "not the default" as if google is the default, and you search with "@google" via bug 1480504, we probably want to show suggestions there too.

More generally, with bug 1479806 exposing keyworded searches more prominently, not sure if we want to prioritize this differently.

Aaron, is this more desired now? It would still be dependent on the search engine providing suggestions, and looks like amazon does for some locales; google, bing, duckduckgo, wikipedia have suggestions; but not ebay, twitter
Flags: needinfo?(abenson)
See Also: → 1480504, 1479806
I'd say yes this is much more desired now that we are exposing the search shortcut behavior via the top site tiles. We should, as much as possible, be showing suggestions based on the domain of the @-keyword entered.
Flags: needinfo?(abenson)
Status: REOPENED → RESOLVED
Closed: 4 years ago1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1496814
You need to log in before you can comment on or make changes to this bug.