Closed Bug 1496814 Opened 2 years ago Closed 2 years ago

Show only autosuggest results when search only engine alias is typed in the address bar

Categories

(Firefox :: Address Bar, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 64
Tracking Status
firefox64 + verified

People

(Reporter: mikedeboer, Assigned: adw)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [fxsearch])

Attachments

(1 file)

For a visual explanation, please see Verdi's second bulleted mockup over at https://mozilla.invisionapp.com/share/4POCDI07U9A#/screens/322966230_Seach_Bar_Changes_For_63

If possible, we'd try and make sure that whenever a search engine alias is entered followed by keywords, to show only the autosuggest results in the AwesomeBar.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Priority: -- → P1
Whiteboard: [fxsearch]
[Tracking Requested - why for this release]:

Moving the tracking? flag from bug 1496772 to this bug, per bug 1496772 comment 5:

(In reply to Mike de Boer [:mikedeboer] from bug 1496772 comment #0)
> [Tracking Requested - why for this release]:
> 
> There are a number of - should be - low effort changes to improve the search
> tiles/ keywords user interaction.
> We believe this will greatly impact the general usefulness, usability and
> users' perception of the feature when it launches in Firefox 63.
This is based on the patch in bug 1496811.

This patch looks a little worse than it probably is. (Maybe not by much.) Some of this is indentation changes, moving code around, renaming, and adding jsdocs. It looks like we missed the boat on uplifting this (and the other couple of bugs) to 63, so there's not a super-pressing need to keep the patch minimal.

PlacesSearchAutocompleteProvider assumes you're fetching suggestions from the current engine, so I had to modify it to take an engine. While I was doing that, I got a little frustrated with some of its implementation, naming, and interface. It seems like it was written to be a little more generic than it ended up being? There doesn't seem to be any need for it to return generic "match" objects instead of simply engines and `{ suggestion, historical }` objects, for example. The "defaultMatch" concept also doesn't make much sense IMO, especially with the aforementioned changes. So I made some improvements, hopefully, and I also added some jsdocs.
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/665fecc38740
Show only search suggestion results when only an engine alias and query are typed in the address bar r=mak
https://hg.mozilla.org/mozilla-central/rev/665fecc38740
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
Using the arrow keys to highlight a search suggestion ends up removing the search shortcut from the urlbar. Is this intentional? To be more specific:

STR:
1. Type `@google test`
2. Use down arrow key to highlight say the second suggestion

AR: urlbar says `testbook`. If I continue typing at this point, the search query is no longer being sent to Google but to my default engine.

ER: urlbar says `@google testbook` and Google remains "active." This feels more intuitive to me and allows[1] for further editing of the search query.

Also after STR1, the one-off section says `Search for @google test with:` followed by the usual list. After STR2, it says `Search for testbook with:`. Bug 1498023 will fix this, iiuc.


[1]Unsure if I'm explaining it correctly so as an example: I would like to be able to do the following:

Goal: Search Google for `telescope price`. Google is not the default engine.

Expected "lazy" steps:
i) Type `@google teles`
ii) Use down arrow to pick the `telescope` suggestion. At this point, urlbar should read `@google telescope` and continue to be in "queries being sent to Google" mode
iii) Type out ` p`. First suggestion is `telescope price`. Select it, urlbar changes to `@google telescope price`, press enter.
Duplicate of this bug: 1294387
Yeah, these are good points, Bruce.  I realized that the @engine text went away when you arrow down to the suggestions, but I didn't think about the fact that changing the suggestion and then selecting it would search with the default engine.  A lot of these interactions are underspecified tbh.  I'll file a new bug and mark it blocking this one.

Thanks for pointing out all the little corners where this stuff could use improvement, it's been helpful. :-)
Depends on: 1500516
This is verified fixed using Firefox 64.0b3 (BuildId:20181022150107) on the following OSes: Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.13.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Depends on: 1529642

I take it there's no way currently to have these suggestions for custom search keywords, which are defined on bookmarks? (Via “Add a keyword for this search.”)

  • Apparently the “@google” keywords are a separate feature from the ages-old bookmark keywords, which were used for search before.

  • Engine-specific suggestions do work on old-style keywords that are defined for engines from the list in the search preferences, possibly as a result of the work on this bug. For engines added with bookmarks, not so much—even if the engine has an OpenSearch definition with the suggestions feature. My guess is, OpenSearch definitions aren't saved with the bookmarks.

  • Afaik engine-specific suggestions do work via the separate search bar. The downside, besides the separate bar, is that URLs for these engines can't be edited (at least from inside the browser)—so I can't change sorting and filters from the default that the engine offers, while they can be changed for some engines via the URL in bookmarks.

Yes, correct. We have two different systems for doing keyword searches: search engine keywords and bookmark keywords. There may be a bug somewhere about unifying them, and I remember talking with Verdi about it when we worked on this bug and/or others, so it's possible we'll address it somehow, but it's not a priority right now afaik.

You need to log in before you can comment on or make changes to this bug.