Closed Bug 1294745 Opened 6 years ago Closed 6 years ago

Reader Mode Narrate - Stop/Play button skips remainder of paragraph

Categories

(Toolkit :: Reader Mode, defect, P3)

49 Branch
x86
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1255261

People

(Reporter: julesmyers2011, Unassigned)

Details

(Whiteboard: [reader-mode-narrate])

What did you do?
================
1. Went to https://www.free-ebooks.net/category/general-non-fiction
2. Opened to the page in reader mode.
3. Clicked on Narrate 
4. Played for a few seconds so some of the sentence/paragraph is read, then clicked on stop.
5. When I clicked on play the rest of the sentence and paragraph are skipped and narrate goes to the next paragraph.

What happened?
==============
When I clicked on play the rest of the sentence and paragraph are skipped and narrate goes to the next paragraph.

What should have happened?
==========================
Narrate should have continued where it left off.

Is there anything else we should know?
======================================
OS: Other → Mac OS X
Product: Mozilla Developer Network → Firefox
Hardware: All → x86
Whiteboard: [specification][type:bug] → [specification][type:bug] [testday-20160812]
Target Milestone: --- → Firefox 49
Version: unspecified → 49 Branch
I confirm this bug found during [testday-20160812] on Windows 7 32-bit SP 1.

(In reply to julesmyers2011 from comment #0)
> When I clicked on play the rest of the sentence and paragraph are skipped
> and narrate goes to the next paragraph.
> 
> What should have happened?
> ==========================
> Narrate should have continued where it left off.
> 
> Is there anything else we should know?
> ======================================

I think that the narration should start from the beginning. It's Play/Stop button not Play/Pause button.
Component: General → Reader Mode
Product: Firefox → Toolkit
Target Milestone: Firefox 49 → ---
I don't know that the text-to-speech API gives us a reliable indication of where it left off, so there are technical restrictions that might make this very difficult.

I also don't know that I'd agree that having it start in the middle of a sentence makes an awful lot of sense, or how to delineate "sentences" when there likely isn't always punctuation and Firefox has no idea how to "split" the paragraph into useful sentences/phrases (also: what would happen with poetry with no punctuation or even "odd" punctuation?). I don't think the tts engines expose "split this utterance into sentences" either. If you just have it restart in the middle of a word or sentence after a 2 minute pause, that seems useless as well.

So I'm leaning to wontfix, but I'll let Eitan make a decision.
Flags: needinfo?(eitan)
Priority: -- → P3
Summary: Text to Speech Feature - Stop/Play Button Skips Rest of Text → Reader Mode Narrate - Stop/Play button skips remainder of paragraph
Whiteboard: [specification][type:bug] [testday-20160812] → [reader-mode-narrate]
As harl said, this is not a play pause button. But pressing play again should read the same paragraph and not skip to next. This was resolved in bug 1255261.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(eitan)
Resolution: --- → DUPLICATE
Duplicate of bug: 1255261
You need to log in before you can comment on or make changes to this bug.