Closed Bug 1295249 Opened 3 years ago Closed 3 years ago

aboutdebugging: items in category sidebar are no longer centered vertically

Categories

(DevTools :: about:debugging, defect)

defect
Not set

Tracking

(firefox51 verified)

VERIFIED FIXED
Firefox 51
Tracking Status
firefox51 --- verified

People

(Reporter: jdescottes, Assigned: jdescottes)

References

Details

Attachments

(3 files)

STRs:
- go to about:debugging
- check the left sidebar items (categories)

ER: The items should be vertically centered
AR: The text and icon of each item is aligned to the top of its container.

Bug 1000957 modified the behavior of "align-content: center" for flex containers displaying a single line of content (see test case in attachment).

This technique was used to vertically align the items in about:debugging's sidebar. Let's first check if the behavior here is intentional.
Daniel: can you confirm the behavior displayed in the attached test-case here is correct according to the specs?
In Firefox 50, the items in the singleline container were vertically centered
In Firefox 51, they are aligned to the top.
Flags: needinfo?(dholbert)
Duplicate of this bug: 1295514
Looks like this is clearly explained in the specs now : https://www.w3.org/TR/2016/CR-css-flexbox-1-20160301/#propdef-align-content . "align-content" has no effect on single line flex containers.

> The align-content property aligns a flex container’s lines within the flex container when 
> there is extra space in the cross-axis, similar to how justify-content aligns individual 
> items within the main-axis. Note, this property has no effect on a single-line flex container.
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Flags: needinfo?(dholbert)
Right, yeah.  And in my opinion, your proposed patch is indeed the correct way to fix this bug.
Comment on attachment 8781498 [details]
Bug 1295249 - aboutdebugging: fix alignment of sidebar items;

https://reviewboard.mozilla.org/r/71912/#review69992

LGTM!
Attachment #8781498 - Flags: review?(janx) → review+
Thanks for the review, checkin-needed.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c8d1ed197537
aboutdebugging: fix alignment of sidebar items;r=janx
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/c8d1ed197537
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
I have reproduced this bug with Firefox nightly 51.0a1(build id:20160815030201)on
windows 7(64 bit)

I have verified this bug as fixed with Firefox nightly 51.0a1(build id:20160822064441)
User Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

[bugday-20160824]
I have reproduced this bug with Nightly 51.0a1 (2016-08-15) on Linux Mint 18, 64 bit!

The bug's fix is now verified on latest Nightly 51.0a1.

Nightly 51.0a1:
Build ID 	20160830030201
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0

[bugday-20160831]
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.