Closed Bug 1295351 Opened 4 years ago Closed 3 years ago

iOS implementation of faster "send tabs to device" using Push

Categories

(Firefox for iOS :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1333765
Tracking Status
fxios 8.0+ ---

People

(Reporter: eoger, Unassigned)

References

Details

(Whiteboard: [send-tab])

+++ This bug was initially created as a clone of Bug #1295348 +++

iOS equivalent of bug 1295348. Let's speed up send tabs to device on iOS.
This patch should be a bit more tricky, because we need to be careful not to drain to device battery/data usage by Syncing all the time.
Conversation that might help make decisions here: https://github.com/mozilla/fxa-auth-server/issues/1316
A quick win here until we have push on iOS would be to do only the sending part:
Send a request to fxa/account/devices/notify after syncing the clients collection if we wrote in another client's record.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1333765
You need to log in before you can comment on or make changes to this bug.