Tabs with a favicon displayed don't show the loading indicator image

RESOLVED FIXED in seamonkey2.48

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: frg, Assigned: frg)

Tracking

(Blocks 1 bug)

SeaMonkey 2.45 Branch
seamonkey2.48
All
Unspecified
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.44 unaffected, seamonkey2.45 fixed, seamonkey2.46 fixed, seamonkey2.47 fixed, seamonkey2.48 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Assignee

Description

3 years ago
Since bug 1272401 got fixed if you load or reload a new tab the loading throbber will no longer display if a favicon is already shown in the tab.

The image attribute needs to be removed from the tab while busy for this to work. This was removed in above bug.
Assignee

Comment 1

3 years ago
Posted patch 1296838-loadingthrobber.patch (obsolete) — Splinter Review
Attachment #8783179 - Flags: review?(philip.chee)

Comment 2

3 years ago
Comment on attachment 8783179 [details] [diff] [review]
1296838-loadingthrobber.patch

That doesn't work properly for me on Linux (KDE4/GTK3).

Yes, the throbber on the respective tab shows up again even if the current tab has a favicon set, then also sets the new favicon once done, but then it is immediately replaced with the generic icon for a page without favicon.

suite/themes/classic/communicator/bookmarks/bookmark-item.png

Thus, it looks like this.mTab.removeAttribute("image"); is also executed when the page has completed loading, then removing the favicon again which was just set elsewhere.
Assignee

Comment 3

3 years ago
I finally got CentOS compiling and running right yesterday. I will look into it during the weekend. Patch for Bug 1296850 isn't meant as a dependency for this one.

Is aggressively look for website icons checked in your profile?

FRG

Comment 4

3 years ago
(In reply to rsx11m from comment #2)
> That doesn't work properly for me on Linux (KDE4/GTK3).
> 
> Yes, the throbber on the respective tab shows up again even if the current
> tab has a favicon set, then also sets the new favicon once done, but then it
> is immediately replaced with the generic icon for a page without favicon.
@rsx11m: What website(s) do you see this happen on?  I did a test build with this patch (SeaMonkey 2.46 linux64 w/ gtk2), and I cannot reproduce that behavior except at http://html5test.com/
All other sites I've browsed, the favicon sticks..

Comment 5

3 years ago
(In reply to Frank-Rainer Grahl from comment #3)
> Is aggressively look for website icons checked in your profile?

New profile = box is unchecked.

(In reply to kevink9876543 from comment #4)
> @rsx11m: What website(s) do you see this happen on?  I did a test build with
> this patch (SeaMonkey 2.46 linux64 w/ gtk2), and I cannot reproduce that

Something as simple as https://bugzilla.mozilla.org/

I'm using SeaMonkey 2.48a1 linux64 w/ gtk3.
                      ^^^^               ^

Comment 6

3 years ago
(In reply to rsx11m from comment #5)
> Something as simple as https://bugzilla.mozilla.org/
> 
> I'm using SeaMonkey 2.48a1 linux64 w/ gtk3.
I put the change in the omni.ja of this official build https://ftp.mozilla.org/pub/seamonkey/nightly/2016/08/2016-08-18-00-30-02-comm-central-trunk/ , still get the same results there.

Comment 7

3 years ago
No clue what's going on (that's my own build, but I don't think I've mangled any other patches into it which may interfere), let's wait for frg if he can reproduce it.
Assignee

Comment 8

3 years ago
I can reproduce it on html5test.com under Windows if I enable scripts for whichbrowser.net. Something funky going on here. Need to try 2.44 and Firefox to see if this is also the case there. Will try Linux later when I am back on the desktop.
Assignee

Comment 9

3 years ago
This should finally work. Tested on html5test.com and bugzilla.
Attachment #8783179 - Attachment is obsolete: true
Attachment #8783179 - Flags: review?(philip.chee)
Attachment #8785625 - Flags: review?(philip.chee)
Assignee

Updated

3 years ago
Blocks: 1296850

Comment 10

3 years ago
Comment on attachment 8785625 [details] [diff] [review]
1296838-loadingthrobber-V2.patch

r=me a=me please land on all branches a=me
Attachment #8785625 - Flags: review?(philip.chee)
Attachment #8785625 - Flags: review+
Attachment #8785625 - Flags: approval-comm-release+
Attachment #8785625 - Flags: approval-comm-beta+
Attachment #8785625 - Flags: approval-comm-aurora+

Updated

3 years ago
Target Milestone: --- → seamonkey2.48
Version: SeaMonkey 2.48 Branch → SeaMonkey 2.45 Branch
You need to log in before you can comment on or make changes to this bug.