Filter UI: Enter while focus is on New/Edit/Del/Move button will close dialog.

RESOLVED WORKSFORME

Status

MailNews Core
Filters
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: laurel, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

(Reporter)

Description

16 years ago
Using mar08 commercial trunk, win98 & linux rh6.2

I thought maybe this was logged a long time ago, but didn't find it. Could be a
mention in some older cluttered bug.

Now that we're implementing more accessibility and just recently in filters (bug
40761) this may be a bit more visible.

When tabbing or otherwise focus placed on any of the action buttons (New, Edit,
Delete, Move Up, Move Down) in the main filter list dialog, if you hit Enter the
dialog is dismissed instead of opening the filter rules (for New or Edit) or
doing appropriate action (for Delete,Move Up/Down).

Steps:
1.  Edit|Message Filters.
2.  Tab to focus on the New button.  Press Enter.

Result:  filter ui dismissed.

Expected:  filter rules dialog should open.

Comment 1

16 years ago
I'm looking into this... this is due to the OK button on the window taking control.

Comment 2

16 years ago
Created attachment 73260 [details] [diff] [review]
Patch

dialogOverlay.xul is deprecated, and all new windows/dialogs should use
<dialog/>. This focus bug is fixed in <dialog/>, so the fix is to convert
FilterListDialog (FilterEditor is already converted).
your changes make me worry that you broke some of the pre-fill-filter feature.

cc varada, who would better than me.

Comment 4

16 years ago
I tried "Create Filter", and it worked.  Can you give me a testcase that you
think I broke?

Comment 5

16 years ago
Worked from the context-menu on message headers as well.

Comment 6

16 years ago
I spoke to varada over AIM, and asked what tests I should perform to ensure I
didn't break anything.  Result: everything works fine, no regressions found.

I'll continue searching for a reviewer.

Comment 7

16 years ago
Comment on attachment 73260 [details] [diff] [review]
Patch

You don't need to call window.close anywhere, the dialog handles that
automatically.	So, you don't really need the ondialogcancel handler at all. 
Remove that por favor, and then count the sr=hewitt
Attachment #73260 - Flags: superreview+

Comment 8

16 years ago
Created attachment 74317 [details] [diff] [review]
Updated patch

Patch with hewitt's comment adressed.

Per request, here are the list of things to test varada gave me over AIM:

1. Right-click on a mail-address and Create Filter.
2. Choose "Create Filter" from the Message menu on a selected message.
3. Make sure the "OK" and "Cancel" buttons work alright in the Filter Editor
after "Create Filter".
Attachment #73260 - Attachment is obsolete: true

Comment 9

16 years ago
Comment on attachment 74317 [details] [diff] [review]
Updated patch

Carry sr=.
Attachment #74317 - Flags: superreview+
I tried this patch, and it looks like it breaks pre-fill filter.

right click on a email addresses in the header area of the message pane, do
"Create Filter"

taking from naving, since he's on vacation.
Assignee: naving → sspitzer
Attachment #74317 - Attachment is obsolete: true
Attachment #74317 - Flags: needs-work+
Comment on attachment 74317 [details] [diff] [review]
Updated patch

this breaks a the pre-fill filter feature.

Comment 12

16 years ago
I swear that this worked when I tried it... :-(

Comment 13

15 years ago
This problem appears to have been corrected, 1.5-Final, Win2K.

Comment 14

15 years ago
No response... => WFM
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.