Closed Bug 1297367 Opened 3 years ago Closed 3 years ago

Call iCC slice and forgetSkippable right after paint

Categories

(Core :: DOM: Core & HTML, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox51 --- fixed

People

(Reporter: smaug, Assigned: smaug)

References

Details

Attachments

(3 files)

...so that we'd have as much as possible time before the next refreshdriver tick.

The patch also moves NotifyDidPaint() calls a bit later so that DidRefresh callbacks have chance to run before the slow operations.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=e7449fcbdfc3
Comment on attachment 8783934 [details] [diff] [review]
iccslice_forgetskippable_right_after_paint.diff

I think I'd like to try this. We should push more stuff to happen right after painting, and not at random time between paints, so that it is more likely that we don't miss any paints.
And GC already does something like this.
Copy-pasting timer initialization isn't perhaps the nicest but adding some helper wouldn't help much since in this case we want to re-init timers only if timers haven't been released during ICCTimerFired/CCTimerFired calls. So the code isn't exactly the same as in the other place where the timers are initialized.


We should also add some telemetry probes to detect when GC or CC is running when refreshdriver should tick, in some other bug.
Attachment #8783934 - Flags: review?(continuation)
Attachment #8783934 - Flags: review?(continuation) → review+
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/649c62d13b57
Call iCC slice and forgetSkippable right after paint, r=mccr8
Assignee: nobody → bugs
Depends on: 1297977
https://hg.mozilla.org/mozilla-central/rev/649c62d13b57
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Backed out per bug 1297977.
https://hg.mozilla.org/mozilla-central/rev/7963ebdd52b9
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla51 → ---
Comment on attachment 8789617 [details] [diff] [review]
iccslice_forgetskippable_right_after_paint_2.diff

Doesn't seem to regress per tryserver talos

interdiff works quite well here.
https://bugzilla.mozilla.org/attachment.cgi?oldid=8783934&action=interdiff&newid=8789617&headers=1
Attachment #8789617 - Flags: review?(continuation)
Attachment #8789617 - Flags: review?(continuation) → review+
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/32c103f71eff
Call iCC slice and forgetSkippable right after paint, r=mccr8
Depends on: 1302347
https://hg.mozilla.org/mozilla-central/rev/32c103f71eff
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Backout by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/16e3043a7ab7
backout because of tart regression, r=backout
Attached patch v3Splinter Review
This would remove gc/cc slices from tart, but apparently avih doesn't want that.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=8c91a90b60c6 is anyhow talos run for that, but I'll re-land v2.
Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c4e8525415a0
Call iCC slice and forgetSkippable right after paint, r=mccr8
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.