Closed Bug 1297806 Opened 3 years ago Closed 3 years ago

15% linux cart regressions from bug 1022573

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 51
Tracking Status
firefox51 --- fixed

People

(Reporter: jmaher, Assigned: dao)

References

Details

Attachments

(4 files)

from bug 1295502, we have two patches in the same push and each patch has a unique set of regressions- the patch in bug 1295502 will fix everything but the linux cart regressions- lets fix that here.

for the backstory, you can see backing out the patch yields the win:
https://bugzilla.mozilla.org/show_bug.cgi?id=1295502#c10
To fix this I think we need to avoid the fill filter and replace menuPanel.png with an SVG instead. Stephen, can you provide the SVG or delegate to someone to do so?
Flags: needinfo?(shorlander)
Version: 50 Branch → Trunk
Priority: -- → P1
(In reply to Dão Gottwald [:dao] from comment #1)
> To fix this I think we need to avoid the fill filter and replace
> menuPanel.png with an SVG instead. Stephen, can you provide the SVG or
> delegate to someone to do so?

We need menuPanel.png in the current sprite layout but as an SVG instead?
Flags: needinfo?(shorlander)
A sprite would be easiest to replace the PNGs with, but I think long term we'll want to get rid of the coordinates and use ids instead. We might as well make that change here.
Flags: needinfo?(dao+bmo)
Flags: needinfo?(shorlander)
(In reply to Dão Gottwald [:dao] from comment #3)
> A sprite would be easiest to replace the PNGs with, but I think long term
> we'll want to get rid of the coordinates and use ids instead. We might as
> well make that change here.

Though considering that these might have different performance characteristics (i.e. I think ids might be slower due to Gecko bugs), maybe we should start with the sprite for the purpose of this bug :/
:dao what are the next steps here?  We will be merging to Aurora next week.
Flags: needinfo?(dao+bmo)
Stephen is still preparing the SVGs.
Flags: needinfo?(dao+bmo)
(In reply to Dão Gottwald [:dao] from comment #6)
> Stephen is still preparing the SVGs.

I will get that to you today.
Attached image menuPanel.svg
Updated menuPanel.png sprite to menuPanel.svg sprite. Should be mostly the same, I had to make a few tweaks and updated the webIDE icon (not even sure if we use that anymore).
Flags: needinfo?(shorlander)
Stephen, could I please get the SVG version of menuPanel-small.png too? Thanks!
Flags: needinfo?(shorlander)
Whiteboard: [assets-needed]
(In reply to Dão Gottwald [:dao] from comment #9)
> Stephen, could I please get the SVG version of menuPanel-small.png too?
> Thanks!

Yes. I will do that today.
Flags: needinfo?(shorlander)
Attached patch patchSplinter Review
Thanks Stephen!
Attachment #8789899 - Flags: review?(mconley)
thanks for the work here!  As a note, we are merging Firefox 51 to Aurora this week- which means that we should consider uplifting this patch to Aurora once we land it on central.
I intend to land this before 51 moves to aurora.
Comment on attachment 8789899 [details] [diff] [review]
patch

Review of attachment 8789899 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good - thanks Dao!
Attachment #8789899 - Flags: review?(mconley) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cbe381245f03
Replace menuPanel.png / menuPanel-small.png and the fill filter with menuPanel.svg / menuPanel-small.svg to fix customize mode animation regression on Linux. r=mconley
https://hg.mozilla.org/mozilla-central/rev/cbe381245f03
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Incidentally this gives us a small installer size win:

== Change summary for alert #3115 (as of September 13 2016 10:21 UTC) ==

Improvements:

  0%  installer size summary windowsxp opt         53574766 -> 53373114.17
  0%  installer size summary windows8-64 opt       57569298.83 -> 57370336.25
  0%  installer size summary windowsxp debug       66902027.83 -> 66702231
  0%  installer size summary windows8-64 debug     79852025.08 -> 79651911.5

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=3115
You need to log in before you can comment on or make changes to this bug.