Closed Bug 1297850 Opened 3 years ago Closed 3 years ago

Remove dead code left after removal of JPZ

Categories

(Firefox for Android :: Toolbar, defect, P3)

51 Branch
Unspecified
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 51
Tracking Status
firefox50 --- unaffected
firefox51 --- fixed

People

(Reporter: rbarker, Assigned: rbarker)

References

Details

Attachments

(3 files)

The removal of JPZ in Bug 1291373 left dead code behind.
Depends on: 1291373
Assignee: nobody → rbarker
Attachment #8784581 - Flags: review?(nchen)
Attachment #8784584 - Flags: review?(nchen)
OS: Unspecified → Android
Priority: -- → P3
Version: unspecified → 51 Branch
Attachment #8784584 - Flags: review?(nchen) → review+
Attachment #8784581 - Flags: review?(nchen) → review+
Pushed by rbarker@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/979694026137
part 1, Remove dead code left behind after JPZ removal. r=jchen
https://hg.mozilla.org/integration/mozilla-inbound/rev/e83c9eb279a9
part 2, Background is no longer cleared by Java. Remove unused setBackgroundColor. r=jchen
(In reply to Wes Kocher (:KWierso) from comment #4)
> When this landed, robocop tests started failing like
> https://treeherder.mozilla.org/logviewer.html#?job_id=34655495&repo=mozilla-
> inbound
> 
> Backed out in
> https://hg.mozilla.org/integration/mozilla-inbound/rev/29f62a5e5273

Based on the stack trace it isn't obvious how the two are related but I will look in to it.
Flags: needinfo?(rbarker)
(In reply to Wes Kocher (:KWierso) from comment #6)
> Definitely started with your patches and went away on the backout:
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-
> searchStr=api15%20(rc1&fromchange=814753913f49e7065a942e55a85ba8569e3f3874&to
> change=29f62a5e52735d44a53071611915b32e0b4e40aa

I figured it out. ProGuard started erroneously stripping out a class. Running on try now to verify.
Attachment #8784974 - Flags: review?(nchen) → review+
Ran on try with fix: https://treeherder.mozilla.org/#/jobs?repo=try&revision=7494f8153308

While I'm seeing a number failures, I'm not see the issue that caused the back out so will try and re-land with fix.
Pushed by rbarker@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b2b2bb8abf7b
part 1, Remove dead code left behind after JPZ removal. r=jchen
https://hg.mozilla.org/integration/mozilla-inbound/rev/1641b474f9d3
part 2, Background is no longer cleared by Java. Remove unused setBackgroundColor. r=jchen
https://hg.mozilla.org/integration/mozilla-inbound/rev/9a7524861d8b
part 3, Fix Robocop breakage caused by proguard stripping out URLMetadata r=jchen
Depends on: 1415297
Blocks: 1415307
You need to log in before you can comment on or make changes to this bug.