Last Comment Bug 1298054 - Deprecate support for iOS 8
: Deprecate support for iOS 8
Status: RESOLVED FIXED
[MobileAS]
:
Product: Firefox for iOS
Classification: Client Software
Component: General (show other bugs)
: unspecified
: Other iOS
P1 normal 2
: ---
Assigned To: Brian Nicholson (:bnicholson)
:
: Stephan Leroux [:sleroux]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-08-25 08:08 PDT by Aaron Train [:aaronmt]
Modified: 2016-10-20 10:37 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: 1.5
Points: ---
Has Regression Range: ---
Has STR: ---
6.0+
fixed


Attachments
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/2111 (48 bytes, text/x-github-pull-request)
2016-09-21 14:15 PDT, Brian Nicholson (:bnicholson)
sleroux: review+
Details | Review | Splinter Review

Description User image Aaron Train [:aaronmt] 2016-08-25 08:08:38 PDT

    
Comment 1 User image Brian Nicholson (:bnicholson) 2016-08-30 08:29:37 PDT
With iOS 10 around the corner, this is a good time to finally drop 8 support.
Comment 2 User image Brian Nicholson (:bnicholson) 2016-09-21 13:58:18 PDT
Not requiring these #available checks for iOS 9 will make life easier for bug 1304456, and we'll have to eventually do this anyway, so let's go ahead and knock this one out now.
Comment 3 User image Brian Nicholson (:bnicholson) 2016-09-21 14:15:51 PDT
Created attachment 8793503 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/2111
Comment 4 User image Stephan Leroux [:sleroux] 2016-09-22 06:32:42 PDT
Comment on attachment 8793503 [details] [review]
Link to Github pull-request: https://github.com/mozilla/firefox-ios/pull/2111

Awesome. Thanks for fixing the keychain stuff I missed in the test targets.
Comment 6 User image Maurya Talisetti 2016-09-28 09:38:41 PDT
Hi Brian,

Was there any burden, code-wise, or any compromises we had to make, that we dropped support for iOS 8? I thought it was only the 'if #available' checks that were extra.

Just curious, since I'm on iPhone 4s/iOS 8 and don't want to move to iOS 9 as it might slow it down.
Comment 7 User image Brian Nicholson (:bnicholson) 2016-09-28 15:28:43 PDT
Hi Maurya,

There's a growing number of features and APIs with each iOS release, so maintaining support for older releases becomes a huge maintenance burden.

Examples from iOS 9:
* Private browsing
* Clearing private data
* New XCTest APIs

This list will grow longer with iOS 10.

Code-wise, we worked around many of these using 'if #available' checks as you said, but maintaining support for 8 means we also need to test and run iOS 8 builds often to make sure they're stable. We were already neglecting iOS 8 before; we just don't have the resources to maintain 8, 9, *and* 10 now.
Comment 8 User image Maurya Talisetti 2016-09-28 22:14:30 PDT
Hmm, yeah that sounds reasonable. Thanks for your reply!

Note You need to log in before you can comment on or make changes to this bug.