Rendering broken after enabling OpenGL acceleration

RESOLVED INVALID

Status

()

Core
Graphics: Layers
P3
normal
RESOLVED INVALID
a year ago
11 months ago

People

(Reporter: marco, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {regression})

51 Branch
Unspecified
Linux
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 unaffected, firefox53 fix-optional)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

a year ago
Firefox isn't rendering anything anymore (the window is completely gray), I've found a regression range with mozregression:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8ef9629d8f90d6507b1bad01146b14101de79174&tochange=30fa88c82366a358f412ca2cc3268142c8991f0d

I can see the rendered content briefly when I close the window.

The gfx card is an "AMD Radeon HD 6310 Graphics", with driver "4.3.12798 Compatibility Profile Context 8.96.7".

Ubuntu Precise Pangolin with kernel 3.2.0-109.

Comment 1

a year ago
Proprietary driver for your GPU is obsolete. Open source driver is recommended for VLIW-based GPUs by AMD. If possible, update to newer distribution (fglrx will get automatically uninstalled while upgrade to 16.04).
(Reporter)

Comment 2

a year ago
This is the standard configuration on 12.04, if we can't support the driver we should blocklist it.

Comment 3

a year ago
In 2012, I think hardware acceleration wasn't even enabled in Windows.. 
Then, besides, why aren't you *at least* using updated drivers?

I don't know if newer fglrx is okay, but there have been plenty of releases since.. what's that? Like the default catalyst 12.4?
http://support.amd.com/it-it/download/desktop/previous/detail?os=Ubuntu%20x86%2064&rev=15.9
(Reporter)

Comment 4

a year ago
(In reply to mirh from comment #3)
> In 2012, I think hardware acceleration wasn't even enabled in Windows.. 
> Then, besides, why aren't you *at least* using updated drivers?
> 
> I don't know if newer fglrx is okay, but there have been plenty of releases
> since.. what's that? Like the default catalyst 12.4?
> http://support.amd.com/it-it/download/desktop/previous/
> detail?os=Ubuntu%20x86%2064&rev=15.9

I'm using the latest drivers available in the 12.04 repositories.

But it doesn't really matter, even if they weren't the latest available drivers on 12.04, we should not enable hardware acceleration for configurations that aren't supported. We have a way (a blocklist) to block hardware acceleration for broken drivers, why shouldn't we use it?

Anyway, I believe this will be fixed with bug 1294232. I will retest after bug 1294232 is fixed.
Depends on: 1294232
Whiteboard: [gfx-noted]

Comment 5

a year ago
Blacklisting is *how* you fix the problem, but I think we should first try to understand **what** (or where?) is the problem. 

I guess we can all agree in that state configuration isn't supported, but if that wasn't latest driver (like it really seem http://it.archive.ubuntu.com/ubuntu/ubuntu/pool/restricted/f/fglrx-installer/), there still a chance?
(Reporter)

Updated

a year ago
status-firefox50: --- → unaffected
status-firefox51: --- → affected
Version: 40 Branch → 51 Branch

Comment 6

a year ago
I just tried on your same gpu with latest fglrx (4.5.13399 Compatibility Profile Context 15.201.1151)
I get a Can not find symbol EGLImageTargetRenderbufferStorageOES error on terminal, then as soon as I choose "start" on the profile window, the process closes.
(Reporter)

Comment 7

a year ago
Would this error be fixed by blocklisting?
Flags: needinfo?(andrew)

Comment 8

a year ago
I now tried by main firefox profile (rather than my empty testing one)... And for no reason firefox can start. 
And the crazy thing is that I then copied the whole working profile folder to the crashing one.. And it still crashed. 

Is there any other "personal" directory aside ~/.mozilla/firefox/*profile_name* ?

Also, I just checked info about this EGLImageTargetRenderbufferStorageOES https://www.khronos.org/registry/gles/extensions/OES/OES_EGL_image.txt
It states that when OES_framebuffer_object ext isn't available the aforementioned operation is invalid. 
So... at least this error (warning?) I get in terminal (that may or may not be related to the crash and to your rendering problems) seems a thing from the firefox side.
I have a related issue on the latest Nightly with an ATI R7 390 card with fglrx 2:13.350.1-0ubuntu0.0.1 driver.

Comment 10

a year ago
(In reply to Ciprian Muresan [:cmuresan] from comment #9)
> I have a related issue on the latest Nightly with an ATI R7 390 card with
> fglrx 2:13.350.1-0ubuntu0.0.1 driver.

Which (hoping I haven't misunderstand fglrx_drv.so) is what everybody else knows as Catalyst 14.4
... 

why don't you people update your drivers?
(Reporter)

Comment 11

a year ago
(In reply to mirh from comment #10)
> why don't you people update your drivers?

We're testing with the default configuration of the distributions, which
is what a lot of people use, to make sure they work.
When they don't work, we need to decide between blocklisting/fixing the
issue (I would expect these drivers to be blocklisted, since they're
so old).

Comment 12

a year ago
Ok, that sounds fair. 
But I guess you'll have to decide which fglrx versions to blocklist sooner or later. 

And then, should you discover critical bugs are still a thing in latest 15.x branch.. What was even the point in the "accurate" testing?
Yes, we could fix this by blocklisting. I'd like to know first whether a "modern" fglrx driver works; we have some very old workarounds for fglrx in our GLX context provider whose assumptions may be incorrect now. Unfortunately, I don't have an AMD card to test on.
Flags: needinfo?(andrew)
Priority: -- → P3
See Also: → bug 1304095
Linux acceleration is nightly only.
status-firefox51: affected → unaffected
status-firefox52: --- → affected
nightly only bug, moving to 53
status-firefox52: affected → unaffected
status-firefox53: --- → affected
(In reply to Julien Cristau [:jcristau] from comment #15)
> nightly only bug, moving to 53

After bug 1323284, acceleration is off by default in nightly as well.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
status-firefox53: affected → fix-optional
Resolution: --- → WONTFIX

Updated

11 months ago
Resolution: WONTFIX → INVALID

Comment 17

11 months ago
I hope this may be re-opened once you find the manpower to dedicate to gpu acceleration.
(In reply to mirh from comment #17)
> I hope this may be re-opened once you find the manpower to dedicate to gpu
> acceleration.

Yes!  It was a difficult decision, but we couldn't get it past nightly, and we couldn't keep it just on nightly for any longer.
You need to log in before you can comment on or make changes to this bug.