[webvr] When I enter into VR mode, Oculus Rift does not connect

RESOLVED WORKSFORME
(Needinfo from 2 people)

Status

()

RESOLVED WORKSFORME
2 years ago
23 days ago

People

(Reporter: rlyle78, Unassigned, NeedInfo)

Tracking

51 Branch
Unspecified
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted][webvr])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36

Steps to reproduce:

When I enter VR Mode like in Aframe sample website, it will get head tracking but nothing shows up on Oculus Rift. I have Oculus Rift and HTC Vive installed on my machine. I even checked webvr.info samples and it crashes the browser. FireFox version 51.0a1 (2016-08-14) works. After that 08-14, it does not work anymore.


Actual results:

Oculus Rift will display "Please Wait", nothing happens. display won't connect to the oculus Rift but head tracking works.


Expected results:

Enter into VR Mode
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10

Updated

2 years ago
QA Whiteboard: [bugday-20160829]
Component: Untriaged → Graphics
Product: Firefox → Core

Updated

2 years ago
Whiteboard: [gfx-noted]

Comment 1

2 years ago
I am having the same problem. Did you find the solution? 

Thanks in advance.
Whiteboard: [gfx-noted] → [gfx-noted][webvr]
Hi, could you please retry again with the latest Firefox Nightly (https://nightly.mozilla.org/) builds and provide a sample URL? Thanks!
Flags: needinfo?(rlyle78)

Comment 3

2 years ago
I'm encountering the same issues. Example URL: https://aframe.io/examples/showcase/helloworld/

Comment 4

2 years ago
(In reply to vaughn from comment #3)
> I'm encountering the same issues. Example URL:
> https://aframe.io/examples/showcase/helloworld/

I'm on the latest nightly as of 11/6/2016
Summary: WebVR - when I enter into VR mode, Oculus Rift does not connect → [webvr] When I enter into VR mode, Oculus Rift does not connect
I believe that is because we are working on GPU process, and it breaks the Oculus support. I can reproduce it in e10s mode, and non-e10s is good. Please have a look at Bug 1316279.
Depends on: 1316279

Comment 6

2 years ago
For the record, I can confirm that disabling e10s works. I am able, for the most part, to launch a WebVR session using reasonably recent builds of A-frame. This is pretty buggy though, as the browser frequently forgets that the Oculus is available and enters Full-screen mode instead. Empirically, if I shut down FF. restart Oculus Home, activate the HMD by looking at the Oculus Home app, then re-launch FF, I am able to restore function. I'm not qualified to guess what, but it seems like some key process gets reset by this set of actions.

Comment 7

2 years ago
I'm on Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 Build 20161109030210
Component: Graphics → WebVR

Comment 8

2 years ago
I'm also experiencing this exact issue, however disabling "Enable multi-process Nightly" does NOT resolve the issue for me.
Went through the usual (make sure external sources allowed, restart computer, restart oculus, restart firefox) steps and it's still not working.

For what it's worth, I haven't been able to get the Chrome developer build to work either.

Does anyone have debugging steps I can try to get it working?
(In reply to andrew from comment #8)
> I'm also experiencing this exact issue, however disabling "Enable
> multi-process Nightly" does NOT resolve the issue for me.
> Went through the usual (make sure external sources allowed, restart
> computer, restart oculus, restart firefox) steps and it's still not working.
> 
> For what it's worth, I haven't been able to get the Chrome developer build
> to work either.
> 
> Does anyone have debugging steps I can try to get it working?

Does setting security.sandbox.gpu.level to "0" in about:preferences and restarting the browser solve your issue?

If so, this should be fixed by Bug 1361719, which will be landing in a couple of days.

Otherwise, could you share a web site that this is failing on?
Also, please try this site and let me know if it behaves differently:

https://webvr.info/samples/03-vr-presentation.html
Flags: needinfo?(andrew)
(In reply to :kip (Kearwood Gilbert) from comment #9)

> Does setting security.sandbox.gpu.level to "0" in about:preferences and
> restarting the browser solve your issue?
> 

Correction:

about:preferences -> about:config

Comment 11

a year ago
I just had this issue with https://edorble.com/webvr and an Oculus.

It goes to full screen mode when I click the VR button, but it doesn't go stereoscopic.

Comment 12

a year ago
This issue seems to pop up again in Firefox 57. The Oculusshows tracking on the PC's screen, but not on the Oculus's display itself. 

Downgrading to Firefox 56 seems to solve the issue.

Comment 13

a year ago
I've been able to mitigate this issue on my Oculus Rift by launching SteamVR manually before launching Firefox and navigating to a WebVR page.
I reproduced this issue using nightly 51.0a1 (build ID: 20160814030203). This issue is no longer reproducible using Fx 62.0.3, Fx 63.0, Fx 64.0b3 and Fx 65.0a1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 23 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.