Back shared persistent buffer provider out from aurora

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: nical, Assigned: nical)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 fixed)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment, 1 obsolete attachment)

Enabled on all platforms except windows. There are regressions and a number of patches that fix them, a few of which have been uplifted already, but I'm not super comfortable with uplifting all of it considering the numerous changes.
I would like to secure plan B: backing the regressing patch out from aurora along with whatever got uplifted, as a potentially less risky solution.
Posted patch Disable BufferProviderShared (obsolete) — Splinter Review
Attachment #8788180 - Flags: review?(bas)
It turns out to be tricky to back every buffer provider related change, so my current plan is to disable it and only uplift the few patches that affect the code paths where it is disabled.
The previous patch was empty.
Attachment #8788180 - Attachment is obsolete: true
Attachment #8788180 - Flags: review?(bas)
Attachment #8788198 - Flags: review?(bas)
Attachment #8788198 - Flags: review?(bas) → review+
Comment on attachment 8788198 [details] [diff] [review]
Disable BufferProviderShared

Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]: crashes and correctness issues.
[Describe test coverage new/current, TreeHerder]: None.
[Risks and why]: low risk, the majority of our users have this pref disabled already.
[String/UUID change made/needed]: None.

This patch go to aurora directly, not central.
Attachment #8788198 - Flags: approval-mozilla-aurora?
Comment on attachment 8788198 [details] [diff] [review]
Disable BufferProviderShared

Makes sense, Aurora50+
Attachment #8788198 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.