PersistentBufferProviderShared regressions

REOPENED
Assigned to

Status

()

Core
Graphics: Layers
P3
normal
REOPENED
2 years ago
11 months ago

People

(Reporter: nical, Assigned: nical)

Tracking

(Blocks: 1 bug)

unspecified
mozilla50
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 fixed, firefox51 fixed)

Details

(Whiteboard: [gfx-noted][leave-open])

Attachments

(2 attachments)

(Assignee)

Description

2 years ago
There are some canvas rendering issues with PersistentBufferProviderShared (preffed off in bug 1284721). We need to figure them out and reenable it.
(Assignee)

Updated

2 years ago
Depends on: 1284723
(Assignee)

Updated

2 years ago
Depends on: 1284705
(Assignee)

Updated

2 years ago
No longer depends on: 1284705
(Assignee)

Updated

2 years ago
Depends on: 1284705
(Assignee)

Updated

2 years ago
Summary: Race condition with PersistentBufferProviderShared → PersistentBufferProviderShared regressions
(Assignee)

Updated

2 years ago
Depends on: 1284384
(Assignee)

Updated

2 years ago
Depends on: 1289105
(Assignee)

Comment 1

2 years ago
Created attachment 8775171 [details] [diff] [review]
Reenable copy-on-write canvas.

All of the problems that I could reproduce have been fixed and the remaining open bug is probably fixed although I haven't been able to verify it yet since I haven't reproduced it.

We should be good to re-enable it now.
Attachment #8775171 - Flags: review?(jnicol)

Updated

2 years ago
Attachment #8775171 - Flags: review?(jnicol) → review+
(Assignee)

Updated

2 years ago
Blocks: 1290072

Comment 2

2 years ago
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d32a26786b30
Reenable copy-on-write canvas. r=jnicol

Comment 4

2 years ago
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c16134a5a20f
Reenable copy-on-write canvas. r=jnicol
(Assignee)

Updated

2 years ago
Flags: needinfo?(nical.bugzilla)

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c16134a5a20f
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
(Assignee)

Comment 6

2 years ago
There's another wave of regressions and the pref landed just befor ethe merge to aurora so I'm thinking about turning the pref back off on aurora. Maybe just on windows since the current regressions seem to be specific to D2D.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

2 years ago
Created attachment 8778231 [details] [diff] [review]
Disable copy-on-write again, on windows

Currently all of the regressions that I don't have patches for are on windows+D2D, so let's try to keep it enabled on the other platforms for now.
Attachment #8778231 - Flags: review?(jnicol)

Updated

2 years ago
Attachment #8778231 - Flags: review?(jnicol) → review+
(Assignee)

Updated

2 years ago
Depends on: 1292545

Comment 8

2 years ago
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/32b74662a9e3
Disable_copy_on_write_canvas_on_windows_r_jnicol: Disable copy-on-write canvas on Windows. r=jnicol

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/32b74662a9e3
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: [gfx-noted][leave-open]
(Assignee)

Comment 10

2 years ago
Comment on attachment 8778231 [details] [diff] [review]
Disable copy-on-write again, on windows

Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]: Loads of crashes on windows
[Describe test coverage new/current, TreeHerder]: None.
[Risks and why]: low risk. The pref was flipped just before the merge to aurora, and we just want to flip it back off one windows due to regressions.
[String/UUID change made/needed]: None.
Attachment #8778231 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

2 years ago
Depends on: 1291296
(Assignee)

Updated

2 years ago
Depends on: 1291084
(Assignee)

Updated

2 years ago
Depends on: 1292192
(Assignee)

Updated

2 years ago
Depends on: 1291163
(Assignee)

Updated

2 years ago
Depends on: 1293693
Comment on attachment 8778231 [details] [diff] [review]
Disable copy-on-write again, on windows

This might account for the spike in Aurora crash rate, let's uplift to Fx50.
Attachment #8778231 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

2 years ago
status-firefox50: fixed → affected
Blocks: 1291190
No longer blocks: 1291190
Depends on: 1291190

Comment 12

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/d4204af2ee53
status-firefox50: affected → fixed
(Assignee)

Updated

2 years ago
No longer depends on: 1291084
(Assignee)

Updated

2 years ago
Depends on: 1298813
(Assignee)

Updated

2 years ago
Depends on: 1298345
(Assignee)

Updated

2 years ago
Depends on: 1300121
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.