Make Request constructor throw less often

RESOLVED FIXED in Firefox 54

Status

()

P3
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: bkelly, Assigned: amarchesini)

Tracking

(Blocks: 1 bug, {dev-doc-needed})

unspecified
mozilla54
dev-doc-needed
Points:
---

Firefox Tracking Flags

(firefox54 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
The spec is being updated to throw less often from the Request constructor:

https://github.com/whatwg/fetch/issues/245
(Reporter)

Comment 1

2 years ago
But the spec is still being decided.
Priority: -- → P3

Comment 2

2 years ago
The spec was updated in https://github.com/whatwg/fetch/pull/377, and I've submitted test changes to account for it in https://github.com/w3c/web-platform-tests/pull/4341 .
(Reporter)

Comment 3

2 years ago
We should implement this before chrome if we can to avoid compat problems.  Andrew, another one to prioritize if we can.
Flags: needinfo?(overholt)
baku, can you handle this?
Flags: needinfo?(overholt) → needinfo?(amarchesini)
(Reporter)

Comment 5

2 years ago
This might be better described by bug 1341223 now.
Created attachment 8841939 [details] [diff] [review]
fetch1.patch
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
Attachment #8841939 - Flags: review?(kyle)

Comment 7

2 years ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7a11dda7af71
Make Request constructor throw less often, r=qdot
(Reporter)

Comment 8

2 years ago
Andrea, why does this one still fail?

https://dxr.mozilla.org/mozilla-central/source/testing/web-platform/meta/fetch/api/policies/referrer-origin-service-worker.https.html.ini#4
Status: NEW → ASSIGNED
Flags: needinfo?(amarchesini)
simply because my local repo was older than that file. I'll remove that file as well.
Flags: needinfo?(amarchesini)
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1341223

Comment 11

2 years ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f2606ea1b31d
Make Request constructor throw less often, r=me, CLOSED TREE

Comment 13

2 years ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6d0ac4c74fd5
Make Request constructor throw less often, r=qdot

Comment 14

2 years ago
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/8a5b7f743d66
Backed out changeset 6d0ac4c74fd5 for frequent failures in test_request.html

Comment 15

2 years ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/36730ac6b59f
Make Request constructor throw less often, r=qdot
(Reporter)

Updated

2 years ago
Keywords: dev-doc-needed

Comment 16

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/36730ac6b59f
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox54: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla54
You need to log in before you can comment on or make changes to this bug.