[e10s] Nightly crashes when scrolling up and down with finger on Print Preview

RESOLVED WORKSFORME

Status

()

Core
Panning and Zooming
P2
normal
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: Grover, Unassigned)

Tracking

({regression})

51 Branch
x86
Windows 10
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox49 unaffected, firefox50 unaffected, firefox51 wontfix, firefox52 unaffected)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

a year ago
Mozilla/5.0 (Windows NT 10.0; rv 51.0) Gecko/20100101 Firefox/51.0

[Pre-Requisites] 
javascript.options.asyncstack; false
browser.tabs.remote.force-enable; true
browser.tabs.remote.autostart.2; true 
about:support Multiprocess Windows 1/1 (Enabled by user)
layers.async-pan-zoom.enabled; true 
about:support Asynchronous Pan/Zoom wheel input enabled; touch input enabled

[Steps to Reproduce]
1. Navigate to a webpage. (eg: https://en.wikipedia.org/wiki/peach )
2. Use your finger to tap the Menu.
3. Press "Print".
4. Use your finger to scroll up and down the page.

[Expected Results]
No crash occurs.

[Actual Results]
Firefox crashes and a prompt is displayed.

[Note]
This only happens when e10s is enabled.
(Reporter)

Updated

a year ago
tracking-e10s: --- → ?
(Reporter)

Comment 1

a year ago
Below are the details from the crash.

Accessibility: Active
AdapterDeviceID: 0x0f31
AdapterDriverVersion: 10.18.10.4358
AdapterSubsysID: 10071025
AdapterVendorID: 0x8086
Add-ons: %7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:51.0a1,e10srollout%40mozilla.org:1.0,firefox%40getpocket.com:1.0.4,flyweb%40mozilla.org:1.0.0,webcompat%40mozilla.org:1.0
AddonsShouldHaveBlockedE10s: 0
AvailablePageFile: 1643020288
AvailablePhysicalMemory: 722149376
AvailableVirtualMemory: 1408720896
BIOS_Manufacturer: INSYDE Corp.
BlockedDllList: 
BreakpadReserveAddress: 29949952
BreakpadReserveSize: 67108864
BuildID: 20160829030202
ContentSandboxCapable: 1
ContentSandboxLevel: 2
CrashTime: 1472504428
DOMIPCEnabled: 1
E10SCohort: unsupportedChannel
EMCheckCompatibility: true
FramePoisonBase: 00000000f0de0000
FramePoisonSize: 65536
InstallTime: 1472489652
MozCrashReason: MOZ_RELEASE_ASSERT(mWorkerLoopID == MessageLoop::current()->id()) (not on worker thread!)
Notes: AdapterVendorID: 0x8086, AdapterDeviceID: 0x0f31, AdapterSubsysID: 10071025, AdapterDriverVersion: 10.18.10.4358
FP(D00-L1000-W00001000-T0000) D2D1.1? DWrite? DWrite+ D2D1.1+ D3D11 Layers? D3D11 Layers+ DXVA2D3D9? DXVA2D3D9+ WebGL? EGL? EGL+ GL Context? GL Context+ WebGL+ WGL? WGL+ 
ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: nightly
SafeMode: 0
SecondsSinceLastCrash: 7615750
StartupCrash: 0
StartupTime: 1472501817
SystemMemoryUsePercentage: 65
TelemetryEnvironment: {"build":{"applicationId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","applicationName":"Firefox","architecture":"x86","buildId":"20160829030202","version":"51.0a1","vendor":"Mozilla","platformVersion":"51.0a1","xpcomAbi":"x86-msvc","hotfixVersion":null},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":1970,"virtualMaxMB":2048,"cpu":{"count":4,"cores":4,"vendor":"GenuineIntel","family":6,"model":55,"stepping":8,"l2cacheKB":1024,"l3cacheKB":null,"speedMHz":1333,"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3","hasSSSE3","hasSSE4_1","hasSSE4_2"]},"os":{"name":"Windows_NT","version":"10.0","locale":"en-US","servicePackMajor":0,"servicePackMinor":0,"windowsBuildNumber":10586,"windowsUBR":218,"installYear":2016},"hdd":{"profile":{"model":"VID:90HCG8e","revision":"0.3"},"binary":{"model":"VID:90HCG8e","revision":"0.3"},"system":{"model":"VID:90HCG8e","revision":"0.3"}},"gfx":{"D2DEnabled":false,"DWriteEnabled":true,"adapters":[{"description":"Intel(R) HD Graphics","vendorID":"0x8086","deviceID":"0x0f31","subsysID":"10071025","RAM":null,"driver":"igdumdim32 igd10iumd32 igd10iumd32","driverVersion":"10.18.10.4358","driverDate":"12-21-2015","GPUActive":true}],"monitors":[{"screenWidth":1280,"screenHeight":800,"refreshRate":60,"pseudoDisplay":false}],"features":{"compositor":"d3d11","d3d11":{"status":"available","version":45056,"warp":false,"textureSharing":true,"blacklisted":false},"d2d":{"status":"available","version":"1.1"}}},"isWow64":false},"settings":{"blocklistEnabled":true,"e10sEnabled":true,"e10sCohort":"unsupportedChannel","telemetryEnabled":true,"locale":"en-US","update":{"channel":"nightly","enabled":true,"autoDownload":true},"userPrefs":{"browser.cache.disk.capacity":358400,"browser.newtabpage.enhanced":true},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":true},"profile":{"creationDate":17042},"addons":{"activeAddons":{"e10srollout@mozilla.org":{"blocklisted":false,"description":"Staged rollout of Firefox multi-process feature.","name":"Multi-process staged rollout","userDisabled":false,"appDisabled":false,"version":"1.0","scope":1,"type":"extension","foreignInstall":false,"hasBinaryComponents":false,"installDay":17039,"updateDay":17039,"isSystem":true},"firefox@getpocket.com":{"blocklisted":false,"description":"When you find something you want to view later, put it in Pocket.","name":"Pocket","userDisabled":false,"appDisabled":false,"version":"1.0.4","scope":1,"type":"extension","foreignInstall":false,"hasBinaryComponents":false,"installDay":17039,"updateDay":17039,"isSystem":true},"flyweb@mozilla.org":{"blocklisted":false,"description":"Discover nearby services in the browser","name":"FlyWeb","userDisabled":false,"appDisabled":false,"version":"1.0.0","scope":1,"type":"extension","foreignInstall":false,"hasBinaryComponents":false,"installDay":17039,"updateDay":17039,"isSystem":true},"webcompat@mozilla.org":{"blocklisted":false,"description":"Urgent post-release fixes for web compatibility.","name":"Web Compat","userDisabled":false,"appDisabled":false,"version":"1.0","scope":1,"type":"extension","foreignInstall":false,"hasBinaryComponents":false,"installDay":17039,"updateDay":17039,"isSystem":true}},"theme":{"id":"{972ce4c6-7e08-4474-a285-3208198ce6fd}","blocklisted":false,"description":"The default theme.","name":"Default","userDisabled":false,"appDisabled":false,"version":"51.0a1","scope":4,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17039,"updateDay":17039},"activePlugins":[{"name":"Shockwave Flash","version":"21.0.0.213","description":"Shockwave Flash 21.0 r0","blocklisted":false,"disabled":false,"clicktoplay":false,"mimeTypes":["application/x-shockwave-flash","application/futuresplash"],"updateDay":16902}],"activeGMPlugins":{"gmp-gmpopenh264":{"version":"1.6","userDisabled":false,"applyBackgroundUpdates":1},"gmp-eme-adobe":{"version":"17","userDisabled":false,"applyBackgroundUpdates":1},"gmp-widevinecdm":{"version":"1.4.8.903","userDisabled":false,"applyBackgroundUpdates":1}},"activeExperiment":{},"persona":null}}
Theme: classic/1.0
Throttleable: 1
TotalPageFile: 3542466560
TotalPhysicalMemory: 2066071552
TotalVirtualMemory: 2147352576
URL: about:blank
UptimeTS: 3401.875431203
Vendor: Mozilla
Version: 51.0a1
Winsock_LSP: Hyper-V RAW : 2 : 34 : 1 : 1 : 0x20006 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : 1234191b-4bf7-4ca7-86e0-dfd7c32b5445 
 MSAFD Tcpip [TCP/IP] : 2 : 2 : 1 : 6 : 0x20066 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : e70f1aa0-ab8b-11cf-8ca3-00805f48a192 
 MSAFD Tcpip [UDP/IP] : 2 : 2 : 2 : 17 : 0x20609 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : e70f1aa0-ab8b-11cf-8ca3-00805f48a192 
 MSAFD Tcpip [RAW/IP] : 2 : 2 : 3 : 0 : 0x20609 : 0xc : %SystemRoot%\system32\mswsock.dll :  : e70f1aa0-ab8b-11cf-8ca3-00805f48a192 
 MSAFD Tcpip [TCP/IPv6] : 2 : 23 : 1 : 6 : 0x20066 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : f9eab0c0-26d4-11d0-bbbf-00aa006c34e4 
 MSAFD Tcpip [UDP/IPv6] : 2 : 23 : 2 : 17 : 0x20609 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : f9eab0c0-26d4-11d0-bbbf-00aa006c34e4 
 MSAFD Tcpip [RAW/IPv6] : 2 : 23 : 3 : 0 : 0x20609 : 0xc : %SystemRoot%\system32\mswsock.dll :  : f9eab0c0-26d4-11d0-bbbf-00aa006c34e4 
 RSVP TCPv6 Service Provider : 2 : 23 : 1 : 6 : 0x22066 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : 9d60a9e0-337a-11d0-bd88-0000c082e69a 
 RSVP TCP Service Provider : 2 : 2 : 1 : 6 : 0x22066 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : 9d60a9e0-337a-11d0-bd88-0000c082e69a 
 RSVP UDPv6 Service Provider : 2 : 23 : 2 : 17 : 0x22609 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : 9d60a9e0-337a-11d0-bd88-0000c082e69a 
 RSVP UDP Service Provider : 2 : 2 : 2 : 17 : 0x22609 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : 9d60a9e0-337a-11d0-bd88-0000c082e69a
useragent_locale: en-US
Do you have a link to the crash report? You should be able to find it in about:crashes
Flags: needinfo?(gwimberly)
(Reporter)

Comment 3

a year ago
Hi Kats, here is the link to the crash report.

https://crash-stats.mozilla.com/report/index/c10fdc13-edea-4e1b-baa6-1111f2160829
Flags: needinfo?(gwimberly)
Ryan, can you take a look at the stack in the above crash report? Looks like it might be another regression from your recent changes.
Flags: needinfo?(rhunt)

Comment 5

a year ago
I think it is a regression from my recent changes because SetScrollingRootContent is the one crashing and wasn't added until Bug 1289650.
Flags: needinfo?(rhunt)

Updated

a year ago
Assignee: nobody → rhunt
Crash Signature: [@ mozilla::ipc::MessageChannel::AssertWorkerThread]
See Also: → bug 1299305
Blocks: 1289650
status-firefox49: --- → unaffected
status-firefox50: --- → unaffected
Keywords: regression
Priority: -- → P2
Whiteboard: [gfx-noted]

Updated

a year ago
tracking-e10s: ? → +

Comment 6

a year ago
I'm having trouble reproducing this on my Windows 10 laptop with simulated touch. Does this issue happen every time or intermittently?
Flags: needinfo?(gwimberly)
(Reporter)

Comment 7

a year ago
(In reply to Ryan Hunt [:rhunt] from comment #6)
> I'm having trouble reproducing this on my Windows 10 laptop with simulated
> touch. Does this issue happen every time or intermittently?

Hi Ryan, 

This issue does not happen every time. It happens intermittently.
Flags: needinfo?(gwimberly)
At least one thing wrong with the code in RemoteContentController is that it doesn't have mCanSend checks on a few functions - including SetScrollingRootContent. That might be related.
Depends on: 1304457
Can you please check if this is still happening in today's nightly? I'm wondering if bug 1304457 fixed it, and that fix is in the Sep 22 nightly. Thanks!
Flags: needinfo?(gwimberly)
(Note also that you might get crashes while trying to load the page - I was seeing those crashes and filed bug 1304130 for it. If so we'll have to wait until those crashes are fixed before we can verify if this is still happening)
(Reporter)

Comment 11

a year ago
Hi Kats, 

No longer observing a crash in the newest Nightly. If there's any other issues, don't hesitate to need info.
Flags: needinfo?(gwimberly)
Awesome, thanks!
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
status-firefox51: affected → wontfix
status-firefox52: --- → unaffected
Crash volume for signature 'mozilla::ipc::MessageChannel::AssertWorkerThread':
 - nightly (version 52): 121 crashes from 2016-09-19.
 - aurora  (version 51): 233 crashes from 2016-09-19.
 - beta    (version 50): 88 crashes from 2016-09-20.
 - release (version 49): 38 crashes from 2016-09-05.
 - esr     (version 45): 0 crashes from 2016-07-25.

Crash volume on the last weeks (Week N is from 10-17 to 10-23):
            W. N-1  W. N-2  W. N-3  W. N-4
 - nightly       0       0      11     110
 - aurora        0       0     161      72
 - beta          0       0      56      32
 - release       0       1      26      12
 - esr           0       0       0       0

Affected platforms: Windows, Linux
status-firefox49: unaffected → affected
status-firefox50: unaffected → affected
status-firefox52: unaffected → affected
The crash signature is too generic, dropping it so the bot doesn't keep finding this bug.
Assignee: rhunt → nobody
Crash Signature: [@ mozilla::ipc::MessageChannel::AssertWorkerThread]
status-firefox49: affected → unaffected
status-firefox50: affected → unaffected
status-firefox52: affected → unaffected
You need to log in before you can comment on or make changes to this bug.