Alt+pgup, Alt+pgdn don't work when arrow buttons are visible

NEW
Unassigned

Status

17 years ago
7 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Depends on: 1 bug, {access, sec508})

Trunk
access, sec508

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Steps to reproduce:
1. Add enough sidebar tabs so arrow buttons appear at the bottom of the sidebar.
2. Try to use Alt+pgup and Alt+pgdn to switch between panels.

Result: can only select panels that are currently visible.  I have to pick up
the mouse and click on the arrow buttons to get to the other panels.

Expected: pressing Alt+pgdn when the last visible panel is selected should do
the same thing as clicking the down arrow and then pressing Alt+pgdn.

I also got a crash the first time I tried, but wasn't able to reproduce the
crash on a newer build.
(Reporter)

Updated

17 years ago
Keywords: access

Comment 1

17 years ago
Should be covered when fixing bug 127973.  Nominating to track this case.
Status: NEW → ASSIGNED
Depends on: 127973
Keywords: nsbeta1
Priority: -- → P3
Target Milestone: --- → mozilla1.0

Comment 2

17 years ago
cc aaronl for section 508 impact.

Comment 3

17 years ago
Yes, this is a section 508 issue, but since most people don't usually have that
many sidebar tabs, I recommend we consider leaving this alone for now.

It does sound like we should try to repro the crash though. 
Keywords: sec508
(Reporter)

Comment 4

17 years ago
Talkbalk ID TB4022456E.

Comment 5

17 years ago
nsbeta1- per Nav triage team, ->1.2
Keywords: nsbeta1 → nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.2alpha

Comment 6

16 years ago
I have no idea, what is the supposed function for Alt+PgUp/PgDn, but I just
found out that in 1.5a, Alt+PgUp opens the sidebar, and Alt+PgDn does nothing
visible.

Any reason for this shortcut?

I really find this improper use of the keyboard, but even if there is some
reason, why doesn't Alt+PgDn "undo" the action, i.e. close the sidebar?

Comment 7

16 years ago
Kalin, read the keyboard docs page.

Alt+PgUp, Alt+PgDn switch sidebar tabs. They also open the sidebar if necessary.
If you have a suggestion on a better way to do that with the keyboard, let us
know what that is.

If you have only one sidebar tab, it will appear that it's doing nothing,
because there is no other sidebar tab to move to. This is similar to how
Ctrl+Tab and Ctrl+Shift+Tab work when you have only one browse tab open.
Product: Browser → Seamonkey
Assignee: samir_bugzilla → nobody
Status: ASSIGNED → NEW
Priority: P3 → --
QA Contact: sujay → sidebar
Target Milestone: mozilla1.2alpha → ---

Comment 8

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 9

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED

Comment 10

7 years ago
Still valid.
Status: RESOLVED → UNCONFIRMED
Resolution: EXPIRED → ---

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

7 years ago
OS: Windows 98 → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.