No focus in message composition window. Focus is in main window

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Stefan.Ronsiek, Unassigned)

Tracking

45 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/51.0.2704.79 Chrome/51.0.2704.79 Safari/537.36

Steps to reproduce:

Thunderbird 45.2.0 running on Linux Mint 17 Qiana (based on Ubuntu 14.04.4 LTS, Trusty Tahr).

Select a received message in the Inbox list. Then select Reply-To, Forward or Write (for new msg).


Actual results:

The message 'Write' window opens, but on clicking the text pane, no cursor appears and typed text is not displayed. Furthermore, when I type 's', I see the star selection for the selected message in the Inbox list toggles, typing 'a' archives the selected message. (This had lead me to believe I had lost messages which in fact had been archived). Anyhow - it is clear the parent window has focus, and not the composition window.

This has only recently started happening, presumably due to a thunderbird version update. It does not occur every time, usually after 2 or so mails have bee written and sent.

Only know workaround is to quit and re-start thunderbird, which I'm needing to do after every 2-3 mails sent now.


Expected results:

Focus in Write window & ability to write a mail!
(Reporter)

Comment 1

3 years ago
2 more snippets of info:

 - when in the state described, it IS possible to click on unused recipient row (CC / BCC etc) in the composition window and a text entry field appears in white. So there is some degree of focus. But it is then not possible to get a cursor or type.

 - I just noted I was able to click on a different folder and back in the parent window - which seemed to 'fix' the issue - which is a better workaround.
(Reporter)

Updated

3 years ago
Severity: normal → major
OS: Unspecified → Linux
Priority: -- → P2
Hardware: Unspecified → x86_64
(Reporter)

Comment 2

3 years ago
Correction: On several repeats, the last workaround did not work.
does it also happen in safe mode?
Priority: P2 → --
(Reporter)

Comment 4

3 years ago
I've reduced my extensions to the minimum I need for work: enigmail, lightning, provider for google.
All plugins are disabled.

With that config I do see the issue recurring.

In the short period I ran in --safe-mode I did not see it - but this is not conclusive - since it was a short period ...
sounds vaguely like an enigmail issue.
do you also see the problem when running beta from http://www.mozilla.org/en-US/thunderbird/channel/ ?
Flags: needinfo?(Stefan.Ronsiek)
Summary: No focus in message composition window → No focus in message composition window. Focus is in main window
(Reporter)

Comment 6

3 years ago
The next piece of info I have is that I *have* seen the issue running in 'normal' (ie not safe) mode, but with *all* plugins and add-ons disabled!

Will try the beta next.
(Reporter)

Comment 7

2 years ago
The beta is looking good. No issues in almost a week with all extensions on.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(Stefan.Ronsiek)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.