Intermittent make[1]: *** [/home/worker/workspace/build/src/js/src/configure] Error 1

RESOLVED FIXED

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure})

Details

Filed by: rvandermeulen [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=2778356&repo=autoland

https://queue.taskcluster.net/v1/task/I0Ng4haOQNyZ_hGXhy1HwQ/runs/0/artifacts/public%2Flogs%2Flive_backing.log

I'm assuming this is due to a stale cache or something, so calling it a Taskcluster bug.
checking for localeconv... (cached) yes
updating cache ./config.cache
creating ./config.data
Creating config.status
Reticulating splines...
Finished reading 40 moz.build files in 0.07s
Processed into 221 build config descriptors in 0.17s
RecursiveMake backend executed in 0.12s
  139 total backend files; 139 created; 0 updated; 0 unchanged; 0 deleted; 8 -> 36 Makefile
FasterMake backend executed in 0.00s
  4 total backend files; 4 created; 0 updated; 0 unchanged; 0 deleted
Total wall time: 0.40s; CPU time: 0.40s; Efficiency: 101%; Untracked: 0.03s
make: Entering directory `/home/worker/workspace/build/src/obj-spider'
make: Leaving directory `/home/worker/workspace/build/src/obj-spider'
make: Entering directory `/home/worker/workspace/build/src/obj-spider'
make[1]: Entering directory `/home/worker/workspace/build/src/obj-spider'
STOP!  /home/worker/workspace/build/src/js/src/old-configure.in has changed, and your configure is out of date.
Please rerun autoconf and re-configure your build directory.
To ignore this message, touch "/home/worker/workspace/build/src/js/src/configure",
but your build might not succeed.
So, all of the spidermonkey builds share the same cache name, `level-{level}-{project}-build-spidermonkey-workspace`.  Would different spidermonkey builds confuse one another this way?  Should we use different workspace caches for them?
Flags: needinfo?(sphink)
See Also: → 1302429
Duplicate of this bug: 1302429
I don't understand how the cache is used. I sort of assumed it was where the ccache was stored. But if it's used to hold the actual objdir, then... well, I wouldn't *think* it should cause any problems, but it has been broken in the past (where rerunning configure with different arguments required a clobber.)

So if that's the case, then it would be safer to have the variant or the job name in the cache name.
Flags: needinfo?(sphink)
Yes, it is for the objdir.  It sounds like separating those would be a good idea.
Issue has not happened in over a month, and the bug (1302429) referenced has been fixed.  I think we can call this resolved.  Please reopen if the issue occurs again.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.