Closed Bug 1299243 Opened 3 years ago Closed 3 years ago

[e10s] Tab crashes in touch enabled windows laptop

Categories

(Core :: Disability Access APIs, defect)

51 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1270916
Tracking Status
e10s + ---
firefox51 --- affected

People

(Reporter: Abe_LV, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Mozilla/5.0 (Windows NT 10.0; rv 51.0) Gecko/20100101 Firefox/51.0

[Pre-Requisites] 
javascript.options.asyncstack; false
browser.tabs.remote.force-enable; true
layers.async-pan-zoom.enabled; true 

about:support shows
Multiprocess Windows 1/1 (Enabled by user)

Asynchronous Pan/Zoom wheel input enabled; touch input enabled


[Steps to Reproduce]
1.Navigate to http://www.fox5vegas.com/story/32870619/ccsd-overcrowding-portables-remain-for-another-school-year

2.Scroll through the page by swiping with finger
3.The tab crashes

[Expected Results]
No crash occurs.

[Actual Results]
Tab crashes and a prompt is displayed.

[Note]
This only happens when e10s is enabled on touch-enabled windows 10 device/laptop.


ScreenCapture: https://testing-1.tinytake.com/sf/OTQyMjI3XzM5NjQwODk

[Crash Reports]
https://crash-stats.mozilla.com/report/index/bp-c60a28f2-10ca-4d9d-8a3d-a133d2160830
https://crash-stats.mozilla.com/report/index/bp-2fa5ce80-42c6-40a5-9e8f-7361e2160830
https://crash-stats.mozilla.com/report/index/bp-9264c5b1-a648-493d-bbca-b2c2f2160830
https://crash-stats.mozilla.com/report/index/bp-7f1baadf-f93b-4112-9bea-e0ba82160830
https://crash-stats.mozilla.com/report/index/bp-2015a74b-c7b7-41e5-9607-9936c2160830
https://crash-stats.mozilla.com/report/index/bp-65ec1646-3514-4487-8c95-7c0762160830
tracking-e10s: --- → ?
Flags: needinfo?(bugmail)
Version: 49 Branch → 51 Branch
Almost all of these appear to be in the accessibility code and are covered by bug 1297131 and/or bug 1293555
Depends on: 1297131, 1293555
Flags: needinfo?(bugmail)
I'll still track it as blocking touch events rollout.
Blocks: 1244402
Blocks: 1258839
Component: Tabbed Browser → Disability Access APIs
Keywords: crash
Product: Firefox → Core
Depends on: 1304449
Trevor do we think bug 1270916 will fix this?
Flags: needinfo?(tbsaunde+mozbugs)
(In reply to David Bolter [:davidb] from comment #4)
> Trevor do we think bug 1270916 will fix this?

yes, it looks like a dup to me.
Flags: needinfo?(tbsaunde+mozbugs)
Resolving as dup per comment 5.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1270916
You need to log in before you can comment on or make changes to this bug.