Closed Bug 1299428 Opened 3 years ago Closed 3 years ago

Search a string looking like a URL using a one-off button doesn't open the search results

Categories

(Firefox :: Address Bar, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 52
Tracking Status
firefox51 --- affected
firefox52 --- fixed

People

(Reporter: marco, Assigned: mak)

References

Details

(Whiteboard: [fxsearch])

Attachments

(2 files)

Steps to reproduce:
1) Open a new tab
2) Write 'os.environ.get' in the awesomebar
3) Click on one of the search providers at the bottom of the awesomebar

A search results page should be opened, but instead Firefox is trying to open 'os.environ.get' as a URL.
Component: Untriaged → Location Bar
Priority: -- → P1
Whiteboard: [fxsearch]
Duplicate of this bug: 1293049
Assignee: nobody → mak77
Status: NEW → ASSIGNED
I think the problem is that we evaluate actions BEFORE checking oneoffs. We should do the opposite.
Summary: Search a string looking like a URL using one of the search providers in the awesomebar doesn't open the search results → Search a string looking like a URL using a one-off button doesn't open the search results
well, actually the problem is that we only serve searches if the string doesn't pass fixup... but it doesn't make much sense since a selected oneoff means it's "active" so what the user wants to do is a search.
this should now be ready for review. The remaining failure on Try in browser_action_keyword.js has been fixed in the last commit
Comment on attachment 8806869 [details]
Bug 1299428 - Searching an URL looking string using a one-off button doesn't open a search result.

https://reviewboard.mozilla.org/r/90156/#review90260

Hmm, I guess the point of the fixup was to navigate to the URL you had typed, or more likely selected from the results, even if a one-off was also selected.  I don't remember.
Attachment #8806869 - Flags: review?(adw) → review+
Comment on attachment 8806868 [details]
Bug 1299428 - Use more of BrowserTestUtils in urlbar tests.

https://reviewboard.mozilla.org/r/90154/#review90262
Attachment #8806868 - Flags: review?(adw) → review+
I must wait for bug 1314812 landing to unbitrot.
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/55884e6a3c8c
Use more of BrowserTestUtils in urlbar tests. r=adw
https://hg.mozilla.org/integration/autoland/rev/370bcd32def2
Searching an URL looking string using a one-off button doesn't open a search result. r=adw
https://hg.mozilla.org/mozilla-central/rev/55884e6a3c8c
https://hg.mozilla.org/mozilla-central/rev/370bcd32def2
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
I have reproduced this bug with Nightly 51.0a1 (2016-08-31) on Windows 7, 64 Bit !

This bug's fix is verified with latest Nightly

Build ID    20161109030210
User Agent  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0

[bugday-20161109]
I have reproduced this bug with Nightly 51.0a1 (2016-08-31) on Ubuntu 16.10, 64 Bit !

This bug's fix is verified with latest Nightly

Build ID    20170202101509
User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0


[testday-20170203]
You need to log in before you can comment on or make changes to this bug.