Intermittent dom/media/test/test_streams_autoplay.html | application crashed [@ jemalloc_crash]

RESOLVED DUPLICATE of bug 1299172

Status

()

P1
normal
Rank:
15
RESOLVED DUPLICATE of bug 1299172
2 years ago
2 years ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

Someone should look into this because it is a crash. Feel free to drop the priority if it turns out not to be a problem.
Priority: -- → P1

Updated

2 years ago
Rank: 15
Component: Audio/Video → Audio/Video: Playback
(In reply to Treeherder Bug Filer from comment #0)
> Filed by: philringnalda [at] gmail.com
> 
> https://treeherder.mozilla.org/logviewer.html#?job_id=4810917&repo=mozilla-
> central
> 
> https://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-central-
> win32-pgo/1472653814/mozilla-central_xp_ix_test_pgo-mochitest-media-bm109-
> tests1-windows-build13.txt.gz

Thread 92 (crashed)
 0  mozglue.dll!jemalloc_crash [jemalloc.c:b38f935eb811 : 1631 + 0x0]
    eip = 0x10011019   esp = 0x260ffc30   ebp = 0x260ffc64   ebx = 0x00800148
    esi = 0x186bc000   edi = 0x00800040   eax = 0x00000400   ecx = 0x00000400
    edx = 0x0000000a   efl = 0x00000206
    Found by: given as instruction pointer in context
 1  mozglue.dll!arena_ralloc [jemalloc.c:b38f935eb811 : 4929 + 0x1e]
    eip = 0x10001fa1   esp = 0x260ffc34   ebp = 0x260ffc64
    Found by: call frame info
 2  mozglue.dll!moz_xrealloc [mozalloc.cpp:b38f935eb811 : 105 + 0x99]
    eip = 0x1000199f   esp = 0x260ffc6c   ebp = 0x260ffc9c
    Found by: call frame info
 3  xul.dll!nsTArray_base<nsTArrayInfallibleAllocator,nsTArray_CopyWithMemutils>::EnsureCapacity<nsTArrayInfallibleAllocator>(unsigned int,unsigned int) [nsTArray-inl.h:b38f935eb811 : 183 + 0x8]
    eip = 0x03270d5e   esp = 0x260ffca4   ebp = 0x260ffcb8
    Found by: call frame info
 4  xul.dll!mozilla::MediaStreamGraph::DispatchToMainThreadAfterStreamStateUpdate(already_AddRefed<nsIRunnable>) [MediaStreamGraph.h:b38f935eb811 : 1356 + 0x16]
    eip = 0x044b9e92   esp = 0x260ffcc0   ebp = 0x260ffcd8
    Found by: call frame info
 5  xul.dll!mozilla::DOMMediaStream::PlaybackStreamListener::NotifyFinishedTrackCreation(mozilla::MediaStreamGraph *) [DOMMediaStream.cpp:b38f935eb811 : 310 + 0x11]
    eip = 0x044999ac   esp = 0x260ffce0   ebp = 0x260ffcec
    Found by: call frame info
 6  xul.dll!mozilla::TrackUnionStream::ProcessInput(__int64,__int64,unsigned int) [TrackUnionStream.cpp:b38f935eb811 : 126 + 0xb]
    eip = 0x044cff65   esp = 0x260ffcf4   ebp = 0x260ffd64
    Found by: call frame info
 7  xul.dll!mozilla::MediaStreamGraphImpl::Process() [MediaStreamGraph.cpp:b38f935eb811 : 1322 + 0x19]
    eip = 0x044c3701   esp = 0x260ffd6c   ebp = 0x260ffda8
    Found by: call frame info
 8  xul.dll!mozilla::MediaStreamGraphImpl::OneIteration(__int64) [MediaStreamGraph.cpp:b38f935eb811 : 1394 + 0xd]
    eip = 0x044c256d   esp = 0x260ffdb0   ebp = 0x260ffdcc
    Found by: call frame info
 9  xul.dll!mozilla::ThreadedDriver::RunThread() [GraphDriver.cpp:b38f935eb811 : 356 + 0xc]
    eip = 0x044ac1da   esp = 0x260ffdd4   ebp = 0x260ffdf0
    Found by: call frame info
10  xul.dll!mozilla::MediaStreamGraphInitThreadRunnable::Run() [GraphDriver.cpp:b38f935eb811 : 229 + 0x8]
    eip = 0x044abe28   esp = 0x260ffdf8   ebp = 0x260ffe04
    Found by: call frame info
11  xul.dll!nsThread::ProcessNextEvent(bool,bool *) [nsThread.cpp:b38f935eb811 : 1058 + 0x6]
    eip = 0x0323b83a   esp =
Component: Audio/Video: Playback → Audio/Video: MediaStreamGraph
There was only one occurrence of this, so could have been fixed.

And looking at the timeframe and related code I'd say this was fixed by bug 1299172.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1299172
You need to log in before you can comment on or make changes to this bug.