Closed Bug 1300016 Opened 3 years ago Closed 3 years ago

Intermittent dom/media/webspeech/synth/test/test_speech_simple.html | application crashed [@ RefPtr<mozilla::dom::SpeechSynthesisUtterance>::operator->()]

Categories

(Core :: Web Speech, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox50 --- unaffected
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: alwu)

References

Details

(Keywords: crash, intermittent-failure)

Attachments

(1 file)

Eitan, any idea what might have made this angry around the beginning of September?
Flags: needinfo?(eitan)
Keywords: crash
See Also: → 1299313
This didn't happen from a change in speech synth. I suspect it may have to do with bug 1262053.


alwu wrote both our AudioChannelAgent support and the patches in bug 1262053. Do you have any idea?
Flags: needinfo?(eitan) → needinfo?(alwu)
Indeed, that looks like a very likely candidate. Bug 1299313 was filed on the 30th of August.
Assignee: nobody → alwu
Flags: needinfo?(alwu)
Duplicate of this bug: 1305231
Attachment #8808100 - Flags: review?(eitan)
Comment on attachment 8808100 [details]
Bug 1300016 - only suspend web-speech when mUtterance exists.

https://reviewboard.mozilla.org/r/91026/#review92002

Thanks!
Attachment #8808100 - Flags: review?(eitan) → review+
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/117b0fa754f7
only suspend web-speech when mUtterance exists. r=eeejay
https://hg.mozilla.org/mozilla-central/rev/117b0fa754f7
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Please request Beta approval on this when you get a chance (for 51, assuming that this won't get approved and landed before Monday's uplift)?
Flags: needinfo?(alwu)
Comment on attachment 8808100 [details]
Bug 1300016 - only suspend web-speech when mUtterance exists.

Approval Request Comment
[Feature/regressing bug #]: Fix the intermittent crash because of using the null pointer.
[User impact if declined]: Intermittent crash.
[Describe test coverage new/current, TreeHerder]: Yes, it already be covered by our test cases.
[Risks and why]: almost no risk, because we just added the null pointer checking. 
[String/UUID change made/needed]: no
Flags: needinfo?(alwu)
Attachment #8808100 - Flags: approval-mozilla-beta?
Attachment #8808100 - Flags: approval-mozilla-aurora?
Comment on attachment 8808100 [details]
Bug 1300016 - only suspend web-speech when mUtterance exists.

Fix an intermittent test failure. Take it in 51 aurora.
Attachment #8808100 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 8808100 [details]
Bug 1300016 - only suspend web-speech when mUtterance exists.

This was uplifted to 51 before the merge to beta, so beta uplift is no longer relevant.
Attachment #8808100 - Flags: approval-mozilla-beta?
You need to log in before you can comment on or make changes to this bug.