Intermittent dom/media/webspeech/synth/test/test_speech_simple.html | application terminated with exit code 1 | after Assertion failure: mRawPtr != 0

RESOLVED DUPLICATE of bug 1300016

Status

()

RESOLVED DUPLICATE of bug 1300016
2 years ago
2 years ago

People

(Reporter: aryx, Unassigned)

Tracking

({assertion, intermittent-failure})

Trunk
assertion, intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox52 affected)

Details

https://treeherder.mozilla.org/logviewer.html#?job_id=3986354&repo=autoland

20:31:53     INFO -  Assertion failure: mRawPtr != 0 (You can't dereference a NULL RefPtr with operator->().), at c:\builds\moz2_slave\autoland-w32-d-000000000000000\build\src\obj-firefox\dist\include\mozilla/RefPtr.h:307
20:32:05     INFO -  #01: mozilla::dom::AudioChannelAgent::WindowSuspendChanged(unsigned int) [dom/audiochannel/AudioChannelAgent.cpp:305]
20:32:05     INFO -  #02: mozilla::detail::FunctionImpl<<lambda_282f09ace65bc55484f8340d8eb92509>,void,mozilla::dom::AudioChannelAgent *>::call(mozilla::dom::AudioChannelAgent *) [obj-firefox/dist/include/mozilla/Function.h:64]
20:32:05     INFO -  #03: mozilla::function<void >::operator()<mozilla::dom::AudioChannelAgent * &>(mozilla::dom::AudioChannelAgent * &) [obj-firefox/dist/include/mozilla/Function.h:181]
20:32:05     INFO -  #04: mozilla::dom::AudioChannelService::RefreshAgents(nsPIDOMWindowOuter *,mozilla::function<void >) [dom/audiochannel/AudioChannelService.cpp:650]
20:32:05     INFO -  #05: mozilla::dom::AudioChannelService::RefreshAgentsSuspend(nsPIDOMWindowOuter *,unsigned int) [dom/audiochannel/AudioChannelService.cpp:670]
20:32:05     INFO -  #06: nsPIDOMWindowOuter::RefreshMediaElementsSuspend(unsigned int) [dom/base/nsGlobalWindow.cpp:3959]
20:32:05     INFO -  #07: nsPIDOMWindowOuter::SetMediaSuspend(unsigned int) [dom/base/nsGlobalWindow.cpp:3884]
20:32:05     INFO -  #08: nsDocument::MaybeActiveMediaComponents() [dom/base/nsDocument.cpp:12107]
20:32:05     INFO -  #09: nsDocument::OnPageShow(bool,mozilla::dom::EventTarget *) [dom/base/nsDocument.cpp:8740]
20:32:05     INFO -  #10: nsDocumentViewer::LoadComplete(nsresult) [layout/base/nsDocumentViewer.cpp:1023]
20:32:05     INFO -  #11: nsDocShell::EndPageLoad(nsIWebProgress *,nsIChannel *,nsresult) [docshell/base/nsDocShell.cpp:7616]
20:32:05     INFO -  #12: nsDocShell::OnStateChange(nsIWebProgress *,nsIRequest *,unsigned int,nsresult) [docshell/base/nsDocShell.cpp:7416]
20:32:05     INFO -  #13: nsDocLoader::DoFireOnStateChange(nsIWebProgress * const,nsIRequest * const,int &,nsresult) [uriloader/base/nsDocLoader.cpp:1255]
20:32:05     INFO -  #14: nsDocLoader::doStopDocumentLoad(nsIRequest *,nsresult) [uriloader/base/nsDocLoader.cpp:840]
20:32:05     INFO -  #15: nsDocLoader::DocLoaderIsEmpty(bool) [uriloader/base/nsDocLoader.cpp:732]
20:32:05     INFO -  #16: nsDocLoader::OnStopRequest(nsIRequest *,nsISupports *,nsresult) [uriloader/base/nsDocLoader.cpp:613]
20:32:05     INFO -  #17: mozilla::net::nsLoadGroup::RemoveRequest(nsIRequest *,nsISupports *,nsresult) [netwerk/base/nsLoadGroup.cpp:633]
20:32:05     INFO -  #18: nsDocument::DoUnblockOnload() [dom/base/nsDocument.cpp:8646]
20:32:05     INFO -  #19: nsDocument::UnblockOnload(bool) [dom/base/nsDocument.cpp:8573]
20:32:05     INFO -  #20: nsDocument::DispatchContentLoadedEvents() [dom/base/nsDocument.cpp:5078]
20:32:05     INFO -  #21: mozilla::detail::RunnableMethodImpl<void ( nsDocument::*)(void),1,0>::Run() [obj-firefox/dist/include/nsThreadUtils.h:766]
20:32:05     INFO -  #22: nsThread::ProcessNextEvent(bool,bool *) [xpcom/threads/nsThread.cpp:1082]
20:32:05     INFO -  #23: NS_ProcessNextEvent(nsIThread *,bool) [xpcom/glue/nsThreadUtils.cpp:290]
20:32:05     INFO -  #24: mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate *) [ipc/glue/MessagePump.cpp:96]
20:32:05     INFO -  #25: MessageLoop::RunInternal() [ipc/chromium/src/base/message_loop.cc:232]
20:32:05     INFO -  #26: MessageLoop::RunHandler() [ipc/chromium/src/base/message_loop.cc:226]
20:32:05     INFO -  #27: MessageLoop::Run() [ipc/chromium/src/base/message_loop.cc:206]
20:32:05     INFO -  #28: nsBaseAppShell::Run() [widget/nsBaseAppShell.cpp:158]
20:32:05     INFO -  #29: nsAppShell::Run() [widget/windows/nsAppShell.cpp:264]
20:32:05     INFO -  #30: nsAppStartup::Run() [toolkit/components/startup/nsAppStartup.cpp:284]
20:32:05     INFO -  #31: XREMain::XRE_mainRun() [toolkit/xre/nsAppRunner.cpp:4419]
20:32:05     INFO -  #32: XREMain::XRE_main(int,char * * const,nsXREAppData const *) [toolkit/xre/nsAppRunner.cpp:4552]
20:32:05     INFO -  #33: XRE_main [toolkit/xre/nsAppRunner.cpp:4643]
20:32:06     INFO -  #34: do_main [browser/app/nsBrowserApp.cpp:281]
20:32:06     INFO -  #35: NS_internal_main(int,char * *,char * *) [browser/app/nsBrowserApp.cpp:414]
20:32:06     INFO -  #36: wmain [toolkit/xre/nsWindowsWMain.cpp:118]
20:32:06     INFO -  #37: __scrt_common_main_seh [f:/dd/vctools/crt/vcstartup/src/startup/exe_common.inl:253]
20:32:06     INFO -  #38: kernel32.dll + 0x17067
20:32:06     INFO -  TEST-INFO | Main app process: exit 1
20:32:06  WARNING -  TEST-UNEXPECTED-FAIL | dom/media/webspeech/synth/test/test_speech_simple.html | application terminated with exit code 1
20:32:06     INFO -  runtests.py | Application ran for: 0:00:43.486000
20:32:06     INFO -  zombiecheck | Reading PID log: c:\docume~1\cltbld~1.t-x\locals~1\temp\tmpq8pe53pidlog
20:32:06     INFO -  mozcrash Copy/paste: C:\slave\test\build\win32-minidump_stackwalk.exe c:\docume~1\cltbld~1.t-x\locals~1\temp\tmpk25cfi.mozrunner\minidumps\ed66808f-d63d-46fd-8db6-26e009e22032.dmp C:\slave\test\build\symbols
20:32:19     INFO -  mozcrash Saved minidump as C:\slave\test\build\blobber_upload_dir\ed66808f-d63d-46fd-8db6-26e009e22032.dmp
20:32:19     INFO -  mozcrash Saved app info as C:\slave\test\build\blobber_upload_dir\ed66808f-d63d-46fd-8db6-26e009e22032.extra
20:32:19  WARNING -  PROCESS-CRASH | dom/media/webspeech/synth/test/test_speech_simple.html | application crashed [@ RefPtr<mozilla::dom::SpeechSynthesisUtterance>::operator->()]
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1300016
You need to log in before you can comment on or make changes to this bug.