Composed message lost when used improper code page

VERIFIED DUPLICATE of bug 106301

Status

--
critical
VERIFIED DUPLICATE of bug 106301
17 years ago
10 years ago

People

(Reporter: jiri.kaderavek, Assigned: bugzilla)

Tracking

({dataloss})

Trunk
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

If you compose message contained characters not included in current character
coding (it may be when replying another message), then after pressing SEND
button you can see dialog message about this fact " ... Some characters may not
be correctly displayed ... bla bla bla ". When you cancel the send request you
are back in the message composition. But in this moment when you want to close
the composition window, another dialog appears 
---
" Mail is currently in the process of sending a message. Would you like to wait
until the message has been sent before quiting or quit now? ........ WAIT or
QUIT ". 
---
If you select quit the composed message the message is definitively lost. I
think, the state of the message after closing the first dialog isn't "send in
progress ...", because you've canceled the send request. It looks that the bad
state is responsible for NOT SHOWING THE "SAVE MESSAGE" DIALOG (you have not
chance to save it in Drafts folder) and the data are lost :-(


Reproducible: Always
Steps to Reproduce:
1. compose message in CP 8859-1 with some non-latin characters
2. press send and cancel send request after warning appears
3. close the compose window and press quit after warning appears
4. message lost!

Actual Results:  Composed message is lost.

Expected Results:  Show the "SAVE MESSAGE" dialog.

Updated

17 years ago
Severity: major → critical
Keywords: dataloss

Updated

16 years ago
Summary: Composed message lost when used inproper code page → Composed message lost when used improper code page

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 106301 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.