[perf] ProgIDToCLSID hash key too small

VERIFIED DUPLICATE of bug 12296

Status

()

Core
XPCOM
P3
normal
VERIFIED DUPLICATE of bug 12296
19 years ago
10 years ago

People

(Reporter: Chris Waterson, Assigned: shaver)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
The nsStringKey uses a vanilla nsAutoString, which will spill to the heap for
just about every ProgID known to man.
(Reporter)

Comment 1

19 years ago
Created attachment 1505 [details]
relevant info from quantify output
(Reporter)

Comment 2

19 years ago
FWIW, in the latest traces, ProgIDToCLSID was taking about ~1% of the time, and
was dominated (>70%) by nsAutoString and locking in the hashtable. (See also
Bug 13009.)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
*** This bug has been marked as a duplicate of 12296 ***

Comment 4

19 years ago
cleaning up: VERIFY duplicate
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XPCOM Registry → XPCOM
QA Contact: dp → xpcom
You need to log in before you can comment on or make changes to this bug.