Scrolling by finger does not work in presentation mode of pdf page

RESOLVED FIXED in Firefox 52

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Abe_LV, Assigned: kats)

Tracking

51 Branch
Firefox 52
All
Windows
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 unaffected, firefox52 fixed)

Details

(Whiteboard: [pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7653)

(Reporter)

Description

2 years ago
[Tested Platform] 
Asus laptop (touch enabled)

Build ID  20160906030431
User Agent  Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

[Pre-Requisites] 
about:config settings:
javascript.options.asyncstack; false
browser.tabs.remote.force-enable; true
layers.async-pan-zoom.enabled; true 

about:support info
Multiprocess Windows 1/1 (Enabled by user)
about:support Asynchronous Pan/Zoom wheel input enabled; touch input enabled

Steps to Reproduce

1. Go to https://www.irs.gov/pub/irs-pdf/fw4.pdf
2. From the top-right of the pdf page, tab "Switch to Presentation Mode".
3. Scroll to next page and then first page by swiping with finger.

Actual Result

Scrolling by finger does not work in presentation mode of the pdf page

Expected Result

Scrolling by finger should work in Presentation mode.

Note:
It is not e10s specific.
(Reporter)

Comment 1

2 years ago
Correction to the Step-2:
2. From the top-right of the pdf page, tap "Switch to Presentation Mode" by finger.
Flags: needinfo?(bugmail)
This needs to be implemented in pdf.js. It looks like in presentation mode they don't do "continuous" scrolling, only page-by-page scrolling. Presumably they can map touch swipes to page scrolling, or something. The code in browser/extensions/pdfjs/content/web/viewer.js already looks like it handles keyboard/mouse/wheel input so touch should be handled there as well.
Blocks: 1244402
Component: Panning and Zooming → PDF Viewer
Flags: needinfo?(bugmail)
Product: Core → Firefox
:bdahl, what is the process for making changes to viewer.js? Do the changes have to go upstream (if so, to which repository) or can I write patches against the copy in m-c?
status-firefox51: affected → unaffected
status-firefox52: --- → affected
Flags: needinfo?(bdahl)
Upstream at https://github.com/mozilla/pdf.js would be ideal.
Flags: needinfo?(bdahl)
Assignee: nobody → bugmail

Updated

2 years ago
Whiteboard: [pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/7653
Depends on: 1306522
Fixed in m-c by bug 1306522.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox52: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
(Reporter)

Comment 7

2 years ago
Verified as fixed. Scrolling by finger works fine in pdf Presentation mode.

--
Version  52.0a1
Build ID  20161003030438
Update Channel  nightly
User Agent  Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
You need to log in before you can comment on or make changes to this bug.