remove stlport support from the build system and stlport code

RESOLVED FIXED in Firefox 52

Status

defect
RESOLVED FIXED
3 years ago
Last year

People

(Reporter: froydnj, Assigned: froydnj)

Tracking

unspecified
mozilla52
Dependency tree / graph

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(1 attachment)

We can no longer build with STLport now that we require a
C++11-compliant standard library, so we might as well get rid of all the
support for it.
If we want to rename STLPORT_LIBS et al, that should be a followup.
Attachment #8788919 - Flags: review?(mh+mozilla)
Comment on attachment 8788919 [details] [diff] [review]
remove stlport support from the build system and stlport code

Review of attachment 8788919 [details] [diff] [review]:
-----------------------------------------------------------------

r+ without the dom changes.

::: build/autoconf/android.m4
@@ -133,5 @@
>              ;;
> -        mozstlport)
> -            # We don't need to set STLPORT_LIBS, because the build system will
> -            # take care of linking in our home-built stlport where it is needed.
> -            STLPORT_CPPFLAGS="-isystem $_topsrcdir/build/stlport/stlport -isystem $_topsrcdir/build/stlport/overrides -isystem $android_ndk/sources/cxx-stl/system/include"

It's funny how history goes, and you end up with STLPORT_* variables and not supporting stlport :)

::: build/moz.build
@@ -17,5 @@
>  
> -if CONFIG['OS_TARGET'] == 'Android' and CONFIG['MOZ_ANDROID_CXX_STL'] == 'mozstlport':
> -    DIRS += ['stlport']
> -    if CONFIG['ENABLE_INTL_API']:
> -        DIRS += ['gabi++']

You can remove the gabi++ directory too.

::: dom/base/test/browser_use_counters.js
@@ +73,5 @@
>                                   "PROPERTY_FILL", false);
>  
>    // Check that using a property B that is an alias for property A only
>    // increments the use counter for property B.
> +  /*

what is this? Same question for the other changes under dom/
Attachment #8788919 - Flags: review?(mh+mozilla) → review+
Duplicate of this bug: 1229391
Pushed by nfroyd@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b479d0f6193b
remove stlport support from the build system and stlport code; r=glandium
https://hg.mozilla.org/mozilla-central/rev/b479d0f6193b
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Blocks: 1376488
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.