Add mochitest-plain code coverage collection task to linux64-ccov.

RESOLVED FIXED in Firefox 52

Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: sparky, Assigned: cody_tran95)

Tracking

(Blocks 1 bug)

unspecified
mozilla52
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

3 years ago
We need to be able to gather code coverage for mochitest-plain through a test on taskcluster. What is needed to be done will be similar to how it is done for the "mochitest-browser-chrome-ccov" test which uses the "--code-coverage" flag.
Reporter

Updated

3 years ago
Blocks: 1301170
Depends on: 1301221
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Updated

3 years ago
Assignee: nobody → cody_tran95
Comment hidden (mozreview-request)

Comment 2

3 years ago
mozreview-review
Comment on attachment 8805430 [details]
Bug 1301223 - Enabled code coverage for mochitest-plain.

https://reviewboard.mozilla.org/r/89160/#review88414

this is clean and simple.  I assume e10s doesn't work at all?  I know there are concerns about the multi process data, it would be good to reference that where possible.
Attachment #8805430 - Flags: review?(jmaher) → review+
Reporter

Comment 3

3 years ago
mozreview-review
Comment on attachment 8805430 [details]
Bug 1301223 - Enabled code coverage for mochitest-plain.

https://reviewboard.mozilla.org/r/89160/#review88444

Nice work, there's only Joels comment to take care of.
Attachment #8805430 - Flags: review?(gmierz2) → review+
basically I would like to know why we are not doing this for e10s- if that is in the future, no worries; if there is a known reason- I would like it to be documented at least in the bug here.
Reporter

Comment 5

3 years ago
There is no reason that I can think of, I've accidentally enabled e10s mode once but both versions were bugged anyway. But I'm pretty sure that we just restricted it to no e10s to make things simple for the time being in case it introduced more problems. So it is in the future plans in that case and I think we could start trying it soon.
any concerns with moving forward with this then?
Reporter

Comment 7

3 years ago
GCOV is supposed to be multi-process safe, and there are differing opinions on how well it works with multi-threading. So because e10s is multi-process, I don't think we will have any problems during the tests. If all the tests run correctly, I'm curious to see what the differences are between the two versions. I'm thinking the e10s mode could have a larger chance of messing with some data so some analysis would be necessary to check the differences.
Reporter

Comment 8

3 years ago
Here's a treeherder link to a browser-chrome run in e10s mode:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=29d1a0f043ed2cf620da201ef9d95f5ff093b60c

It worked without any extra changes or problems (aside from the data itself, which should be analyzed).
let me land this and please file bugs to collect coverage on e10s modes.

Comment 10

3 years ago
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/27157986b0be
Enabled code coverage for mochitest-plain. r=gmierz2+560562,jmaher

Comment 11

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/27157986b0be
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Reporter

Updated

3 years ago
Duplicate of this bug: 1301221
Assignee

Comment 13

3 years ago
After looking through everything above, I think I'll continue enabling ccov for the test suites here:

https://bugzilla.mozilla.org/show_bug.cgi?id=1314305

I see that Greg also added bugs to enable e10s mode for bc, dt, and mochitest-plain. I will also get to those.
You need to log in before you can comment on or make changes to this bug.