Get rid of the artifact model

RESOLVED FIXED

Status

Tree Management
Treeherder
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: wlach, Assigned: wlach)

Tracking

Details

Attachments

(2 attachments)

After we've gotten rid of the last of the job artifacts, we should just get rid of the artifact model and replace it with a set of functions that do the things we need.
Depends on: 1303036
Blocks: 1178641
Duplicate of this bug: 1190900
Depends on: 1313779
Created attachment 8805713 [details] [review]
[treeherder] wlach:1301477 > mozilla:master
Comment on attachment 8805713 [details] [review]
[treeherder] wlach:1301477 > mozilla:master

This removes the datasource parts of the artifacts model, though the abstraction is still around. I'm in a bit of a rush to finish up the ds removal refactoring and move on to other things, so I might leave that last bit of cleanup to later.
Attachment #8805713 - Flags: review?(james)
Assignee: nobody → wlachance
Attachment #8805713 - Flags: review?(james) → review+

Comment 4

a year ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/129adcfab3a5d5b353d4476b0422a55b33c27e34
Bug 1301477 - Disable external facing artifact endpoints and API's (#1965)

* Can no longer store raw artifacts (anything treeherder doesn't understand
  is ignored)
* Attempting to retrieve an artifact now returns a 405 (not allowed)
Created attachment 8816510 [details] [review]
[treeherder] wlach:1301477-followup > mozilla:master
Comment on attachment 8816510 [details] [review]
[treeherder] wlach:1301477-followup > mozilla:master

This does away with the remainder of the artifacts model.
Attachment #8816510 - Flags: review?(james)
Comment on attachment 8816510 [details] [review]
[treeherder] wlach:1301477-followup > mozilla:master

Cam, could you take a look at this since James is going to be away for the rest of the year? It should be a relatively fast review (there are no functional changes).
Attachment #8816510 - Flags: review?(james) → review?(cdawson)
Attachment #8816510 - Flags: review?(cdawson) → review+

Comment 8

a year ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/0f10dff26aa922259a16e0f1dffb0ea15a23ac94
Bug 1301477 - Convert artifact model into a set of etl methods (#2013)
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.