Move away from the multi database architecture & use the Django ORM

RESOLVED FIXED

Status

Tree Management
Treeherder
P2
normal
RESOLVED FIXED
3 years ago
a year ago

People

(Reporter: mdoglio, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

3 years ago
We have recently talked about moving to a more standard database architecture, with a unified database containing both reference and job data. This includes:
- create orm classes for every db table.
- adapt the api to use the new unified db schema.
- convert all the JobsModel methods into a orm counterpart, potentially switching to raw sql where necessary.

Updated

3 years ago
Blocks: 1178227
(Reporter)

Comment 1

3 years ago
After some coding on this I still think it's a good idea but we need to tackle the problem in a more incremental way. I'll mark some bugs as blockers to keep track of the progress on this.
(Reporter)

Updated

3 years ago

Updated

3 years ago
Depends on: 1182455

Updated

3 years ago
Summary: investigate what it would take to move away from the multi database architecture → Move away from the multi database architecture & use the Django ORM

Updated

3 years ago
Priority: -- → P2

Updated

3 years ago
Duplicate of this bug: 1096970

Updated

3 years ago
Depends on: 1192976

Updated

3 years ago
Depends on: 1196764
No longer depends on: 1218537

Updated

2 years ago
Blocks: 1312007
Hi wlach, what is your current timeline for this?
(In reply to Armen Zambrano [:armenzg] (EDT/UTC-4) from comment #3)
> Hi wlach, what is your current timeline for this?

I am hoping to have this mostly finished (pending reviews) within ~1 week. The largest piece of work is bug 1306674.
treeherder no longer uses datasource in any way \o/
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Duplicate of this bug: 1312007

Updated

a year ago
Blocks: 1330479
You need to log in before you can comment on or make changes to this bug.