TEST-UNEXPECTED-TIMEOUT | netwerk/test/unit/test_http2.js | Test timed out (Linux+Mac)

RESOLVED FIXED in Thunderbird 51.0

Status

Thunderbird
General
RESOLVED FIXED
8 months ago
7 months ago

People

(Reporter: Jorg K (GMT+2), Assigned: Jorg K (GMT+2))

Tracking

({intermittent-failure})

Trunk
Thunderbird 51.0
intermittent-failure

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 months ago
First seen Sat Sep 10, 2016, 12:02:37

https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=bac458bd851b19f5b665b38d761834a9e7ce99ed&selectedJob=45831

TEST-UNEXPECTED-TIMEOUT | netwerk/test/unit/test_http2.js | Test timed out
TEST-UNEXPECTED-FAIL | Received SIGINT (control-C), so stopped run. (Use --keep-going to keep running tests after killing one with SIGINT)

This seems new and not bug 1092261 as suggested by Treeherder.

Seems to be caused by bug 1301117.

Patrick, any idea why that test would now be failing in a Thunderbird context. We only see the failure on Linux and Mac.
Flags: needinfo?(mcmanus)

Comment 1

8 months ago
Try porting the package-manifest changes from https://hg.mozilla.org/mozilla-central/rev/7078c20114e2.
Flags: needinfo?(mcmanus)
(Assignee)

Comment 2

8 months ago
Created attachment 8790039 [details] [diff] [review]
1301885.patch
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #8790039 - Flags: review?(aleth)
(Assignee)

Comment 3

7 months ago
To make the review easier, here's a try run to see whether the problem is really fixed:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=f55ffa88365a
(Assignee)

Comment 4

7 months ago
That worked, the failure is gone:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=f55ffa88365a6df00d98e92dafd501523044bf11&selectedJob=21362

Comment 5

7 months ago
Comment on attachment 8790039 [details] [diff] [review]
1301885.patch

Review of attachment 8790039 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #8790039 - Flags: review?(aleth) → review+
(Assignee)

Comment 6

7 months ago
https://hg.mozilla.org/comm-central/rev/9252289a33d6
Status: ASSIGNED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 51.0
You need to log in before you can comment on or make changes to this bug.