Report content backend to telemetry

RESOLVED FIXED in Firefox 51

Status

()

Core
Graphics
RESOLVED FIXED
9 months ago
8 months ago

People

(Reporter: mchang, Assigned: mchang)

Tracking

unspecified
mozilla51
Points:
---

Firefox Tracking Flags

(firefox51 fixed)

Details

(Whiteboard: gfx-noted)

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Updated

9 months ago
Whiteboard: gfx-noted
(Assignee)

Comment 1

9 months ago
Created attachment 8790458 [details] [diff] [review]
Report content backend to telemetry

Try - https://treeherder.mozilla.org/#/jobs?repo=try&revision=cbf05de1506e
Attachment #8790458 - Flags: review?(dvander)
Comment on attachment 8790458 [details] [diff] [review]
Report content backend to telemetry

Review of attachment 8790458 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine but since GetContentBackend doesn't depend on Windows, can we move it to GfxInfoBase?

Note: you'll probably fail a unit test somewhere in toolkit since we test the fields of the environment string. But it's easy to fix when you get it.
Attachment #8790458 - Flags: review?(dvander) → review+
(Assignee)

Comment 3

9 months ago
(In reply to David Anderson [:dvander] from comment #2)
> Comment on attachment 8790458 [details] [diff] [review]
> Report content backend to telemetry
> 
> Review of attachment 8790458 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Looks fine but since GetContentBackend doesn't depend on Windows, can we
> move it to GfxInfoBase?

Fixed.

> 
> Note: you'll probably fail a unit test somewhere in toolkit since we test
> the fields of the environment string. But it's easy to fix when you get it.

Try looks ok, I didn't see a test fail - https://treeherder.mozilla.org/#/jobs?repo=try&revision=5de7915fdf3d

Comment 4

9 months ago
Pushed by mchang@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/682489fca27b
Report content backend to telemetry. r=dvander

Comment 5

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/682489fca27b
Status: NEW → RESOLVED
Last Resolved: 9 months ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla51

Comment 6

9 months ago
This patch did a performance improvement in talos, thanks.

Improvements:

 11%  sessionrestore_no_auto_restore linux64 opt       1254.92 -> 1113.08
 11%  sessionrestore linux64 opt                       1198.33 -> 1063.17
  3%  sessionrestore osx-10-10 opt                     1060.17 -> 1023.5
  3%  sessionrestore_no_auto_restore osx-10-10 opt     1100.62 -> 1066

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=3108
There's no way this patch had performance impact. It's diagnostic.
(Assignee)

Comment 8

8 months ago
(In reply to David Anderson [:dvander] from comment #7)
> There's no way this patch had performance impact. It's diagnostic.

I concur, this talos improvement makes no sense..

Comment 9

8 months ago
I am also confused by this, but it does show up with a few retriggers as the root cause very clearly.
See Also: → bug 1302225
Blocks: 1007702
You need to log in before you can comment on or make changes to this bug.