Cut/Copy items are enabled in context menu even if there is no selection

RESOLVED DUPLICATE of bug 1178047

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 1178047
2 years ago
2 years ago

People

(Reporter: Honza, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Clipboard menu actions: Cut & Copy are enabled in the context menu even if there is no selection.

STR:
1) Load google.com
2) Make sure the input box is empty
3) Right click on the input box
4) Cut and Copy menu items are enabled -> BUG

Honza
See bug 1271897 comment 5 and onward.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1271897

Comment 2

2 years ago
Bug 1271897 basically describes that UI moved from a good point to another, completely illogical point
It suggests several ways to fix it. And also it's not finished/not the only thing that was broken.
To understand it, read some comments (e.g. user story) that were written NOT by Mozilla developers, because they never admit they implemented something illogical / broken by design.

Bug 1178047 asks exactly to bring back the good old behavior.
Duplicate of bug: 1178047

Updated

2 years ago
See Also: → bug 1328029
You need to log in before you can comment on or make changes to this bug.